3

Ubuntu 19.10 doesn't automatically connect to saved hidden wireless networks. I have each time to go to Settings > Wi-Fi Settings > Connect to Hidden Network to get connected to Wi-Fi.

Is there a way to make Ubuntu connect to a saved, available hidden network automatically in the same way as visible networks ?

7
  • My version of Ubuntu is 19.10 – Lichtt Apr 26 '20 at 14:50
  • Is "Connect Automatically" enabled in the wi-fi connection profile? – heynnema Apr 26 '20 at 15:56
  • Yes, it is. I even upgraded to 20.04 LTS and I still have the same issue. – Lichtt Apr 26 '20 at 22:23
  • From the help pages... "You may have to check the settings of the wireless access point or router to see what the network name is. If you don’t have the network name (SSID), you can use the BSSID (Basic Service Set Identifier, the access point’s MAC address), which looks something like 02:00:01:02:03:04 and can usually be found on the underside of the access point.". So, try using the BSSID instead of the SSID. Use nm-connection-editor. – heynnema Apr 26 '20 at 23:01
  • See askubuntu.com/questions/9014/… – heynnema Apr 26 '20 at 23:06
2

For me like @heynnema said using the BSSID worked for me.

I used the following click path to change the BSSID:

  • on the right top corner, the down right arrow
  • Then onto WiFi
  • Wireless network settings
  • Connect to hidden radio networks
  • entered / selected the hidden radio network
  • then on the gear in the row of the hidden network
  • onto identity
  • and there is a dropdown for BSSID

If you have an access point that has multiple GHz channels, you can also have multiple BSSIDs here. Depending on what you select, the corresponding channel is used.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.