11

Prior to the upgrade my sound was working, now it's not. I only have one output "dummy output".

My computer has the snd_hda_intel sound card and I've tried all the steps outlined here

Any assistance would be appreciated, would like to avoid a reinstall.

System info, Thinkpad T460s, Kubuntu 20.04.

output of lsmod | grep snd_hda_intel

snd_hda_intel          53248  3
snd_intel_dspcfg       24576  1 snd_hda_intel
snd_hda_codec         131072  4 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec_realtek
snd_hda_core           90112  5 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek
snd_pcm               106496  5 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_hda_core
snd                    90112  17 snd_hda_codec_generic,snd_seq,snd_seq_device,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek,snd_timer,thinkpad_acpi,snd_pcm,snd_rawmidi

output of lspci -nnk | grep -A3 Audio

00:1f.3 Audio device [0403]: Intel Corporation Sunrise Point-LP HD Audio [8086:9d70] (rev 21)
        Subsystem: Lenovo Sunrise Point-LP HD Audio [17aa:2233]
        Kernel driver in use: snd_hda_intel
        Kernel modules: snd_hda_intel
2
15

after lurking some other threads I was able to fix it by running

sudo apt purge timidity-daemon

The alsa reloads and config changes where of no use.

1
  • 2
    It worked! I still wonder why, though. What's wrong with Timidity-daemon? Aug 18 '20 at 13:33

Not the answer you're looking for? Browse other questions tagged or ask your own question.