1

I am new here. I just bought new laptop , HP Envy x360 13-ar0022nn AMD Ryzen 5 3500U ,with 8 /gb RAM.

Only problem , I have Bang & Olufsen, quad speakers, but sound comming only from bottom, so 2 speakers..

Is it possible to fix that ?

Ubuntu 20.04 LTS x86_64 and Kernel: 5.4.0-26-generic

2 Answers 2

1

Here is my settings on the same computer (model slightly different, but the same processor, also envy x360 13).

Open terminal, then type the following:

sudo apt-get install alsa-tools-gui

After installation finished, do the following:

sudo hdajackretask

You will enter the graphical interface of Jack Retasking for HDA Intel sound cards. It works the same even if we are using AMD processors.

Check the box: show unconnected

Find the 0x14 pin, check the override button, and set it with the option "Internal speaker"

Also find the 0x17 pin, check the override button, and set it with the option "Internal speaker (Back)"

Then click the button Install boot override

Reboot to see changes.

It should work, however, the volume would seem bugged, but it is in the settings menu.

In the AnalogSurround 4.0 Output, move the Fade slider to the right until you think the volume goes with how you feel.

There is a reset bug (unconfirmed), but is surely out of the "enable front audio thing"

1
  • I managed to enable the speakers, but there's an issue with volume control. The rear speakers are either muted or playing with constant volume (for any volume setting other than 0). This only happens if the volume is set on the output in pavucontrol. Adjusting volume on a EQ seems to work, though.
    – Jacajack
    Aug 6, 2020 at 20:13
0

William's answer worked for me perfectly as far as enabling speakers is concerned. As he mentioned, though, there are some issues with volume control. At least in my case, the system volume level only affected front speakers while the rear were always playing with constant volume (or were muted).

I managed to solve that problem by adding:

[Element Master]
switch = mute
volume = ignore

above the line containing [Element PCM] in the file /usr/share/pulseaudio/alsa-mixer/paths/analog-output.conf.common. Now the volume control affects all channels equally.

Related links:

1
  • I had the switch option set correctly, however, volume was set to merge (which did not merge), and setting it to ignore also didn't work. I can set the volume level manually through alsamixer, but it's quite annoying.
    – fufs
    Dec 5, 2020 at 10:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.