1

I've installed the last version of Ubuntu (20.04) and I have an issue with my fan : even if my CPU temp is low my fan is working at max speed :(

I use sensors to check temp and fan speed :

# sensors
coretemp-isa-0000
Adapter: ISA adapter
Package id 0:  +35.0°C  (high = +100.0°C, crit = +100.0°C)
Core 0:        +32.0°C  (high = +100.0°C, crit = +100.0°C)
Core 1:        +34.0°C  (high = +100.0°C, crit = +100.0°C)
Core 2:        +34.0°C  (high = +100.0°C, crit = +100.0°C)
Core 3:        +32.0°C  (high = +100.0°C, crit = +100.0°C)
Core 4:        +32.0°C  (high = +100.0°C, crit = +100.0°C)
Core 5:        +33.0°C  (high = +100.0°C, crit = +100.0°C)

dell_smm-virtual-0
Adapter: Virtual device
fan1:        4975 RPM
fan2:        5132 RPM

BAT0-acpi-0
Adapter: ACPI interface
in0:          10.78 V  
curr1:         1.34 A  

iwlwifi_1-virtual-0
Adapter: Virtual device
temp1:        +32.0°C  

pch_cannonlake-virtual-0
Adapter: Virtual device
temp1:        +35.0°C  

acpitz-acpi-0
Adapter: ACPI interface
temp1:        +25.0°C  (crit = +107.0°C)

I've tryed to reduce speed manualy using i8k :

# i8kfan 1 1
2 2

I can hear the fan slowing down and then speeding up again (1 or 2 seconds after).

Can any one help me ?

2 Answers 2

0

The same issue here with a fresh installed Ubuntu 20.04 but on an Asus Laptop.

I thought that it's a non-selected driver issue when I go to Software & Updates -> Additional Drivers. It was marked as continue using a manually installed driver and the others were disabled.

Than I followed this https://askubuntu.com/a/1032365/829928 instructions to select a driver:

$ ubuntu-drivers devices    # list drivers that are available to be installed from the default Ubuntu repositories
$ sudo apt install [xserver-xorg-video-nouveau]

I installed xserver-xorg-video-nouveau for my system then rebooting solved the fan speed issue.

Maybe this method can work for your system as well.

Edit: The issue occurred again within a few days. Trying $ ubuntu-drivers list then $ sudo apt install nvidia-driver-440 didn't work as well.

0

I had the similar issue on my DELL Inspiron 7591 running Ubuntu 18.04 LTS. So I believe it should work on 20.04 as well.

What you did was correct using i8kfan but it stops quickly because the BIOS will take over the control of the fans.

So, I managed a workaround for this situation (thanks to the GitHub repo https://github.com/TomFreudenberg/dell-bios-fan-control) by overriding the BIOS control.

  1. Clone the repo to your machine.
  2. Run the Makefile (just type make in terminal in the directory of Makefile).
  3. This will create an executable file dell-bios-fan-control.
  4. You can use this file as shown in their GitHub Repo README (You need to pass 0 as argument to disable the BIOS control & then try running i8kfan like you did earlier).

This worked for me, I can't ensure the same to all cases.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.