14

I saw an OMG Ubuntu article about Ubuntu offering fingerprint support. But I do not see any such option in 20.04.

Is it really possible to login using fingerprint scan in 20.04? If yes, how?

8
  • 1
    Take a look at frpintd, but keep in mind you'll still need a password to unlock your keyring, so not as useful as you might hope.
    – ubfan1
    Apr 26, 2020 at 4:06
  • 1
    Go to users -> Automatic login, and that should display the option for fingerprint login. I can't get mine to work, but if it does work, that's where it'll be
    – snapcrack
    Apr 26, 2020 at 4:08
  • It works without auto login under user settings. Thanks.
    – user227495
    Apr 26, 2020 at 4:31
  • OP, I have the same question. I have a ThinkPad X1 Carbon with a fingerprint reader that is recognized by 20.04 I have "enrolled" my fingerprint via Settings > Users and "Fingerprint Login" there is marked "Enabled". But on the login screen there is no visible option to activate fingerprint scanning, and simply trying it does nothing (i.e. password still required). I'm wondering if this is DM related. I upgraded from 19.04 after long use and may not have the stock DM active. May 8, 2020 at 18:11
  • 1
    @CpILL I didn't install any extra drivers, it "just worked" starting with 20.04 for me. Light might not have happened until after I registered a print. 2nd gen X1 Carbon FWIW. Dec 15, 2020 at 1:42

2 Answers 2

19

What you need to do is to enable PAM Fingerprint authentication method.

  1. Issue sudo pam-auth-update
  2. Select Fingerprint authentication
  3. Press Spacebar
  4. Hit Enter
7
  • This answer solved it for me, it should be the accepted answer.
    – gionni
    Jul 5, 2020 at 15:00
  • It probably depends on the HW support installed. Did not work for me on my out of the box Dell XPS 15, after I fresh installed ubuntu 20.04 Jul 14, 2020 at 2:27
  • works for me but after rebooting its disabled again (but showing up ad enabled) Sep 11, 2020 at 12:54
  • 1
    No work for me on 20.04 on a Lenovo Thinkpad Carbon X1 :(
    – CpILL
    Dec 10, 2020 at 4:09
  • Some laptops manufacturers have no drivers yet for fingerprint working on linux distributions Jan 13, 2021 at 13:37
0

I partially solved it by upgrading firmware using

fwupdmgr upgrade

Now I get the option of login using fingerprint in settings->users. And I can get my fingerprints scanned there.

But I still can't really login with it. Nothing happens when I scan my fingers when the computer is locked.

1
  • Just figured it all out by following the answer above. Nov 19, 2020 at 15:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.