32

I've installed Ubuntu 20.04 and bluetooth is not working for me. But it works in a live session if I boot that from USB. Can anyone help me please?

systemctl | grep -i blue output:

  sys-devices-pci0000:00-0000:00:14.0-usb1-1\x2d14-1\x2d14:1.0-bluetooth-hci0.device        loaded active     plugged   /sys/devices/pci0000:00/0000:00:14.0/usb1/1-14/1-14:1.0/bluetooth/hci0     
  sys-subsystem-bluetooth-devices-hci0.device                                               loaded active     plugged   /sys/subsystem/bluetooth/devices/hci0                                      
  bluetooth.service                                                                         loaded active     running   Bluetooth service                                                          
  bluetooth.target                                                                          loaded active     active    Bluetooth    

dmesg | grep -i blue output:

[    2.309059] Bluetooth: Core ver 2.22
[    2.309071] Bluetooth: HCI device and connection manager initialized
[    2.309073] Bluetooth: HCI socket layer initialized
[    2.309074] Bluetooth: L2CAP socket layer initialized
[    2.309076] Bluetooth: SCO socket layer initialized
[    3.413708] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[    3.413710] Bluetooth: BNEP filters: protocol multicast
[    3.413713] Bluetooth: BNEP socket layer initialized
[    4.342171] Bluetooth: hci0: command 0xfc05 tx timeout
[    4.342173] Bluetooth: hci0: Reading Intel version information failed (-110)
[  193.048690] Bluetooth: hci0: command 0xfc05 tx timeout
[  193.048749] Bluetooth: hci0: Reading Intel version information failed (-110)

lspci output:

00:00.0 Host bridge: Intel Corporation 8th Gen Core Processor Host Bridge/DRAM Registers (rev 07)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor PCIe Controller (x16) (rev 07)
00:02.0 VGA compatible controller: Intel Corporation UHD Graphics 630 (Mobile)
00:04.0 Signal processing controller: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Thermal Subsystem (rev 07)
00:08.0 System peripheral: Intel Corporation Xeon E3-1200 v5/v6 / E3-1500 v5 / 6th/7th/8th Gen Core Processor Gaussian Mixture Model
00:12.0 Signal processing controller: Intel Corporation Cannon Lake PCH Thermal Controller (rev 10)
00:14.0 USB controller: Intel Corporation Cannon Lake PCH USB 3.1 xHCI Host Controller (rev 10)
00:14.2 RAM memory: Intel Corporation Cannon Lake PCH Shared SRAM (rev 10)
00:14.3 Network controller: Intel Corporation Wireless-AC 9560 [Jefferson Peak] (rev 10)
00:15.0 Serial bus controller [0c80]: Intel Corporation Cannon Lake PCH Serial IO I2C Controller #0 (rev 10)
00:16.0 Communication controller: Intel Corporation Cannon Lake PCH HECI Controller (rev 10)
00:17.0 RAID bus controller: Intel Corporation 82801 Mobile SATA Controller [RAID mode] (rev 10)
00:1d.0 PCI bridge: Intel Corporation Cannon Lake PCH PCI Express Root Port #9 (rev f0)
00:1d.5 PCI bridge: Intel Corporation Cannon Lake PCH PCI Express Root Port #14 (rev f0)
00:1d.6 PCI bridge: Intel Corporation Cannon Lake PCH PCI Express Root Port #15 (rev f0)
00:1f.0 ISA bridge: Intel Corporation HM470 Chipset LPC/eSPI Controller (rev 10)
00:1f.3 Audio device: Intel Corporation Cannon Lake PCH cAVS (rev 10)
00:1f.4 SMBus: Intel Corporation Cannon Lake PCH SMBus Controller (rev 10)
00:1f.5 Serial bus controller [0c80]: Intel Corporation Cannon Lake PCH SPI Controller (rev 10)
01:00.0 VGA compatible controller: NVIDIA Corporation GP107M [GeForce GTX 1050 3 GB Max-Q] (rev a1)
01:00.1 Audio device: NVIDIA Corporation GP107GL High Definition Audio Controller (rev a1)
02:00.0 Non-Volatile memory controller: Phison Electronics Corporation Device 5008 (rev 01)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 16)
04:00.0 Unassigned class [ff00]: Alcor Micro AU6625 PCI-E Flash card reader controller

lspci -k -s 00:14.3 output:

00:14.3 Network controller: Intel Corporation Wireless-AC 9560 [Jefferson Peak] (rev 10)
    DeviceName: WLAN
    Subsystem: Intel Corporation Wireless-AC 9560 [Jefferson Peak]
    Kernel driver in use: iwlwifi
    Kernel modules: iwlwifi

bluetoothctl:

[bluetooth]# list
[bluetooth]# power on
No default controller available

rfkill list all output:

0: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

lsusb output:

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 002: ID 04f2:b627 Chicony Electronics Co., Ltd HP Wide Vision HD Camera
Bus 001 Device 003: ID 8087:0aaa Intel Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

14 Answers 14

30

I have the same problem with bluetooth with ubuntu 20.04, and fixed by this way

sudo apt install blueman

sudo add-apt-repository ppa:blaze/rtbth-dkms
sudo apt-get update
sudo apt-get install rtbth-dkms

sudo vim /etc/modules

Comment all and add this line

rtbth

Reboot and open

sudo blueman-manager

If still not work, try this

sudo rmmod btusb
sleep 1
sudo modprobe btusb

If still not work, try this

update /etc/default/grub with this value

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pci=nommconf pcie_aspm=off"

update grub

sudo update-grub

then reboot and enjoy your music

7
  • 2
    Merely removing rtusb and reinserting it worked for me. – Auspex May 17 '20 at 19:42
  • 3
    btw, this isn't a blueman issue, because it also happens in kubuntu which doesn't use blueman. – Auspex May 17 '20 at 20:58
  • 6
    I tried this solution on 20.04 and it didn't work for me. – alex Jul 3 '20 at 22:57
  • 1
    This worked great for me for ubuntu 20.04, I didn't have to reboot, worked to use my airpod pros with my ubuntu 20 installed on my macbook pro 16inch. – jamescampbell Jul 20 '20 at 21:59
  • 2
    @Nam Nguyen Can you please explain each step of the configuration process, what each command does and why each step is needed. I found that it works but only receives files on the admin account*(which is where I did the configs above) and *not receiving on my work (user) account. – Trunk Dec 4 '20 at 21:07
23

I experienced the same issue, after a hot boot switch from Windows to Ubuntu, Bluetooth failed to work. I followed the Ubuntu bug report here, and Bluetooth fully functions. Use the following commands:

  1. sudo rmmod btusb
  2. sudo modprobe btusb
3
  • 3
    Why isn't this at top of all? It works! – Sayan Dey Oct 20 '20 at 11:33
  • I used a combination of askubuntu.com/a/1238076/1108393 and this one and it started working again. – Luke Duncan Nov 14 '20 at 20:12
  • Dude thank you very much. This fixed my bluetooth. Probably will fail 'cause of this bug, but at least I don't have to reboot. – Noctis Jan 20 at 15:14
8

I also experienced this problem. For me, the error was related to python. The problem is with version 3.7. For me the following worked:

I uninstalled bluetooth:

sudo apt remove blueman

sudo apt autoremove

Then change your version of python to 3.6 or 3.8:

sudo update-alternatives --config python3

If this command does not work, you will need to run:

sudo update-alternatives --install /usr/bin/python3 python3 /usr/bin/python3.7 1

sudo update-alternatives --install /usr/bin/python3 python3 /usr/bin/python3.8 2

Then, re-run the command to change the python version.

To install bluetooth, it is necessary to have python-gi, for this, execute the command below:

sudo apt install python3-gi

After that, install the bluetooth again:

sudo apt install blueman -y && blueman-manager

Those were the steps I followed and it worked, but maybe just changing the version of python would have worked. When I try to go back to python 3.7, bluetooth stops working again. I don't know how to solve this, I just stopped using version 3.7.

Hope this helps.

4
  • 1
    Can you say how you diagnosed this as a Python issue, please? It would help others (me included) to establish whether your solution is applicable to them. – Paul Pepper Jun 5 '20 at 10:49
  • 2
    When I tried to reinstall bluetooth using python 3.7, the installation failed with an error message not finding the python-gi package. Even installing python-gi, the bluetooth installation still didn't work. When I switched to python 3.8, the installation worked normally. – Danilo Escudero Jun 6 '20 at 14:37
  • 1
    Im currently running Python 3.8.2. No luck here. It was working, and not it is not. – alex Jul 3 '20 at 22:57
  • FYI this worked for me, ty. I already had python 3. Bluetooth on my system was really flaky with my Kensington Expert Wireless TB until doing the reinstall outlined here. I did stop the service first with sudo /etc/init.d/bluetooth stop, not sure if that was relevant. Once this reinstall was completed, on re-boot I got the blueman-manager running with a nice little icon on the top right (was asked if I wanted this on the install). Using the manager, I was able to sort out my trackball problem and trust the paired device. I removed the other TB address (probably for dongle).Working nicely :) – Richard Logwood Feb 18 at 18:36
2

I had this same problem after updating Kubuntu to 20.04, tried reinstalling several times to no avail. Then I noticed that the bluetooth didn't fail (White LED) until I logged-in, after some testing it turned out that disabling "Enable bluetooth integration" inside bluetooth settings and reloading the driver with:

sudo pkill -2 rtbt
sudo rmmod rtbth
sudo modprobe rtbth

makes it work again, with the obvious caveat of not being able to send files to the computer, pairing devices and sending files to them do still work.

2

I had trouble pairing a XBOX ONE controller (which worked without any problems in 19.10). The solution was to disable bluetooth ERTM (https://bugs.launchpad.net/ubuntu/+source/gnome-control-center/+bug/1750146)

sudo su
echo 1 > /sys/module/bluetooth/parameters/disable_ertm 
2

I have a Mouse Logitech M535. Was working fine in 18.04. After upgrading to 20.04 started to have random issues. Works fine for around 10-15 secs and then disconnects. Only reconnects after a restart. I only have Ubuntu (not dual or Windows).

My solution was: How can I disable USB autosuspend on Ubuntu 18.04? Although the USB autosuspend is a feature designed to preserve battery life, its' 18.04 default is "enabled", whether or not the device Ubuntu is being installed on even has a battery.

Further, in order for autosuspend to be more help than harm, it appears that the USB device's driver needs to support autosuspend. Hence all the posts- yours' included- seeking to disable the "feature".

In 18.04 on my device, I scripted disabling autosuspend persistently in /etc/default/grub like so:

sed -i 's/GRUB_CMDLINE_LINUX_DEFAULT="/&usbcore.autosuspend=-1 /' /etc/default/grub

update-grub

systemctl reboot

The sed expression just prepends "usbcore.autosuspend=-1" with a trailing space after the initial quote mark to ensure it always matches whatever your particular GRUB_CMDLINE_LINUX_DEFAULT options look like.

If you execute cat /sys/module/usbcore/parameters/autosuspend after a reboot, you'll remark the "-1" preference (disabled) is retained.

2

I dual boot between Ubuntu 20.04 and Windows 7.

My problem was that bluetooth service would not start even though I turned it on in the bluetooth settings.

The previous comments did not work for me. Here is what did work:

To start the bluetooth service enter:

sudo /etc/init.d/bluetooth start

This will enable bluetooth during the session.

To make the bluetooth service start automatically when booting into Ubuntu enter:

sudo systemctl enable bluetooth
1

In my case, one poor connection with Spotify (I was in the other room) had disabled Bluetooth with no Bluetooth device on the settings menu or hcitool dev. None of the workarounds worked for me. I uninstalled Spotify and everything is fine.

1

I faced the same problem with my HP pavilion x360 (dual boot with windows 10). All I did was to log into windows 10 and update my bluetooth driver from HP website and then when I restarted the system to Ubuntu 20.04 my problem was fixed.

1

Just in case... My system is XP13/KUbuntu 20.04 recently upgraded from 18.04 and I had a "Receiving files failed".

Appears it was simply because the folder to receive the files had disappeared. Workaround was to recreate the folder.

enter image description here

1

Just a hint: In case that someone comes across the same issue.

I was not able to recognize the MK850 keyboard + mouse (neither ubuntu 18.04 nor 20.04)

I did install solaar in the messages unify was discovered. So I did remove the keyboard and mouse from the solaar (even though they were connected) and afterwards I did add the devices again and everything started working.

Hope this helps to anyone using this keyboard in Ubuntu.

0

I had the same problem in my hp laptop with LTS 20.04 what I did, and what did work was: 1. Go to settings in your LTS -> about -> find updates -> firmware updates, and patch the OS. if this does not works: - having a dual boot with another OS: Go to your other OS (I've made it with windows), you must to pair a Bluetooth device using the OS wizard, after that, go back to your Ubuntu and run:

sudo /etc/init.d/bluetooth status

check your status and that's it.

1
  • Going "to your other OS" should always work, whatever you do, because the problem is on resume from sleep, not on boot. Whenever you reboot Ubuntu, the bluetooth adapter will get properly loaded. – Auspex May 17 '20 at 21:00
0

After some researching I found this bug report. The bug reported by this link is similar to what happened to my system. This occurs when I do a hot reboot from Windows to Ubuntu and the solution that worked for me is to do a cold reboot whenever I use bluetooth device on Windows.

Redsandro (redsandro) wrote on 2020-04-17:

So I am inclined to believe that the Linux Bluetooth driver puts the Bluetooth hardware in a certain state that persists across hot reboots but doesn't affect the Windows driver from successfully interacting with the Bluetooth hardware.

I believe this to be a software bug where a certain state or signal from the Bluetooth hardware is misinterpreted by the Linux driver, causing it to stop working.

2
  • That can't possibly be the solution, since it happens whether or not you use Windows – Auspex May 17 '20 at 19:40
  • As noted here, I find the problem whenever I reboot vs. cold start. Doesn't matter if the last OS running was Windows or Linux, bluetooth is only detected after a complete shutdown and cold start – LenB Jan 1 at 17:19
0

It's a bug: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1859592

I work around this by cold booting, as in powering off from PC's source button (taking electricity off the mother board). Just shutting down / (re)starting and having the motherboard LEDs on didn't work.

Not the answer you're looking for? Browse other questions tagged or ask your own question.