0

Installing Ubuntu 20.04 on dual boot windows HP Envy consumer laptop. Got the error to disable RST. Consumer HP lap with insyde bios f.47 which does not allow "Advanced option" to disable RST and change to AHCI. Dont want to mod the BIOS. I disabled optane memory via Windows APP. but no luck. same laptop was running Ubuntu 18.04 without any issue. is there a way to bypass the RST check by Unbuntu installer. Thanks

  • 1
    No, sorry, Ubuntu cannot handle this. You need AHCI. – mook765 Apr 25 at 18:04
0

I have Win 10 and wanted to do the same. What I did was logged into BIOS and switched RAID ON to AHCI. Then I made sure and booted to the USB, and installed 20.04 to replace 18.04 (the first option). Reboot into your new install of Ubuntu (still in AHCI) and go to 'Drives'. Set your windows drive/partitions not to automatically mount on system startup. Then you can reboot, go into BIOS and switch back to RAID ON. Now windows will boot fine and so will Ubuntu. If you don't set your windows drives to NOT boot automatically in Ubuntu then with RAID ON Ubuntu will spend a minute at the spash screen trying to find the hidden drives. Works fine, just a little awkward that you can't just install 20.04 with RSK enabled.

| improve this answer | |
  • Thanks Paul, I dont have access to advanced options in the BIOS, hence unable to change to AHCI. its consumer HP Envy Laptop – Zee Apr 27 at 1:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.