11

I have recently updated to Ubuntu 20.04 and I am a bit fresh user for ubuntu. after installing postgresql 12 I ran sudo apt-get update it says

N: Skipping acquire of configured file 'main/binary-i386/Packages' as repository 'http://apt.postgresql.org/pub/repos/apt focal-pgdg InRelease' doesn't support architecture 'i386'

I have no idea how to solve this! can anybody help me solve this please? Thanks in advance!

1
  • 1
    This is not answered in the other question for me. – geneorama Dec 18 '20 at 19:04
18
+50

The definition for your apt.postgresql.org repo is defined in one of two possible places. Let's find it...

In terminal...

sudo grep -i postgresql /etc/apt/sources.list

or

sudo grep -i postgresql /etc/apt/sources.list.d/*.list

You'll get a hit on one of the above commands.

Let's edit the file...

sudo -H gedit /etc/apt/sources.list (ignore any warning messages)

or

sudo -H gedit /etc/apt/sources.list.d/found_filename.list (ignore any warning messages)

Find the line that starts with...

deb https://blah blah blah

And change it to...

deb [arch=amd64] https://blah blah blah

Save the file and quit the editor.

Now sudo apt-get update and sudo apt-get upgrade will run without the noise.

2
  • 3
    I had the same issue with qgis. Changing deb https://qgis.org/debian focal main to deb [arch=amd64] https://qgis.org/debian focal main solved my issue with "skipping acquire of configured file..." – geneorama Dec 18 '20 at 19:06
  • worked for me on Ubuntu 20.04 installing Postgres 13 using the following guide computingforgeeks.com/how-to-install-postgresql-13-on-ubuntu thanks! – Luke Belbina Feb 8 at 18:37

Not the answer you're looking for? Browse other questions tagged or ask your own question.