1

today I removed nordvpn and tried to install it again, I followed all steps that mentioned in the official website and still can't get it work.

sudo dpkg -i ./nordvpn-release_1.0.0_all.deb

sudo apt update

sudo apt install nordvpn

Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package nordvpn
4
  • There is no need to sudo apt install nordvpn. The first command installs it. Apr 25 '20 at 17:02
  • I used to official steps on their website and it works for me on Ubuntu 20.04.
    – mkkl
    Apr 25 '20 at 17:28
  • yeah, but the commend nordvpn still not found
    – user1072555
    Apr 25 '20 at 17:36
  • It is not found because you use the wrong command. Apr 25 '20 at 19:07
6

If you downloaded the .deb via a browser it should be in \home\<user name>\Downloads, cd to that location:

cd /path/
sudo dpkg -i <name of file>.deb

If it shows broken packages or missing dependancies follow on-screen instructions.

In response to below comments, seems like the .deb file just adds a repository but does not install the nordvpn package.So you need to run

sudo apt-get update
sudo apt-get install nordvpn

as well to actually install it which wasn't clear to me.

Check for these two lines for a successful addition when apt update is run:

Get: https://repo.nordvpn.com/deb/nordvpn/debian stable/main amd64 Packages [3,298 B]
Get: https://repo.nordvpn.com/deb/nordvpn/debian stable/main i386 Packages [3,298 B]

Seems like the .deb failed to add the contents to /etc/apt/sources.list.d/nordvpn.list, so here are they

deb [arch=amd64] http://repo.nordvpn.com/deb/nordvpn/debian stable main
deb [arch=i386 ] http://repo.nordvpn.com/deb/nordvpn/debian stable main 

Steps:

cd /etc/apt/sources.list.d/
sudo nano nordvpn.list

Add the above contents exactly as they are without any "#" at start or end in a blank line.

Runsudo apt update then and sudo apt install nordvpn

4
  • the last two lines didn't show up after running apt update
    – user1072555
    Apr 25 '20 at 17:33
  • 1
    Post cat /etc/apt/sources.list.d/nordvpn.list,please. Apr 25 '20 at 17:35
  • # # NordVPN releases, stable #
    – user1072555
    Apr 25 '20 at 17:37
  • 1
    seems empty, there's just a comment
    – user1072555
    Apr 25 '20 at 17:38
0

In my case, it needed to create a group named nordvpn.

(According to logs journalctl -xe. nordvpnd.socket: Failed to resolve group nordvpn: No such process).

sudo groupadd nordvpn

then start service:

sudo systemctl enable --now nordvpnd.service

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy