15

I am unable to adjust brightness levels through Gnome. I had the same issue with 18.04 but it was resolved there (honestly, I can't remember how).

lspci|grep VGA
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 18)

xrandr --output LVDS-1 --brightness 0.95
<-- this works through the terminal
excerpt from /etc/default/grub
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"

Thank you in advance.

2
  • Seeing a similar problem on an old MacBook Air 3,2 (with KDE Neon, NVidia drivers, Linux 5.4.0-54-generic). After upgrade to Ubuntu 20.04, brightness control keys stopped working. xrandr brightness works but lacks power management integration, is not convenient, and resets night color. grub command line is unchanged, so the kernel is suspect #1 now.
    – mak
    Nov 22 '20 at 19:54
  • Updating my kernel as to the latest oem kernel in this post worked for me
    – Nelly
    May 23 at 6:33

12 Answers 12

20

The xrandr solution didn't worked for me. I have installed brighness-controller and worked well.

sudo add-apt-repository ppa:apandada1/brightness-controller
sudo apt update
sudo apt install brightness-controller

UPDATED: After I have upgraded to Ubuntu 21, this issue has fixed completely. My laptop buttons of brightness control works normally. No needed additional configuration.

5
  • I just tried it, and it seems to work on Ubuntu 20.04. What I like about this solution is that the software is relatively fast to install and doesn't require a reboot.
    – Rmurphy
    Aug 8 at 12:34
  • Works for me. Not as ideal as having my Fn buttons working again, but saves me from going blind which is definitely something.
    – Gigi
    Aug 19 at 16:51
  • It does conflict with Night Color Control though...
    – Gigi
    Aug 19 at 16:59
  • not working for me. having gtx 1660 ti card.
    – arslion
    Aug 19 at 17:55
  • Not working for me on Lenovo Thinkpad X250.
    – blnks
    Oct 30 at 5:21
10

I am having similar issue. There is no screen brightness slider on system menu (the one below the volume). I know that there is a workaround using xrandr that goes like this:

xrandr -q | grep " connected"

The output looks like:

DP-1 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 477mm x 268mm
DP-3 connected primary 1920x1080+1920+0 (normal left inverted right x axis y axis) 477mm x 268mm

I am using a dual screen, so that is why I have 2 channels (DP-1 and DP-2). Then you can adjust the brightness by typing

xrandr --output DP-3 --brightness 0.8

Here, I am using 0.8 in monitor DP-3. Just do the same for the other monitor and we are all set.


However, I noticed that the screen brightness is oscillating and no solution that I found in the internet worked for me.

3
  • Is it harmfull to set --brightness 5 ?
    – 5hifaT
    Jan 6 at 9:58
  • No, it wouldn't be harmful, however, I don't think it would have the effect that you expect. Values larger than 1.0 produce weird colors on the screen (at least that is what happens on my screen). You can test different values yourself and choose the one you feel more comfortable with. Jan 7 at 11:18
  • recently i had a problm that my brightness becomes low then the normal one.So when i was setting it 100% i mean full brightness still it was low. So i have to make --brightness 5 and it's working fine.
    – 5hifaT
    Jan 7 at 11:38
3

I had the same problem, which was solved following this post: How to Fix Brightness Keys Not Working in Ubuntu. The solution is quite simple:

Edit file /etc/default/grub, set

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor acpi_osi=linux"

Save the file and update grub:

> sudo update-grub

Restart the computer and it worked.

The rational behind the operations, as the author explained, is as follows:

ACPI is a power interface management standard which is implemented in operating system kernels. By default Linux kernel uses an inbuilt driver for keyboard keys, which is often non compatible with some keyboards.

Hence, we specify the option acpi_backlight=vendor which tells the kernel to take precedence of vendor driver over kernel driver. The option acpi_osi=linux tells the kernel to enable inbuilt ACPI workarounds for Linux drivers; which can be the case if the device driver has issues for Linux architecture.

1
  • this is it!
    – cipricus
    May 10 at 20:12
2

In my case, I resolved this problem by upgrading the kernel version from 5.4 to 5.6.

$ sudo apt-cache search linux-image-5

Then it will return the list of available kernels. I installed linux-image-5.6.0-1028-oem which is listed at the bottom at the moment.

You can install it as follows.

sudo apt install linux-image-5.6.0-1028-oem

After reboot your system, you may see that your kernel is updated.

As a reference, my GRUB_CMDLINE_LINUX_DEFAULT is set to be that of the original one, i.e. GRUB_CMDLINE_LINUX_DEFAULT="quiet splash". In addition, I installed the brightness-controller but I'm not sure whether it helped me or not.

Hope this might help you.

2
  • In fact, rebuilding the initrd for my 5.4 kernel was already enough for me (see my answer). I could imagine that installing a new kernel has a similar effect (hypothesis: it was not the change in the kernel that was decisive, but the fact that is was properly initialised).
    – mak
    Nov 22 '20 at 21:31
  • Thanks, this solved the problem for me! My kernel was at 5.4, and I also tried mak's answer before. But that didn't work. Installing the 5.6 kernel worked. Btw. before upgrading, when entering "xrandr -q" in the command line, the following was returned: "Failed to get size of gamma for output default". With the newer kernel, this error has also vanished.
    – Sam
    Jan 5 at 20:45
2

For me, the problem was solved by simply rebuilding the initrd another time after booting into the new kernel:

sudo dpkg-reconfigure linux-image-5.4.0-54-generic

Obviously, you should run this with the package of your current boot kernel. If you are unsure, run uname -r to get the kernel name. Moreover, package names after dpkg-reconfigure auto-complete in my bash, but your settings may vary.

Doing this should always be safe and quick, so it would not hurt to try this before you do anything else. However, I add more details on my setup and what else I did below.

My configuration and observed behaviour

  • Problem was as described above, first found after upgrade to Ubuntu 20.04 (brightness worked before)
  • Renato Miotto's solution (via xrandr --output ... --brightness 0.8) allowed me to change brightness, but system keys still do not work and using xrandr resets screen colour (night colour mode)
  • Macbook Air 3,2 (very old, tends to have EFI boot issues related to graphics)
  • KDE Neon, Nvidia video drivers, kernel 5.4.0-54-generic

Note that Nvidia drivers on MacBook Air 3,2 have a whole set of other, unrelated issues, some specifically related to brightness control. In particular, you need to add X-related device option settings EnableBrightnessControl=1 as per Brightness not working after installing NVIDIA driver. Also, MacBook Air 3,2 by default may fail to boot usable graphics altogether in Nvidia drivers, which is fixed by setting certain PCI-E registers in grub as per Proprietary NVidia drivers with EFI on Mac, to prevent overheating. Both were applied before on my machine and remained active after the upgrade, so not related.

What else I did (may have interacted with the above fix)

I saw two more boot-level issues after the upgrade and I fixed them too. Doing this might have interacted with the effectiveness of my fix:

  1. I fixed Failed to Set MokListRT: Invalid Parameter by following (a KDE Neon adapted version of) Shibiwan's answer on Ubuntu 20.04 Failed to Set MokListRT: Invallid Parameter.
  2. My grub boot menu had vanished too. I recovered it by editing /etc/default/grub to contain GRUB_TERMINAL=console, GRUB_TIMEOUT_STYLE=menu, and GRUB_TIMEOUT=10. After this, update-grub needs to be run (which the above dpkg-reconfigure will do as well).

Having the grub menu working is also a minimal safety net when tempering with boot settings, so it makes sense to address this first if you see this too.

2

I had the same issue, in my case all answers I found not working. Maybe my case is specific, but I hope my answer can help someone.

My computer is a Lenovo Legion Y740-15I with a nvidia GeForce RTX 2060. I have tried all solutions available but none worked. One day by chance when I installed tensorflow I had to install CUDA Toolkit 11.0 and his compiler.

After CUDA installation and a reboot I noticed brightness controller is working !!! I gave you all steps I followed below :

  1. Follow base installer instructions for CUDA nvidia toolkit (official release instructions)
  2. Check CUDA version $ cat /usr/local/cuda/version.txt
  3. Install CUDA compiler $ sudo apt install nvidia-cuda-toolkit
  4. Check CUDA compiler version $ nvcc -V
  5. Reboot computer
  6. Check if nvidia driver communicate with GPU $ nvidia-smi If you can see CUDA Version: 11 installation is done !

Now check if your brightness controller work. Hope this might help someone...

PS: Also resolved boot black screen problem when login

2
  • the OP says lspci|grep VGA 00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller. Your answer cannot apply to that.
    – cipricus
    May 10 at 20:11
  • 1
    Maybe my case is specific, but I hope my answer can help someone. -you can also create a question in order to answer it.
    – cipricus
    May 10 at 20:28
1

Yes, this has been answered in the past. And it was the method I used in 18.04, before upgrading.

Brightness problem Ubuntu 18.04 LTS

1

If you're having problems on 20.04 and you've upgraded from an earlier version where you tweaked with the grub file, try changing the grub file back to the original:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

then do sudo update-grub, then restart.

I suspect that 20.04 has fixed the brightness issues of 18.04 and, ironically, that their fix breaks your fix for earlier versions.

Not sure, but it worked for me. Best of luck.

1

On Lubuntu 20.04 there's a simple shortcut : Ctrl+Shift+F6 or Ctrl+Shift+F7 to increase or decrease brightness.

1

I had much easier solution. Somehow unintentionally I've disabled "Handle display brightness keys" option in Xfce Power Manager. When pressing the brightness keys, the notification popup was displayed but the brightness bar wasn't moving. I took quite a while before I realized this.

However this is only related to XFCE, I have Xubuntu 20.04.

1

For Lenovo Legion 5 with AMD Ryzen and Nvidia 1060Ti on Ubuntu 21.04 I tried multiple fixes listed by others in this thread (adding EnableBrightnessControl=1 in xorg.conf, updating kernel - yes, I was desperate, etc.), however that what helped was the following:

GRUB_CMDLINE_LINUX_DEFAULT="acpi_osi=linux thinkpad-acpi.brightness_enable=1"

where acpi_osi=linux really helped and brightness keys and slider started to work.

Before I discovered this fix, I was using a little program brightness-controller, which also did the trick.

1
  • I have a legion 5i with i7 and RTX 2060, I began to get desperate, but then I remembered that I have turned off the "hybrid mode" to not use the generic intel graphics and use directly the RTX, I switched to "dynamic graphics" on bios and it started to work again Aug 14 at 13:46
0

I have a Lenovo Ideapad Gaming laptop with nVidia 1650 Graphics Card. None of the above solutions worked for me. This is how I was able to get the brightness to work:

sudo add-apt-repository ppa:cappelikan/ppa
sudo apt update
sudo apt install mainline

Open the "Ubuntu Mainline Kernel Installer" app. Select the latest Kernel version which is at the very top of the list and click the Install button. As of this writing, version 5.15.1 is the latest. Restart the computer and the brightness keys work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.