I am unable to adjust brightness levels through Gnome. I had the same issue with 18.04 but it was resolved there (honestly, I can't remember how).

lspci|grep VGA
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 18)

xrandr --output LVDS-1 --brightness 0.95
<-- this works through the terminal
excerpt from /etc/default/grub
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"

Thank you in advance.

  • Seeing a similar problem on an old MacBook Air 3,2 (with KDE Neon, NVidia drivers, Linux 5.4.0-54-generic). After upgrade to Ubuntu 20.04, brightness control keys stopped working. xrandr brightness works but lacks power management integration, is not convenient, and resets night color. grub command line is unchanged, so the kernel is suspect #1 now.
    – mak
    Nov 22, 2020 at 19:54
  • Updating my kernel as to the latest oem kernel in this post worked for me
    – Nelly
    May 23, 2021 at 6:33

19 Answers 19


The xrandr solution didn't worked for me. I have installed brighness-controller and worked well.

sudo add-apt-repository ppa:apandada1/brightness-controller
sudo apt update
sudo apt install brightness-controller

UPDATED: After I have upgraded to Ubuntu 21, this issue has fixed completely. My laptop buttons of brightness control works normally. No needed additional configuration.

  • I just tried it, and it seems to work on Ubuntu 20.04. What I like about this solution is that the software is relatively fast to install and doesn't require a reboot.
    – Rmurphy
    Aug 8, 2021 at 12:34
  • Works for me. Not as ideal as having my Fn buttons working again, but saves me from going blind which is definitely something.
    – Gigi
    Aug 19, 2021 at 16:51
  • It does conflict with Night Color Control though...
    – Gigi
    Aug 19, 2021 at 16:59
  • not working for me. having gtx 1660 ti card.
    – arslion
    Aug 19, 2021 at 17:55
  • Not working for me on Lenovo Thinkpad X250.
    – blnks
    Oct 30, 2021 at 5:21

I am having similar issue. There is no screen brightness slider on system menu (the one below the volume). I know that there is a workaround using xrandr that goes like this:

xrandr -q | grep " connected"

The output looks like:

DP-1 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 477mm x 268mm
DP-3 connected primary 1920x1080+1920+0 (normal left inverted right x axis y axis) 477mm x 268mm

I am using a dual screen, so that is why I have 2 channels (DP-1 and DP-2). Then you can adjust the brightness by typing

xrandr --output DP-3 --brightness 0.8

Here, I am using 0.8 in monitor DP-3. Just do the same for the other monitor and we are all set.

However, I noticed that the screen brightness is oscillating and no solution that I found in the internet worked for me.

  • Is it harmfull to set --brightness 5 ? Jan 6, 2021 at 9:58
  • No, it wouldn't be harmful, however, I don't think it would have the effect that you expect. Values larger than 1.0 produce weird colors on the screen (at least that is what happens on my screen). You can test different values yourself and choose the one you feel more comfortable with. Jan 7, 2021 at 11:18
  • 1
    recently i had a problm that my brightness becomes low then the normal one.So when i was setting it 100% i mean full brightness still it was low. So i have to make --brightness 5 and it's working fine. Jan 7, 2021 at 11:38
  • Not working for ubuntu 21.04 on Samsung Galaxy book pro
    – Rowing0914
    Jan 3, 2022 at 11:56

I had the same problem, which was solved following this post: How to Fix Brightness Keys Not Working in Ubuntu. The solution is quite simple:

  1. Edit file /etc/default/grub and set:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor acpi_osi=linux"
  2. Save the file and update GRUB:

    sudo update-grub
  3. Restart the computer and it worked.

The rational behind the operations, as the author explained, is as follows:

ACPI is a power interface management standard which is implemented in operating system kernels. By default Linux kernel uses an inbuilt driver for keyboard keys, which is often non compatible with some keyboards.

Hence, we specify the option acpi_backlight=vendor which tells the kernel to take precedence of vendor driver over kernel driver. The option acpi_osi=linux tells the kernel to enable inbuilt ACPI workarounds for Linux drivers; which can be the case if the device driver has issues for Linux architecture.

  • this is it!
    – cipricus
    May 10, 2021 at 20:12
  • Not working for ubuntu 21.04 on Samsung Galaxy book pro
    – Rowing0914
    Jan 3, 2022 at 11:56
  1. Open the grub file from the directory /etc/default or run the command:

    gedit /etc/default/grub

    in a terminal.

  2. Edit the following line from:



    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pcie_aspm=force acpi_backlight=native"
  3. Run the command:

    sudo update-grub
  4. Restart your computer.

  • Thank you! I tried every other solution I could find without any success but yours finally fixed it.
    – Pockets
    Jan 31, 2023 at 21:05

I had the same issue, in my case all answers I found not working. Maybe my case is specific, but I hope my answer can help someone.

My computer is a Lenovo Legion Y740-15I with a nvidia GeForce RTX 2060. I have tried all solutions available but none worked. One day by chance when I installed tensorflow I had to install CUDA Toolkit 11.0 and his compiler.

After CUDA installation and a reboot I noticed brightness controller is working !!! I gave you all steps I followed below :

  1. Follow base installer instructions for CUDA nvidia toolkit (official release instructions)
  2. Check CUDA version $ cat /usr/local/cuda/version.txt
  3. Install CUDA compiler $ sudo apt install nvidia-cuda-toolkit
  4. Check CUDA compiler version $ nvcc -V
  5. Reboot computer
  6. Check if nvidia driver communicate with GPU $ nvidia-smi If you can see CUDA Version: 11 installation is done !

Now check if your brightness controller work. Hope this might help someone...

PS: Also resolved boot black screen problem when login

  • the OP says lspci|grep VGA 00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller. Your answer cannot apply to that.
    – cipricus
    May 10, 2021 at 20:11
  • 1
    Maybe my case is specific, but I hope my answer can help someone. -you can also create a question in order to answer it.
    – cipricus
    May 10, 2021 at 20:28

For me, the problem was solved by simply rebuilding the initrd another time after booting into the new kernel:

sudo dpkg-reconfigure linux-image-5.4.0-54-generic

Obviously, you should run this with the package of your current boot kernel. If you are unsure, run uname -r to get the kernel name. Moreover, package names after dpkg-reconfigure auto-complete in my bash, but your settings may vary.

Doing this should always be safe and quick, so it would not hurt to try this before you do anything else. However, I add more details on my setup and what else I did below.

My configuration and observed behaviour

  • Problem was as described above, first found after upgrade to Ubuntu 20.04 (brightness worked before)
  • Renato Miotto's solution (via xrandr --output ... --brightness 0.8) allowed me to change brightness, but system keys still do not work and using xrandr resets screen colour (night colour mode)
  • Macbook Air 3,2 (very old, tends to have EFI boot issues related to graphics)
  • KDE Neon, Nvidia video drivers, kernel 5.4.0-54-generic

Note that Nvidia drivers on MacBook Air 3,2 have a whole set of other, unrelated issues, some specifically related to brightness control. In particular, you need to add X-related device option settings EnableBrightnessControl=1 as per Brightness not working after installing NVIDIA driver. Also, MacBook Air 3,2 by default may fail to boot usable graphics altogether in Nvidia drivers, which is fixed by setting certain PCI-E registers in grub as per Proprietary NVidia drivers with EFI on Mac, to prevent overheating. Both were applied before on my machine and remained active after the upgrade, so not related.

What else I did (may have interacted with the above fix)

I saw two more boot-level issues after the upgrade and I fixed them too. Doing this might have interacted with the effectiveness of my fix:

  1. I fixed Failed to Set MokListRT: Invalid Parameter by following (a KDE Neon adapted version of) Shibiwan's answer on Ubuntu 20.04 Failed to Set MokListRT: Invallid Parameter.
  2. My grub boot menu had vanished too. I recovered it by editing /etc/default/grub to contain GRUB_TERMINAL=console, GRUB_TIMEOUT_STYLE=menu, and GRUB_TIMEOUT=10. After this, update-grub needs to be run (which the above dpkg-reconfigure will do as well).

Having the grub menu working is also a minimal safety net when tempering with boot settings, so it makes sense to address this first if you see this too.


I had much easier solution. Somehow unintentionally I've disabled "Handle display brightness keys" option in Xfce Power Manager. When pressing the brightness keys, the notification popup was displayed but the brightness bar wasn't moving. I took quite a while before I realized this.

However this is only related to XFCE, I have Xubuntu 20.04.

  • Not working for ubuntu 21.04 on Samsung Galaxy book pro
    – Rowing0914
    Jan 3, 2022 at 12:09

I have a Lenovo Ideapad Gaming laptop with nVidia 1650 Graphics Card. None of the above solutions worked for me. This is how I was able to get the brightness to work:

sudo add-apt-repository ppa:cappelikan/ppa
sudo apt update
sudo apt install mainline

Open the "Ubuntu Mainline Kernel Installer" app. Select the latest Kernel version which is at the very top of the list and click the Install button. As of this writing, version 5.15.1 is the latest. Restart the computer and the brightness keys work.

  1. Open a terminal with Ctrl+Alt+T.

  2. Open the file /etc/default/grub from the terminal:

    sudo gedit /etc/default/grub
  3. Update the following line from:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" 


    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=none"
  4. Run from the terminal:

    sudo update-grub 
  5. Restart the computer.

This worked for me. Ubuntu's own brightness control and keyboard brightness control work. Even when I turn the computer off and on, the setting does not change. This is real brightness control. When I lowered the brightness in third party programs, the screen became slightly bluish.


In my case, I resolved this problem by upgrading the kernel version from 5.4 to 5.6. Run:

sudo apt-cache search linux-image-5

This will return the list of available kernels. I installed linux-image-5.6.0-1028-oem which is listed at the bottom at the moment.

You can install it as follows.

sudo apt install linux-image-5.6.0-1028-oem

After rebooting your system, you may see that your kernel is updated.

As a reference, my GRUB_CMDLINE_LINUX_DEFAULT is set to be that of the original one, i.e. GRUB_CMDLINE_LINUX_DEFAULT="quiet splash". In addition, I installed the brightness-controller, but I'm not sure whether it helped me or not.

Hope this might help you.

  • In fact, rebuilding the initrd for my 5.4 kernel was already enough for me (see my answer). I could imagine that installing a new kernel has a similar effect (hypothesis: it was not the change in the kernel that was decisive, but the fact that is was properly initialised).
    – mak
    Nov 22, 2020 at 21:31
  • Thanks, this solved the problem for me! My kernel was at 5.4, and I also tried mak's answer before. But that didn't work. Installing the 5.6 kernel worked. Btw. before upgrading, when entering "xrandr -q" in the command line, the following was returned: "Failed to get size of gamma for output default". With the newer kernel, this error has also vanished.
    – Sam
    Jan 5, 2021 at 20:45
  1. goto ls /sys/class/backlight/ and move to the respective folder based on vga and graphics driver.
  2. change the value of /sys/class/backlight/intel_backlight/brightness to the level between 60000 - 120000

This worked for me! As a quick patch u can consider this.


If you're having problems on 20.04 and you've upgraded from an earlier version where you tweaked with the grub file, try changing the grub file back to the original:


then do sudo update-grub, then restart.

I suspect that 20.04 has fixed the brightness issues of 18.04 and, ironically, that their fix breaks your fix for earlier versions.

Not sure, but it worked for me. Best of luck.

  • Not working for ubuntu 21.04 on Samsung Galaxy book pro
    – Rowing0914
    Jan 3, 2022 at 12:09

On Lubuntu 20.04 there's a simple shortcut : Ctrl+Shift+F6 or Ctrl+Shift+F7 to increase or decrease brightness.

  • Not working for ubuntu 21.04 on Samsung Galaxy book pro
    – Rowing0914
    Jan 3, 2022 at 12:09

I did not want to install any third party software to control brightness. All the native fixes that are mentioned here, did not work for me. Things that I tried:

  1. Modified and updated GRUB file on /etc/default/grub from GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" to GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor". This did not work.
  2. Create a file /usr/share/X11/xorg.conf.d/20-intel.conf. This did not work.
  3. Create a file /usr/share/X11/xorg.conf.d/80-backlight.conf. This did not work.

Finally, this worked for me:

Modify and update GRUB file /etc/default/grub from GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" to GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=none" and run sudo grub-update then restart.

PS: This was originally posted here. Props to OP for this solution. I spent a lot of time with lots of tricks without anything fixing it for me.

  • try changing the X11 display manager, from gdm3 to lightdm (I presume you now have gdm3). be prepared to take some risk though :) askubuntu.com/questions/829108/… Jan 9, 2022 at 7:44
  • this answer worked for me. Lenovo laptop converted from Windows 10 to Ubuntu 22.04. Intel integrated graphics card.
    – Theo F
    Jul 20, 2022 at 21:48

I had the same issue. I followed the answers above but couldn't fix the issue. But updating the package index and then upgrading the packages solved the issue in my case. Commands:

sudo apt update
sudo apt list --upgradable
sudo apt upgrade
  • this post is rather old, the issue has been resolved in some kernel update. you did good to post. Jan 21, 2022 at 8:12

You shouldn't install anything. Just do the following changes in /etc/default/grub:


Then run:

sudo update-grub && reboot

For a Lenovo Legion 5 with AMD Ryzen and Nvidia 1060Ti on Ubuntu 21.04 I tried multiple fixes listed by others in this thread (adding EnableBrightnessControl=1 in xorg.conf, updating kernel - yes, I was desperate, etc.), however that what helped was the following:

GRUB_CMDLINE_LINUX_DEFAULT="acpi_osi=linux thinkpad-acpi.brightness_enable=1"

where acpi_osi=linux really helped and brightness keys and slider started to work.

Before I discovered this fix, I was using a little program brightness-controller, which also did the trick.

  • I have a legion 5i with i7 and RTX 2060, I began to get desperate, but then I remembered that I have turned off the "hybrid mode" to not use the generic intel graphics and use directly the RTX, I switched to "dynamic graphics" on bios and it started to work again Aug 14, 2021 at 13:46
  • Not working for ubuntu 21.04 on Samsung Galaxy book pro
    – Rowing0914
    Jan 3, 2022 at 12:10

I have a similar problem on Ubuntu 22 (brightness slider doesn't change anything) and tried the proposed solution without success. So I tried to change acpi_backlight=video instead acpi_backlight=vendor (as other answer propose) and brightness slider start to work.

Since I get warning, that my post does not provide an answer to the question, I write step by step instruction:

  1. Open the file /etc/default/grub with text editor that run with administrator privileges.

  2. Find line:

  3. Change that line to:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=video"
  4. Save changes and close text editor

  5. From terminal run command: sudo update-grub

  6. Restart the computer:

    sudo reboot

At https://www.kernel.org I found that acpi_backlight can have 4 different values: vendor, video, native, none. So if one is not working, try another value.


Here's what worked for me:

1º Go into the menu and click in "Software and Updates" app and go in additional drivers. It should look like this.

Software and Updates -> Additional Drivers

2º From all the options choose the latest one (the one that has the greater number) and you'll see that there are lots of the, some end in -server, others end in -open; what you have to do is choose the one that ends in nothing, for example, in the picture above I used the first one 'Using NVIDIA ... nvidia-driver-535 (propietary)' and then I clicked on apply changes, it made me restart and voila!

Note: If the screen has chosen the option 'Continue using a manually installed driver' what you have to do is execute this command:

sudo apt purge nvidia-*

and reopen your 'Software and updates' app and it should work.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .