2

I upgraded to Ubuntu 20.04 LTS from Kubuntu 18.04 with a clean install (still dual boot with Windows 10). I can see my network with the correct SSID, but when I try connecting, it never authenticates and keeps asking for the password which I am 100% sure is entered correctly.

I can however, connect to my mobile hotspot wireless.

uname -a

Linux mthiagar-ThinkPad-T440s 5.4.0-26-generic #30-Ubuntu SMP Mon Apr 20 16:58:30 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

dmesg | grep iwl

[    4.444541] Loading modules backported from iwlwifi
[    4.444542] iwlwifi-stack-public:master:8324:9176b151
[    4.582977] iwlwifi 0000:03:00.0: Direct firmware load for iwl-dbg-cfg.ini failed with error -2
[    4.586206] iwlwifi 0000:03:00.0: loaded firmware version 17.bfb58538.0 7260-17.ucode op_mode iwlmvm
[    4.586243] iwlwifi 0000:03:00.0: Direct firmware load for iwl-debug-yoyo.bin failed with error -2
[    4.654758] iwlwifi 0000:03:00.0: Detected Intel(R) Dual Band Wireless AC 7260, REV=0x144
[    4.678917] iwlwifi 0000:03:00.0: base HW address: e8:2a:ea:73:8c:32
[    4.895628] ieee80211 phy0: Selected rate control algorithm 'iwl-mvm-rs'
[    5.308224] iwlwifi 0000:03:00.0 wlp3s0: renamed from wlan0

lspci -knn | grep Net -A3; rfkill list

03:00.0 Network controller [0280]: Intel Corporation Wireless 7260 [8086:08b2] (rev 83)
    Subsystem: Intel Corporation Dual Band Wireless-AC 7260 [8086:c270]
    Kernel driver in use: iwlwifi
    Kernel modules: iwlwifi
0: tpacpi_bluetooth_sw: Bluetooth
    Soft blocked: no
    Hard blocked: no
1: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
2: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

I'm not an advanced user by any means, so I've only tried the following from reading other threads:

  1. forgetting the network and reconnecting, unchecking connect automatically, and entering the password into the security tab under configuration

  2. reinstalling iwlwifi using sudo apt install backport-iwlwifi-dkms

  3. running sudo service network-manager restart

Any ideas on what may be wrong, and what else I should try? Let me know if more info is needed.

  • Have you checked password encryption method? – ubuntu user Apr 26 at 12:12
  • Yes, it's WPA & WPA2 Personal. This is the right one. – mthiagar Apr 26 at 14:19
  • 1
    Seeing this exact issue on Dell XPS 9560 after upgrading from 18.04 to 20.04. I am able to connect to 5 GHz network, but not able to connect to 2.4 GHz. Were you able to fix this? – serejja May 1 at 16:39
  • See the solution by @chronodekar below. That worked for me. Just note, I had to restart my computer, just restarting network services didn't work. – mthiagar May 1 at 18:40
1

Can you try editing the file,

$ sudo vi /etc/modprobe.d/iwlwifi.conf

to add the following if you are attempting to connect to a 5g based N network?

options iwlwifi 11n_disable=8

The above line is supposed to enable antenna aggregation.

Or add the following if you want to connec to a 2.4g based G network;

options iwlwifi 11n_disable=1

The above line disables 802.11n mode.

I can confirm that the above works for me on a regular Ubuntu 20.04 (not Kubuntu) with a Lenovo T460s. Spent enough time digging into the issue to make this post on the Ubuntu forums = https://ubuntuforums.org/showthread.php?t=2442177 (the link has more details which might be useful to read about on this issue, but is not relevant as a direct answer to this question).

| improve this answer | |
  • This solved it! You are awesome, thank you! I'm connecting to a 2.4g based G network so I added options iwlwifi 11n_disable=1 and had to restart. Just running systemctl restart network-manager.service or `sudo service network-manager restart' didn't work. Must restart. – mthiagar May 1 at 18:34
  • Update: So this works, gets me connected, but disabling 802.11n definitely slows things down very noticeably. In any case, it's better than nothing. – mthiagar May 1 at 22:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.