23

When I start Ubuntu I had my "home/user" in my Desktop.

test is my User.

home folder on desktop

home folder open in file manager

How do I make the folder not be on the desktop?

0

5 Answers 5

34

Open the terminal and type the following command:

gsettings set org.gnome.shell.extensions.desktop-icons show-home false

After you do this, the home folder icon should disappear from your desktop.

2
  • 2
    best answer, just copy/paste the command Aug 12, 2020 at 11:25
  • 5
    And (in case it's not obvious) to remove just the "trash" icon copy and paste this command in the terminal - gsettings set org.gnome.shell.extensions.desktop-icons show-trash false Dec 16, 2020 at 23:49
14

The easiet way would be to install the package.. gnome-shell-extension-prefs

Once you install the package, you can find the app in all apps..

enter image description here

and then turning off the switch for "Show the personal folder in the desktop"

enter image description here

enter image description here

Same thing can be achieved with gnome-tweaks also, If you already Installed gnome-tweaks

10
  • 1
    you want to hide only the user named Icon rite? in the above way I just see it is only hiding the user Icon. i.stack.imgur.com/xsMAt.png
    – UnKNOWn
    Apr 25, 2020 at 14:46
  • 1
    Hi, I just tried it in a fresh install by creating /home partition like you. Are you sure you are not looking for this? i.stack.imgur.com/olic5.png
    – UnKNOWn
    Apr 25, 2020 at 15:11
  • 1
    Yes it does not matter whether you mount it separately or leave it to root. That's why I did a fresh install and check it.
    – UnKNOWn
    Apr 25, 2020 at 15:47
  • 1
    in 18.04 the desktop/icons is controled by nautilus.. I think from 19.04/19.10 the desktop/icons are controlled by the above extension. desktop-icons
    – UnKNOWn
    Apr 25, 2020 at 15:52
  • 1
    the gnome-shell-extension named desktop icons is handling the desktop/icons. In 18.04 it is handled by nautilus/File Manager (Default). gnome-shell-extension-prefs is a tool to configure installed gnome-shell-extensions
    – UnKNOWn
    Apr 25, 2020 at 16:14
11

To remove both the trash icon and home icon:

gsettings set org.gnome.shell.extensions.desktop-icons show-home false

and

gsettings set org.gnome.shell.extensions.desktop-icons show-trash false

No need to install any additional software 👍

1
  • 1
    Thanks for the post. Very helpful.
    – Melinda
    Sep 5, 2020 at 17:59
2

I came here without solution, but this answer for similar question solve it. I'm current in Ubuntu 21.10:

https://askubuntu.com/a/1335409/452437

In dconf application, after installed, I went to /org/gnome/shell/extensions/ding/ and disable show-home option.

1
  • Yeah, this has apparently changed in 21.10. I tried the *desktop-icons" mentioned above and it isn't present; apparently replaced with "ding".
    – AdvApp
    Mar 16 at 1:44
1

You can also use the above mentioned commands in one line

To hide to home and trash icons:

gsettings set org.gnome.shell.extensions.desktop-icons show-home false && gsettings set org.gnome.shell.extensions.desktop-icons show-trash false

Just in case, to show those icons again:

gsettings set org.gnome.shell.extensions.desktop-icons show-home true && gsettings set org.gnome.shell.extensions.desktop-icons show-trash true

Hope it helps.

Not the answer you're looking for? Browse other questions tagged or ask your own question.