11

I tried Ubuntu Vanila, Mate and Kylin (all same version 20.04) still the same. It plays fine with the inbuilt speakers but when a headphone is plugged in there is no audio. In the speaker settings it changes from speaker to headphones but doesn't play. Then reinstalled 19.10 and now audio is fine.

2

6 Answers 6

8

Try in your terminal

  • sudo apt update && sudo apt install alsamixer
  • run alsamixer in your terminal.
  • press arrow right til you go to HEADPHONES bar.
  • press M to unmute.
  • press up/down to adjust the volume.
  • press Esc to exit alsamixer.
  • run sudo alsactl store in your terminal to store your settings earlier.
5
  • 2
    There is no headphones bar in alsamixer, only master and capture. Apr 28, 2020 at 20:46
  • For me, this fixes it temporarily, but then unplugging and reinserting the 3.5mm speaker it stops working again
    – blazingkin
    Apr 28, 2020 at 21:49
  • I can get it to work again by changing the profile for "Built-in Audio", cycling from Analog Stereo Input > Analog Stereo Output > Analog Stereo Duplex, and then it works
    – blazingkin
    Apr 28, 2020 at 21:50
  • 1
    It still is not working :(
    – sgrmshrsm7
    Sep 4, 2020 at 5:00
  • 1
    It worked and the headphone is working but the sound is coming from the laptop's speaker also along with the audio. Please help Nov 12, 2021 at 6:49
2

Ubuntu, headphone not muted in 'alsamixer', volume is high, still now sound!

Please try this, if your Ubuntu is using snd hda intel.

  1. Open Terminal (If you don't know where Terminal is, click Show Application in Unity, type Terminal, it should appear, click it open.)

  2. In Terminal type the command, sudo nautilus. Give your password as asked. This should have opened your file browser with access to root filesystem. Look for etc folder.

  3. Inside etc folder, find modprob.d folder.

  4. In modprobe.d find the file alsa-base.cof (or alsa.conf instead, if alsa-base.conf is not there.)

  5. Copy the following two lines and paste as the last two lines in alsa configuration file you have just opened.

options snd-hda-intel model=headset-mode
options snd-hda-intel model=dell-headset-multi
  1. Click 'Save' in alsa or alsa-base.

  2. Restart the system. Plugin your headphone, microphone.

Now Ubuntu should be able to auto-detect headphone and microphone.

1
  • Great! This is what helped me get my sound working.
    – Jethro Cao
    Feb 28, 2021 at 22:09
2

Use pavucontrol and enable the microphone audio (and speaker). If the microphone is disabled the speaker doesn't work.

I don't know why this happens, but the above fixes the problem.

1
  • Thanks! Unmuting the microphone in Input Devices worked for me.
    – DevAb
    Oct 29, 2021 at 13:17
1

If you are still having problems, this worked for me as well as alot of people with "gaming" laptops: [link][1]

Pasting the answer that worked for me

so after having this issue with beautiful, but already annoying 20.04 I've found a solution in another post at superuser. In my case what helped me was:

cat /proc/asound/card*/codec* | grep Codec

to get the Audio Codec for your machine model. In my case I saw Audio (ex: Codec: Realtek ALC233) & Video (ex: Codec Nvidia GPU 94 HDMI/DP) codecs there.

Go to www.kernel.org and look up the version of the codec, and get the full name of it. In my case: Realtek ALC233 -> alc233

Create/update a file under /etc/modprobe.d/alsa-base.conf, and add this line: options snd-hda-intel model=alc233-eapd

while replacing model with yours

Reboot the machine.

It helped me, so let me know if that works for you. Cheers!

0

20.04 headphones didn't work for me either. BUT after I finished doing another partial upgrade of packages evertyhing worked. Apparently something was missing / upgrade was not completely finished. Now headphones works just like 19.04.

1
  • 1
    After installing 20.04, I've updated the OS and rebooted but still the headphone jack is not working. Any particular package did you install? Apr 26, 2020 at 19:19
0

After installing Ubuntu 20.04 LTS on my new Dell Vostro 3490 (2019) my 3.5 mm audio jack was not working. This is what worked for me:

  1. Make sure Headphones built-in audio is selected in Ubuntu's Sound Settings in the Output panel.
  2. Run alsamixer to unmute the headphone audio (as in @tanhernandez answer):
# alsamixer
  1. Save alsamixer settings:
# sudo alsactl store
  1. Run:
# lsactl restore

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .