0

Today I upgraded Ubuntu from 18.04 to 20.04 and suddenly noticed a lot of the following warnings appearing:

Apr 25 11:12:38 [...]: Fontconfig warning: "/etc/fonts/conf.avail/41-ttf-arphic-uming.conf", line 40: Having multiple <family> in <alias> isn't supported and may not work as expected
Apr 25 11:12:38 [...]: Fontconfig warning: "/etc/fonts/conf.avail/65-ttf-droid-sans-fonts.conf", line 61: Having multiple values in <test> isn't supported and may not work as expected

These messages were appearing in relation to various processes. It seems they appear when ever a process is loading fonts. The problem is described in Fixing Font Configuration Warning Messages.

However the above blog explains how to modify the font files under /etc/fonts/ to fix the problem. How ever want to understand why they appear in the first place?

1

So here are some details on how to debug the problem to find where these problems are originating from.

Lets start by checking which package is responsible for this problem

foo@bar ~$ dpkg -S 41-ttf-arphic-uming.conf
ttf-arphic-uming: /etc/fonts/conf.avail/41-ttf-arphic-uming.conf

So the problematic file was coming from a package named ttf-arphic-uming. Doing the same for the other file revealed another package named ttf-droid.

Next, I checked what these packages are used for:

foo@bar ~$ apt show ttf-arphic-uming
Package: ttf-arphic-uming
Version: 0.2.20080216.2-4ubuntu4
Status: install ok installed
Priority: extra
Section: oldlibs
Source: fonts-arphic-uming
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Original-Maintainer: Debian Fonts Task Force <pkg-fonts-devel@lists.alioth.debian.org>
Installed-Size: 38.9 kB
Pre-Depends: dpkg (>= 1.15.6~)
Depends: fonts-arphic-uming
Homepage: http://www.freedesktop.org/wiki/Software/CJKUnifonts
Download-Size: unknown
APT-Manual-Installed: yes
APT-Sources: /var/lib/dpkg/status
Description: transitional dummy package
 This package is a dummy transitional package. It can be safely removed.

The important part is in the last line, which tells us that we do not need this package and can safely remove it.

After removing both packages the warnings no longer appear. Taking a closer look at the issue I realized that I had many obsolete packages installed on my system and those two packages were just two of these obsolete packages.

If you have upgraded from previous versions of Ubuntu using the update-manager, it may happen that you have obsolete packages left on your computer, you can check that via aptitude search '~o'. A proper solution is probably to check the obsolete packages on your system and remove all that are not needed anymore. Nevertheless I decided to post this answer in case anyone has a similar problem and may find it useful.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.