9

I have installed ubuntu 20.04 on virtualbox 6.0.20 and I have installed guest additions.

The issue is that if I resize the screen resolution to whatever size, even to predefined resolutions, it will always start/boot at 800x600 and I have to resize it again.

What I noticed is that when it boots, it goes for ~1 sec to the previous screen size but shows only black and then just before the wallpaper-desktop appears it goes to 800x600.

Any ideas?

1
  • I am having the same problem - losing of resolution of display setting everything I restart the image with Ubuntu 20.04 and Virtual box - Version 6.1.14 r140239 (Qt5.6.2). When I tried the VMSVGA driver the ubuntu guest system stops responding to mouse click and I could not type anything. System becomes very slow. I have not tried older version of Virtual Box that is my next step – user1426933 Oct 12 '20 at 3:17
14

I had the same problem with the new Kubuntu release. Do the following:

  1. Shut down your Ubuntu VM.
  2. Open the Settings for your Ubuntu VM and select the Display section
  3. Select VBoxSVGA as your Graphics Controller. VirtualBox will warn you at the bottom of the Settings window about the invalid settings, you can ignore that.
  4. Leave the option Enable 3D Acceleration unchecked, otherwise VirtualBox will revert the Graphics Controller back to VMSVGA when you confirm the settings.
  5. Confirm your choices by clicking OK.
  6. Start your Ubuntu VM.

I'm using VM VirtualBox ver. 6.1.6, Extension Pack (with included Guest additions virtual CD) is also 6.1.6

If someone knows how how to remedy the resolution issue with VMSVGA selected as Graphics Controller, I'd love to read it.

Update #1
This issue with screen resizing didn't let go of me, so I went and searched on the web some more.

From what I've read - and with my limited knowledge of inner workings of Linux systems, hopefully understood it at least somewhat correctly - the problem lies in relation between the graphic drivers included in Oracle's VM VirtualBox Guest Additions and the new Linux kernels that came with the recently released version of Ubuntu distro and others based on it. It seems the drivers present in ver. 6.1.6 Guest Additions aren't working correctly with these new kernels, hence the resizing problem when the Graphics Controller in VM is set to VMSVGA.

So until Oracle comes up with updated version of VirtualBox/Guest Additions, the temporary solution is the one I explained above, or what I've tried earlier and for me at least, works as well.

  1. Uninstall the current Guest Additions from your VM, then power it off.
  2. Download the older version - 6.1.2 ISO (link to Oracle's web page, there's only one such file listed).
  3. Start your VM and after you logged back, open VM Devices menu, select Optical Drives > Choose a disc file... to mount Guest Additions CD.
  4. Open your terminal and run the install script VBoxLinuxAdditions.run located in the root of the CD.
  5. Follow this step if your VM Graphics Controller is set to VBoxSVGA, otherwise skip to step 6: Power off the VM and in Settings > Display > Graphics Controller select VMSVGA, also enable 3D Acceleration. Confirm changes by clicking OK.
  6. Restart the VM, automatic screen resizing should work now.

I chose version 6.1.2 of Guest Additions because there's a bug with Bidirectional Clipboard support in 6.1.4.

5
  • 1
    I just had a similar problem with 6.1.6. Your steps described above did not help in my case. Installing the Guest Additions 6.1.2 alone didn't do it but switching View -> "Auto-resize Guest Display" off and then on again afterwards did the trick for me. Who knows, maybe only toggling that option works right out of the box. – linkD May 3 '20 at 15:52
  • @linkD Thank you for the feedback on this. I've never tried to toggle that option. I'll give it a go with 6.1.6 Guest Additions installed. – DigitalGreg May 3 '20 at 16:24
  • I am using Guest Addition 6.1.8 and facing this issue. I toggled the "Auto-resize Guest Display" option and it did not help. – user118967 May 26 '20 at 20:17
  • 1
    which version of the guest additions do i need to use on Focal Fossa? I see eoan.. But no focal.. I'm having the same issue. i'm hesitating to upgrade my Eoan because of this issue.. – Kornelito Benito Jul 23 '20 at 15:03
  • Thanks, I selected VBoxSVGA and it works now. Would like to follow up and ask if there are any downside of using VBoxSVGA instead of VMSVGA, is there any benefit of using VMSCVGA instead of VBoxSVGA? Thanks. – Ng Sek Long Jan 18 at 2:16
1

It's a bug. Upgrade to 6.1.8, and the problem goes away.

7
  • 2
    I'm using 6.1.8 and I still have the problem. – user118967 May 26 '20 at 20:13
  • @user118967 did you also install the new version of VirtualBox Guest Additions? – Aren Cambre May 27 '20 at 0:03
  • Yes, I'm using 6.1.8 which is the latest version of both VirtualBox and Guest Additions. – user118967 May 28 '20 at 2:13
  • Just to make sure, you have to also install the Guest Additions into your guest OS. From the guest OS, did you re-mount the Guest Additions ISO and re-install on that OS? – Aren Cambre May 31 '20 at 3:16
  • Yes, I did that. I am guessing the bug remains in the latest version, but does not always manifest in all systems? – user118967 Jun 1 '20 at 5:38

Not the answer you're looking for? Browse other questions tagged or ask your own question.