6

After a successful upgrade to Ubuntu 20.04, the WiFi hotspot option became disabled and when I hover on it, it shows "System policy prohibits use as a Hotspot". I have tried changing the hotspot modes but the same problem persists.

1
-3

I was able to solve the issue by referring Fix Wi-Fi Hotspot Not Working (Can not connect) in Ubuntu 18.04 | UbuntuHandbook

  1. Press Alt+F2 on keyboard to bring up 'Enter a Command' box, then input nm-connection-editor and hit Enter.

    enter image description here

  2. When the 'Network Connections' window pops up, click on the bottom-left plus button to create a new connection.

    enter image description here

  3. In next window, select Wi-Fi from the drop-down box.

    enter image description here

  4. After clicked the 'Create…' button, do following settings in next window.

    • Type connection name: whatever as you want (Ji-laptop in the case)
    • Type SSID: whatever as you want (ubuntu1804 in the case)
    • Select Mode: Hotspot
    • (Optional) Set password in Wi-Fi security tab. (WPA & WPA2 Personal in my case)

    Tip: you may disable ‘Automatically connect to this network when it is available’ in General tab, or Wi-Fi hotspot auto-enabled in every login. enter image description here

  5. Finally in Wi-Fi Settings window, do:

    • click the top-right menu and select Connect to Hidden Network
    • then choose connect to the previous created network.

    enter image description here

12

The button is also deactivated on my system after I upgrade from 19.10 to 20.04. And this is how I manage to enable my hotspot.

enter image description here

  1. Click on Connect to Hidden Network

    enter image description here

  2. Select Hostpot for the connection field.

    enter image description here

  3. For me my hotspot network get automatically selected after that. And your finish by clicking on connect

1
  • @RKatana please accept the answer, this works as the best workaround – Sayan Dey Mar 21 at 14:49
6

I started Terminal with Ctrl+Alt+T and ran:

sudo gnome-control-center
3
  • Does this solves the problem regarding hotspots? – Sasuke Uchiha Jul 1 '20 at 14:09
  • 1
    At least it gives you full control. Now you can edit and start hotspot. ( in combination with nm-connection-editor ). But I do not think that this is a final solution for a setting I configured at first in a user context. It is all a bit confusing. I would call it a work-around. – Ralf Bielefeld Jul 4 '20 at 23:58
  • 1
    now the button is enabled and I can use the functionality properly, thanks – Souhaieb Aug 24 '20 at 10:32
5

Try switching to another settings tab and back to WiFi settings tab. That fixed it for me.

This has been reported on Launchpad as Bug #1883425 “Various bugs in network part of GNOME settings” : Bugs : gnome-control-center package : Ubuntu.

2

Click on any other tab in the settings and then return back to wifi section. You'll get it back.

1
  • This actually works. Strange. – Doc Dec 25 '20 at 11:53
0

Not sure if other answers here are working or not but you might have to wait for the next release with the new network manager 1.22.10-1ubuntu3~build1 which has fixed the hotspot issue

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.