41

I have just upgraded to 20.04 without any issues, however, Gnome is painfully slow 2second delay with every action, apps take an age to open, terminal takes 2 sec to scroll through the history one item at a time. Anyone else seen this and have any answers?

4
  • 4
    What are your system specs? – Archisman Panigrahi Apr 25 '20 at 8:48
  • 3Ghz 8 core AMD, 32GB ram – Lynwode Apr 25 '20 at 21:27
  • 2
    20.04 Gnome desktop suddenly became extremely slow on my high-end hardware with scads of RAM, disk, swap, etc. for no obvious reason (e.g. log files clear). With this and the random WiFi disconnects that now occur daily, I think 20.04 was not actually ready for release. – Lexible Jun 2 '20 at 18:33
  • 1
    I have a 36 Core Xeon with 512GB of RAM and this is slow for me. WTF?? Seriously what is the point of this stupid window manager if it's so slow? – Eric des Courtis Feb 12 at 17:42
10

;tldr Avoid using the Fractional scaling and solve the scale of your high-dpi screen by reducing its resolution.

I was dealing with a terribly slow GNOME desktop for a few days now (after a fresh install of Ubuntu 20.04). I do not use any GNOME extensions and I have turned off animations using Gnome Tweaks. I also installed sudo apt install indicator-cpufreq to set CPUs to performance instead of powersafe. I checked the BIOS settings to aim for the maximum performance when on AC. But nothing helped. All window movements were lagged, sluggish, movements were ~2s delayed. Mouse cursor was jumpy. It always took 1-2s to change a Firefox tab and scrolling was not at all smooth and freezing at random times for a while. YouTube videos were unwatchable, even scrolling through a terminal was slow! It was just unacceptable.

I have a reasonably powerful notebook so it just did not feel right:

  • Lenovo Thinkpad X1 Carbon 7gen 20QD
  • CPU Intel® Core™ i7-8565U CPU @ 1.80GHz × 8
  • GPU Mesa Intel® UHD Graphics 620
  • RAM 16GB
  • OS NAME Ubuntu 20.04.LTS
  • GNOME Version 3.36.3
  • Windowing system X11
  • ThinkPad USB-C Gen2 Docking station
  • 3 monitors (built-in 14" WQHD, external 24" and 22")

I made sure that I have:

  • everything updated
  • the newest kernel (5.4.0-40-generic)
  • newest UEFI BIOS etc.

As it turns out, the problem was in the Fractional scaling the whole time. I know they write May increase power usage, lower speed, or reduce display sharpness, but damn this was not usable at all.

But I can not live without it, since my built-in display is WQHD (2560x1440) and when the Fractional scaling is off, both external monitors are OK, but everything on the built-in display is just tiny and unreadable. I tried switching to Wayland, it seemed promising for a while, until random freezes started occurring so I ditched the idea.

And then I realized I can just lower the resolution on my built-in monitor <facepalm>. The final solution was to turn off the Fractional scaling and reducing the resolution of the built-in monitor to FullHD. I sacrificed some sharpness, but the whole desktop is lightning fast now even with the animations and on powersave. I hope the Fractional scaling will get better at some point.

2
  • 1
    I have a similar issue but instead of fractional scaling I've just increased text size with $ gsettings get org.gnome.desktop.interface text-scaling-factor (this one gets current value, should be 1.0 by default). Use set instead to e.g. 1.4. – Daniel Nov 6 '20 at 16:29
  • I had played with it when I freshly installed it, had clicked the revert settings, but that was one option that hadn't reverted itself, just the scaling. – Tschallacka May 11 at 7:30
2

Ok Looks like Nvidia driver issue. Re-installed the default and we off and running

6
  • 16
    You can give more details about how you reinstalled the default, as that may help new users. – Archisman Panigrahi Apr 26 '20 at 2:42
  • install nvidia driver will make 20.04 can not login – Liao Zhuodi Apr 27 '20 at 1:26
  • 1
    @ArchismanPanigrahi I had the same issue and followed these instructions: cyberciti.biz/faq/… – Wouter De Coster Apr 29 '20 at 12:51
  • I did a fresh install of Ubuntu 20.04 including the proprietary drivers, but could not login as Liao mentions above. After that I re-did the fresh install but without the proprietary drivers and instead using the nouveau driver, and ran into the same problem as OP where everything was very slow. After that I simply installed nvidia-driver-390 using the link Wouter provided and everything worked. – casper May 4 '20 at 2:02
  • 2
    Made no difference for me. – Lexible Jun 2 '20 at 21:54
2

I have had same issues last two days. Everything was slow down and wifi connection was disconnecting periodically. if you have wifi problem, I suggest turn off wifi and plug in a lan cable before start.

try sudo apt update And sudo apt upgrade commands, then follow these instructions https://www.cyberciti.biz/faq/ubuntu-linux-install-nvidia-driver-latest-proprietary-driver/ (Wouter De Coster's comment from Lynwode answer), then https://askubuntu.com/a/961460/934684 disable wifi powersave mode, then restart; now everything good for me.

maybe my answer might not meet the answer qualification. but because of my reputation I couldn't comment. I wanted to write them, maybe it works. because it's very annoying.

Not the answer you're looking for? Browse other questions tagged or ask your own question.