OS: Ubuntu 20.04 LTS; Graphics: GeForce GTX 1060 6GB/PCle/SSE2; Monitor: ASUS PB287Q; Port: Display Port;

I just installed Ubuntu 20.04 LTS and attempted to apply fractional scaling to the display.

When changing the display scale option to 150%, the screen went blank/black for roughly 10 seconds and then came back and showed an error, without the scaling applied.

With the fractional scale option still selected, I changed to 200%, and then the screen went blank and stayed that way.

After turning my PC off and on again, I can login normally, but after logging in, the screen turns blank again and I can't do anything.

I could just re-install the system, but I'm hoping for a solution in case I face this problem again in the future.

  • Same issue with the same graphics card. LG monitor however.
    – Samuel
    Apr 25, 2020 at 12:51
  • 1
    Same issue with nvidia 670 connected to an asus monitor using display port also. Not only my screen is black but my monitor says no signal. Apr 25, 2020 at 13:31

5 Answers 5


Just to add a bit more to Wagner Michael's answer:

The following was performed successfully on Ubuntu 20.04:

  1. Boot into Ubuntu Recovery mode.

  2. Select "Drop into root user"

  3. sudo su - [Insert your username]

  4. gsettings get org.gnome.mutter experimental-features

    • Output should be = "['x11-randr-fractional-scaling']"
  5. gsettings set org.gnome.mutter experimental-features "[]"

  6. reboot



Disabling fractional scaling via command line has done the job for me:

gsettings set org.gnome.mutter experimental-features "[]"

Before experimental-features was set to "['x11-randr-fractional-scaling']" in my case.


Either you go into a different tty at boot (Ctrl+Alt+F2) or you do it from recovery mode and dropping into the root prompt. Either way, all you have to do is type:

rm .config/monitors.xml

To get rid of the fractional scaling config


If you get an error (as I did ) when gsettings set ...

to the effect cannot launch autolaunch d-bus without x-11 DISPLAY use

dbus-launch gsettings set org.gnome.mutter experimental-features "[]"

Go into Terminal at the login screen, remove the file .config/dconf/user and then sudo reboot. I think it resets the display settings to default.

This fixed my problem -- setting a fractional scaling and then black screen after login.

See Black screen after logging in, after upgrading to 20.04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.