7

Since I installed Ubuntu 20.04 I notice that there is Screen tearing when playing videos, it happens in several browsers and it is noticeable when moving the windows within the screen, when scrolling it is also noticeable. How is this problem solved?

1
  • Error: couldn't find RGB GLX visual or fbconfig Apr 26, 2020 at 0:01

4 Answers 4

6

I had the same problem with a GTX 960M on my Lenovo ideaPad Y700 and the following worked for me.

Open a terminal and run

sudo gedit /etc/modprobe.d/nvidia-drm-nomodeset.conf

In the file, write the following line:

options nvidia-drm modeset=1

Save the file. Back into the terminal, update initramfs by running:

sudo update-initramfs -u

Reboot.

Source: ubuntuhandbook.org


If the previous step didn't work, there is another solution that you can try:

$ xrandr --output eDP-1-1 --set "PRIME Synchronization" 1

Reboot.

This command will enable the sync in your hybrid card.

To check that sync has been enable: $ sudo cat /sys/module/nvidia_drm/parameters/modeset

it should return Y now.

Reboot.

6
  • I have a GT 635M Nvidia card and that steps don't work! Jul 19, 2020 at 2:00
  • What drivers are you using?
    – Nandete82
    Jul 26, 2020 at 11:07
  • I used the private drivers it doesn't work and the free drivers too Jul 28, 2020 at 4:30
  • I amended the solution to include an alternative. Hope it works!
    – Nandete82
    Aug 16, 2020 at 19:23
  • Why is there a need to update "intramfs"?
    – Tony Sepia
    Apr 9, 2021 at 19:59
1
  1. Try this video to see if you still have screen tearing.
  2. Try the solution provided here.
  3. What helped in my specific case was that I switched the driver used for my NVIDIA GP107M when using the "Additional Drivers" application and switched from nvidia-driver-440 to nvidia-driver-435.
0

I couldn't get this answer to work because the DRM kernel mode setting would not get updated.

Then I stumbled upon this answer explaining how to set that kernel boot parameter through GRUB instead. This worked for me on my laptop running Ubuntu 21.04 with the 470 drivers and a GTX 1050M GPU.

Steps based on this Ubuntu wiki page that describes how to set boot params through GRUB:

  1. Open the file /etc/default/grub for editing (e.g. sudo nano /etc/default/grub). It should already exist.

  2. Change the line starting with GRUB_CMDLINE_LINUX_DEFAULT, adding the parameter nvidia-drm.modeset=1 to the text inside the double-quotes. If you haven't added any parameters before, it likely just contains quiet splash. So the changed line would be GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nvidia-drm.modeset=1".

  3. Now save the file and run sudo update-grub to make the changes take effect.

  4. Restart the system.

-1

I didn't have the "Enable Force Composition Pipeline or Force Full Composition Pipeline" setting in the graphical Nvidia X server setting window nor did the command $ xrandr --output eDP-1-1 --set "PRIME Synchronization" 1 worked for me (it just didn't change the parameter value for some reason).

But when under "RRIME profiles" of the "NVIDIA X Server Settings" I selected "NVIDIA On-Demand" and restarted I got rid of the screen tearing.

Note: somebody commented that's because on demand uses intel not nvidia so it's probably not a very good solution

1
  • 1
    That's because the On-demand uses Intel unless explicitly commanded to use nvidia.
    – doug
    Nov 20, 2020 at 10:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.