15

I just upgraded from Ubuntu 18.04 to 20.04 on one of the Dell XPS 13 machines, and the network performance is abhorrent. Internet speed is very fast from a google speed test (>300Mb/s for both upload and download).

However, whenever I try to browse a website or even run sudo apt update the connection will often time out. My internet is very fast on all other devices and I really don't know how to debug this problem.

sudo lshw -class network -short && nmcli device status

shows

H/W path           Device           Class          Description
==============================================================
/0/100/1c.6/0      wlp2s0           network        Wi-Fi 6 AX200
/3                 br-96f5b790e29e  network        Ethernet interface
/4                 br-15e76fb81c05  network        Ethernet interface
/5                 docker0          network        Ethernet interface

DEVICE           TYPE      STATE         CONNECTION      
wlp2s0           wifi      connected     CSA HQ          
br-15e76fb81c05  bridge    connected     br-15e76fb81c05 
br-96f5b790e29e  bridge    connected     br-96f5b790e29e 
docker0          bridge    connected     docker0         
p2p-dev-wlp2s0   wifi-p2p  disconnected  --              
lo               loopback  unmanaged     --              
gpd0             tun       unmanaged     --             

Solution:

It seems like this is a pretty common problem, and one without a definitive cause. For me, it was because Ubuntu resets the TLP configuration, and the power management went back to "on". I disabled wifi power management directly by editing:

sudo nano /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

Then changed the value from 3 to 2, saved changes and rebooted.

I actually got this solution from Reddit and this worked for my case specifically but it seems like it could be caused by a bunch of other things. Read all the proposed solutions below!

  • 1
    @K7AAY I updated the question – tiega Apr 24 at 23:02
  • Same issue with the Dell Precision 5540 with the AX200 wifi (Device wlp59s0) after upgrading from Ubuntu 18.04. Using backport-iwlwifi-dkms did not work. Uninstalling backport-iwlwifi-dkms did not work. Also, power consumption was very high (minimum >22W, and often >60W). – Gorka Apr 25 at 12:21
  • 1
    I am on XPS 15 (2019) and it did not solve the problem for me. But thank you anyway sharing your findings. – Erik Kubica May 15 at 13:02
  • So far (XPS 13 / 2020) this seems to have solved it. It might be worth adding as nswer and accepting (the top voted answer doesn't fix it for me) – Andy Smith May 16 at 8:03
16

could be the "backport-iwlwifi-dkms" package

I experienced a better performance without this package, so i suggest to remove it

$ sudo apt remove backport-iwlwifi-dkms

this is a known bug

https://bugs.launchpad.net/ubuntu/+source/backport-iwlwifi-dkms/+bug/1869588

| improve this answer | |
  • I am having the same performance issue... however, when I try to uninstall the "backport-iwlwifi-dkms" package, I receive a message saing "ackage 'backport-iwlwifi-dkms' is not installed, so not removed" from apt – Rafael Apr 27 at 14:30
  • 3
    Worked for me, thanks! – Rumbles Apr 27 at 18:15
  • 1
    You've saved my life. I had installed this package while on kernel 4.x with 18.04 because support for wifi/bluetooth for my board only came on kernel 5.x. As Ubuntu 20.04 uses kernel 5.x the package was conflicting with the new kernel and that was the cause! – DallaRosa May 11 at 14:36
  • 1
    After days of multiple changes and tests on DNS over TLS issues, working with systemd-resolved, stubby, and NetworkManager, this was the real issue. Removing this package fixed my stalling network. It wasn't DNS issues I thought it was due to the repeated failures I saw while debugging. Thank you. – m1st0 May 25 at 2:09
3

Thanks a lot for all information you provided above.

Here I want to tell you about my situation.

I have an XPS-13-9360 (i7-8550U,16G,1T) and manually installed a killer 1650 (aka. intel ax 200). I was facing the same issue, extremely slow wireless connection.

And it seems that the problem has been solved since I installed a linux-5.6.7-generic kernel. (While the last one was 5.4.0-low-latency, I don't know why I installed low latency version, all that I did was do-release-upgrade from Ubuntu 19.10 with 5.3 kernels).

Here I recommend that you install a generic kernel instead of all one (by uname -sr, you can see what kind of kernel you are using), and upgrade to a newer kernel if possible.

BTW, I didn't sacrifice WiFi 6 and it seems OK with Linux 5.6.7

Bests, Leon

| improve this answer | |
  • Are you GOD? Boy you rock! :D installed kernel, updated grub and now my WiFi is working at full sleep instead of dialup. Finally after few hours of trying and googling different solutions. – Erik Kubica May 15 at 13:20
2

I was having the same problem with slow wireless internet speed and what worked for me was to follow the steps proposed in the following post:

Very slow internet connection on ubuntu 16.04

Basically, I edited the file /etc/gai.conf as super user:

sudo nano /etc/gai.conf

Then I looked for the line with precedence ::ffff:0:0/96 100 and removed the # character that preceded it. I had to reboot my system for it to take effect. It worked like a charm.

The funny thing is that when I was using Ubuntu 20.04 Beta, this problem did not happen. Later, when I installed the LTS version, I started having this problem.

| improve this answer | |
  • I am on XPS 15 (2019) and it did not solve the problem for me. But thank you anyway sharing your findings. – Erik Kubica May 15 at 13:02
  • Unfortunately there seems to be multiple reasons why network performance can be slow on Ubuntu. I recommend you read this article from 2019 that lists many possible solutions to wireless internet issues on Linux: itsfoss.com/speed-up-slow-wifi-connection-ubuntu – Rafael May 16 at 15:25
  • the final solution that worked was from the guy who wrote that kernel needs to be updated from 5.4 to anything higher. – Erik Kubica May 17 at 8:29
1

I had the same problem with an Intel AX200 and Ubuntu 20.04 - extremely slow. Sort of working, but dialup speeds at best.

I updated to the latest Ubuntu mainline kernel build, and now it performs well. This script can make it easy to manage mainline kernel installation and updates.

If you go down this path, consider that it will be up to you to stay on top of security vulnerabilities.

| improve this answer | |
  • 1
    This appears to have worked for me, although it should only really be considered a temporary fix, hopefully I can revert back to a stable kernel soon – Rumbles Apr 25 at 12:00
1

The top voted answer didn't solve it for me and I got this solution from a different source.

This was because Ubuntu resets the TLP configuration when I upgraded from 18.04 to 20.04, and the power management went back to "on". I disabled wifi power management directly by editing /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf and changed the value from 3 to 2, saved changes and rebooted.

| improve this answer | |
0

Selecting the proprietary wireless driver solved the problem from me.

Steps:

  1. Search and open "Additional Drivers"
  2. Look for the Wireless Network Adapter driver's entry.
  3. Check if the option "Do not use this device" is selected.
  4. If yes, select the driver of your computer's network adapter which mentions "(proprietary)" in the end.

Here's how it looks on my machine (second driver - Broadcom)

enter image description here

| improve this answer | |
0

Also updated from Ubuntu 18.04 to 20.04 on a Dell XPS 7390, had the same problem, and the accepted solution worked well for a bit (see comments):

sudo nano /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

I would just add for any other newbies like me that Ctrl + o and then Enter saves the changes made, and Ctrl + x then exits nano mode (https://wiki.gentoo.org/wiki/Nano/Basics_Guide). While here, Ctrl + Alt + t is how you open the terminal where you'd enter all these commands.

My current download speed (compared to a Win10 machine on the same desk) is 87 Kbps (vs. 19Mbps), and upload is 6.7 Mbps (vs. 8.5Mbps).

| improve this answer | |
  • Scratch that. It seemed to help a little bit, but then the Tor Browser would hang for minutes, and Firefox tabs to anything non-Google took the same. I reverted the change back to the original "3" and this way at least Tor loads, if still slowly. – zulu May 5 at 19:24
  • I also tried deleting the package as Giovanni Rodríguez said, $ sudo apt remove backport-iwlwifi-dkms, which seemed to make matters worse (luckily I could still wirelessly reinstall it via $ sudo apt install backport-iwlwifi-dkms). I also looked for "Additional Drivers" but didn't have any that Pale Blue Dot had. – zulu May 5 at 19:37
  • Still troubleshooting. Updating the DNS to 8.8.8.8 from 127.0.0.53 (securitronlinux.com/debian-testing/…), following these instructions (askubuntu.com/questions/249203/…) did not make a difference. – zulu May 6 at 15:34
  • Tried reinstalling Ubuntu; couldn't find much information on how to do it via terminal but tried ostechnix.com/…. After restarting it seems a bit faster, or at least not hanging up mid-load on websites. This could be because of the updated DNS from above though. It's noticeably faster on sites I've already visited, even with cache clearing. YouTube videos load after just an initial pause, with no breaks afterwards. fast.com shows downloads (v. Win10) are 72Kbps (v. 21Mbps) and uploads are 7.4Mbps (v. 7.5Mbps). – zulu May 6 at 16:14
  • I am facing the same issue. Removing backport-iwlwifi-dkms worked for a while but then I am having 23bps. It is horrible. – Leo May 7 at 2:13
-2

I faced the exact same problem also the same laptop model after upgrade to ubuntu 20.04 I tried many things and here are some results but still, I couldn't find out what is the problem.

****Don't follow these steps blindly if you want to fix this problem on you pc, because I couldn't at the end. I'm just writing down it to find more idea about it *****

Okay then, Just google and very few websites are working throw the wifi but the rest of the websites don't open or it takes a long time to open. so I started with ping and it ping works properly with domains and IPs:

➜  Downloads ping cnn.com                 
PING cnn.com (151.101.65.67) 56(84) bytes of data.
64 bytes from 151.101.65.67 (151.101.65.67): icmp_seq=1 ttl=57 time=20.6 ms
64 bytes from 151.101.65.67 (151.101.65.67): icmp_seq=2 ttl=57 time=33.2 ms
64 bytes from 151.101.65.67 (151.101.65.67): icmp_seq=3 ttl=57 time=59.5 ms
^C
--- cnn.com ping statistics ---
4 packets transmitted, 3 received, 25% packet loss, time 3004ms
rtt min/avg/max/mdev = 20.623/37.781/59.532/16.213 ms

Then I tried to fetch the sites with wget:

Here is the result with the cable:

➜  Downloads wget https://edition.cnn.com/
--2020-04-26 21:36:59--  https://edition.cnn.com/
Resolving edition.cnn.com (edition.cnn.com)... 151.101.193.67, 151.101.65.67, 151.101.129.67, ...
Connecting to edition.cnn.com (edition.cnn.com)|151.101.193.67|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1119208 (1.1M) [text/html]
Saving to: ‘index.html’

index.html          100%[===================>]   1.07M  5.21MB/s    in 0.2s    

2020-04-26 21:36:59 (5.21 MB/s) - ‘index.html’ saved [1119208/1119208]

and here with WIFI:

➜  Downloads wget https://edition.cnn.com/
--2020-04-26 21:37:34--  https://edition.cnn.com/
Resolving edition.cnn.com (edition.cnn.com)... 151.101.65.67, 151.101.129.67, 151.101.193.67, ...
Connecting to edition.cnn.com (edition.cnn.com)|151.101.65.67|:443... connected.
HTTP request sent, awaiting response... 

as you can see it got stuck in the sending request ... and also sometimes it works after a 30 second which is long time.

so, here is my wifi info:

➜  Downloads lspci -nnk | grep -A2 0280          
02:00.0 Network controller [0280]: Intel Corporation Wi-Fi 6 AX200 [8086:2723] (rev 1a)
    Subsystem: Bigfoot Networks, Inc. Wi-Fi 6 AX200 [1a56:1653]
    Kernel driver in use: iwlwifi

then I tried to check iwconfig:

➜  Downloads iwconfig                  
veth70fdc20  no wireless extensions.

wlp2s0    no wireless extensions.

br-4e37ef7da225  no wireless extensions.

vethdb21925  no wireless extensions.

lo        no wireless extensions.

docker0   no wireless extensions.

usb0      no wireless extensions.

as you can see wlp2s0 has no wireless extensions which I think It shouldn't be like this. (It would be perfect if somebody with a right wifi connection tell us if iwconfig should show what exactly?)

Then I tried to check /etc/network/interfaces to see if the wifi with DHCP is defined or not here is the result:

➜  Downloads sudo nano /etc/network/interfaces  

# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

then I changed it and manually add wlp2s0 to the file and didn't work too.

I'd appreciate it if someone knows any way to find the problem.

Best,

| improve this answer | |
  • 1
    Welcome to AskUbuntu! This is a Q & A site which might be a bit different from what you are used to. I recommend that you take the tour and review askubuntu.com/help/how-to-answer Cheers! – Elder Geek Apr 27 at 20:37

Not the answer you're looking for? Browse other questions tagged or ask your own question.