10

I did an upgrade today to the latest version of ubuntu. Everything looked good and fine only for me to discover that I cannot find my applications after clicking the 'Show Applications' icon. The same applies when I search for an application in the search bar, I do not see it. It shows me an endless search.

These are the screenshot images of the problem:

Screenshot 1

Screenshot 2

In the meantime, I access my applications from the menu at the top bar and also use the terminal to run applications with CLI.

  • 2
    I also have this issue. Additionally, when I click "Frequent" at the bottom of the application list (to show frequently used applications), the desktop environment briefly crashes. Does this also happen for you? – SpencerDub Apr 24 at 23:11
  • 1
    @SpencerDub Yes, I also have this same issue. It crashes briefly. – FOBABS Apr 25 at 12:00
9

In my case, this was being caused by an extension. In my particular case once I deactivated the Appfolders management extension which I had included in 18.04 LTS and restarted the computer everything worked perfectly.

Here's how to do that if you can't access your applications via the Launcher:

  1. Press Ctrl+Alt+T on your keyboard to open a Terminal window.
  2. In the Terminal, type gnome-tweaks and hit Enter. This will launch the GNOME Tweaks application.
  3. In GNOME Tweaks, click Extensions in the left-hand pane.
  4. Deactivate individual extensions by clicking the switch next to them. Alternatively, you can use the switch at the top of the window to deactivate all extensions at once.
  5. When you have deactivated the extensions, you need to restart your shell. Press Alt+F2 to open a 'Run a Command' dialog.
  6. In the 'Run a Command' dialog, type r and press Enter. This will restart the shell.
  7. Open your launcher to see if the problem is fixed. Use these steps and the process of elimination to determine if an extension is causing the bugged behavior.
| improve this answer | |
  • 1
    I just did as you said and it worked instantly. You don't actually have to restart the computer, you can just use ALT + F2 and input r. Thanks a bunch, Andre, you are a real MVP. – FOBABS Apr 25 at 22:48
  • I just noticed a little bug there. It doesn't respond perfectly well especially when you open folders already grouped. Though, I believe the next update would fix it. I can still run around with it for now. – FOBABS Apr 25 at 23:00
  • This was my experience as well. I completely reinstalled 20.04, including wiping the drive, and it worked swimmingly until I reactivated Appfolders Management. Deactivating it again fixed the problem. Andre, I'm going to edit your answer with some keyboard shortcuts so people who are used to the GUI can use this answer. :) – SpencerDub Apr 26 at 15:53
  • Amazing - how did you think to try this? – Startec May 18 at 20:09
2

I disabled all GNOME extensions as suggested by pomsky and after a restart of GNOME-shell the applications were shown again in the dash! Afterwards I reactived one GNOME extension after the other and finally, when I came to the appfolder-management extension, the applications were gone again. So I deactivated the appfolder-management extension again and everything were fine again.

So I can confirm, that there's a problem with the appfolder-management extension but to be safe you have to disable ALL extensions first and then reactivate them EXCEPT the appfolder-managment extension. Furthermore, after GNOME shell 3.33 there's no need for that extension, because after 3.33, GNOME Shell handles this feature natively.

| improve this answer | |
0

I ran into the same issue even though my extensions were disabled. It turned out to be caused by having the new theme - Yaru (previously called Communitheme) - installed on 18.04 before upgrade. After switching from Communitheme to Yaru in Gnome tweak tool and from "Ubuntu Communitheme" to "Ubuntu" during login under gear icon, the issue went away.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.