6

After Upgrading from 18.04 to 20.04 I've notices several warnings during shutdown or reboot like:

Failed to unmount /oldroot: Device or Resource busy
Failed to unmount /oldroot/dev/pts: Device or Resource busy
Failed to unmount /oldroot/dev: Device or Resource busy
Failed to unmount /oldroot/sys: Device or Resource busy

Sometimes it's visible on the screen, sometimes it's covered by the splash.
I cannot find anything related using journalctl or logs, the only thing I've found is:

abr 23 22:24:36 vanburen07-G5-5590 sudo[6451]: vanburen07 : TTY=pts/0 ; PWD=/home/vanburen07 ; USER=root ; COMMAND=/bin/umount /oldroot/dev/pts

There's nothing specific in fstab:

 <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/nvme0n1p3 during installation
UUID=063c6892-66d6-4598-9dcf-82136ad4ea81 /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/nvme0n1p1 during installation
UUID=C000-EAB9  /boot/efi       vfat    umask=0077      0       1
/swapfile                                 none            swap    sw              0       0

The only thing I was able to find were on Arch/Manajaro forums and the suggested workaround is to modify a file that doesn't esxist in Ubuntu: /etc/mkinitcpio.conf

I don't think this is a huge issue as it doesn't cause visible crush or even error in syslogs but yet it'd be nice to know the reason.

4
  • I'm also experiencing this on Kubuntu 20.04...but it wasn't an upgrade, it was a fresh install. I've tried multiple kernel versions but it makes no difference - the latest 5.4, as well as the latest 5.6.
    – J23
    May 27, 2020 at 7:36
  • not exactly sure why but it has gone after reinstalling it formating the disk. that can be the difference May 27, 2020 at 16:36
  • Have you posted a bug report on the launchpad? I have the same issue, and I always install fresh with formatting of partitions. Launchpad is the place for bug reports... not here. ;-) Indeed, same as you, it seems to have no effect at all but spit a few lines on the screen on shutdown, so probably not a dramatic bug!
    – Zakhar
    Jun 25, 2020 at 16:18
  • No I haven't, since the issue is gone and I haven't recieved a lot of feedback here I considered it not essencial and rather related to my system/upgrade. Jun 26, 2020 at 20:22

3 Answers 3

3

Hope this will help. I think it is because of the unused kernel because I have upgraded my ubuntu from 18.04 LTS to 20.04 LTS and in few days after that I encountered the problem during shutdown and restart.

Just remove all unused kernels without doing clean re installation of the system, just visit this link on removing unused kernels --> https://www.cyberciti.biz/faq/ubuntu-18-04-remove-all-unused-old-kernels/

God Bless everyone.

1

This happened to me too after switching motherboards. It turns out that a MBR compatibility setting was hidden inside the Windows submenu (that I skipped initially) which seems to cause this.

After changing these settings, the error disappeared:

  • BIOS>Settings>Boot>Boot Mode Select [LEGACY+UEFI] set to UEFI
  • BIOS>Settings>Advanced>Windows OS Configuration>BIOS UEFI/CSM Mode set to UEFI
3
  • it's happening mostly those laptop, which has Intel C-State error. Dec 13, 2020 at 7:03
  • Solved via the hint, thanks! Sep 13, 2021 at 21:32
  • I don't have that option in latest Dell Laptop. Is there a different name for this? Oct 9 at 8:09
0

Seems to be related to update from 18.04, for some reason it left some old legacty Kernels untouched. Reinstalling system (because of another issue) solved the problem.

1
  • 2
    Sorry Ivan, your statement is not true, as I have a brand new laptop on 20.04 LTS, installed from scratch. and I experience the same issue.
    – Chris
    Jul 9, 2021 at 9:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .