3

After upgrading from 18.04 > 20.04 my internal soundcard of my laptop is not proberly recognized by pulseaudio. Altough alsamixer is shwoing the card. Any hints?

aplay -l
**** Liste der Hardware-Geräte (PLAYBACK) ****
Karte 0: PCH [HDA Intel PCH], Gerät 0: ALC293 Analog [ALC293 Analog]
  Sub-Geräte: 0/1
  Sub-Gerät #0: subdevice #0
Karte 0: PCH [HDA Intel PCH], Gerät 3: HDMI 0 [HDMI 0]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
Karte 0: PCH [HDA Intel PCH], Gerät 7: HDMI 1 [HDMI 1]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
Karte 0: PCH [HDA Intel PCH], Gerät 8: HDMI 2 [HDMI 2]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
Karte 0: PCH [HDA Intel PCH], Gerät 9: HDMI 3 [HDMI 3]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
Karte 0: PCH [HDA Intel PCH], Gerät 10: HDMI 4 [HDMI 4]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
Karte 1: Dock [USB3.0 Dual Video Dock], Gerät 0: USB Audio [USB Audio]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0

The HDA Intel PCH is the right device see:

lspci
00:00.0 Host bridge: Intel Corporation Coffee Lake HOST and DRAM Controller (rev 0b)
00:02.0 VGA compatible controller: Intel Corporation UHD Graphics 620 (Whiskey Lake)
00:12.0 Signal processing controller: Intel Corporation Cannon Point-LP Thermal Controller (rev 30)
00:14.0 USB controller: Intel Corporation Cannon Point-LP USB 3.1 xHCI Controller (rev 30)
00:14.2 RAM memory: Intel Corporation Cannon Point-LP Shared SRAM (rev 30)
00:16.0 Communication controller: Intel Corporation Cannon Point-LP MEI Controller #1 (rev 30)
00:17.0 SATA controller: Intel Corporation Cannon Point-LP SATA Controller [AHCI Mode] (rev 30)
00:1c.0 PCI bridge: Intel Corporation Cannon Point-LP PCI Express Root Port #5 (rev f0)
00:1d.0 PCI bridge: Intel Corporation Cannon Point-LP PCI Express Root Port #9 (rev f0)
00:1d.1 PCI bridge: Intel Corporation Cannon Point-LP PCI Express Root Port #10 (rev f0)
00:1f.0 ISA bridge: Intel Corporation Cannon Point-LP LPC Controller (rev 30)
00:1f.3 Audio device: Intel Corporation Cannon Point-LP High Definition Audio Controller (rev 30)
00:1f.4 SMBus: Intel Corporation Cannon Point-LP SMBus Controller (rev 30)
00:1f.5 Serial bus controller [0c80]: Intel Corporation Cannon Point-LP SPI Controller (rev 30)
39:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTL8411B PCI Express Card Reader (rev 01)
39:00.1 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 12)
3a:00.0 Network controller: Intel Corporation Wireless-AC 9260 (rev 29)

When i open pavucontrol the card is not showing up. Sees that there is something wrong. I already tried the following followed by a reboot:

sudo apt-get --purge remove linux-sound-base alsa-base alsa-utils
sudo apt-get install linux-sound-base alsa-base alsa-utils

Did not help unfortunately... Any hints?

  • okay i tried to play a file with aplay which is also not working seems that alsa is also affected... – benjamin10 Apr 24 at 16:44
  • I wonder is this related to my issue: askubuntu.com/questions/1230333/… – Avi Avinash Apr 24 at 19:34
  • Related: askubuntu.com/a/1165640/968501 – Raffa Apr 24 at 19:47
  • Having the same issue. pavucontrol does not detect my onboard sound card, but it does detect my external sound card. Workaround does not work for me. – Greg Apr 25 at 7:54
  • I tried the solution of paulc found here and It worked. – Mohamed Bendaoud Apr 25 at 23:23
3

If you get things working with

sudo alsa force-reload

But need to repeat it every time you reboot, it's worth trying:

sudo apt purge timidity-daemon

then reboot.

This worked for me after an upgrade from 18.04 to 20.04. Before making this change sound worked fine if I booted using the old linux kernel from 18.04 (which was left on my system after the upgrade). So for my system the problem was how timidity daemon worked with the 5.4 kernel.

| improve this answer | |
  • 1
    I did sudo apt purge timidity while trying to play music, and the sound immidiatly came on. – Alexey May 30 at 6:53
  • sudo alsa force-reload fixed this issue after upgrade from 18.04 to 20.04. I only had to do it once, not every reboot – Marius Bjørnstad Jun 3 at 11:44
  • sudo apt purge timidity-daemon also did it for me as @Alexey also found. Thank you – fwg Aug 19 at 18:17
0

Okay I found a workaround

sudo alsa force-reload

brought back my soundcard to life. So i decided to put a script with the follwing content into startup script:

#!/bin/bash
sudo alsa force-reload

and fired the script up into:

sudo chmod +x /etc/rc.local
sudo nano /etc/rc.local

and put the line in:

sh /path/to/alsa_force_reload.sh

F3 and save. That workes for me. For the time being ;)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.