12

I recently upgraded to Ubuntu 20.04 lts from 18.04 lts. After reboot audio is not working. I tried to reinstall pulseaudio and alsa but still not working. sudo apt-get install --reinstall alsa-base pulseaudio sudo alsa force-reload still not working.

output

 └─▶ inxi -SMA
System:    Host: Wizard Kernel: 5.4.0-26-generic x86_64 bits: 64 Desktop: Gnome 3.36.1 Distro: Ubuntu 20.04 LTS (Focal Fossa) 
Machine:   Type: Portable System: Dell product: Vostro 2520 v: N/A serial: <superuser/root required> 
           Mobo: Dell model: 0V1NDP v: A11 serial: <superuser/root required> BIOS: Dell v: A11 date: 02/24/2014 
Audio:     Device-1: Intel 7 Series/C216 Family High Definition Audio driver: snd_hda_intel 
           Sound Server: ALSA v: k5.4.0-26-generic 

output

└─▶ lspci 
00:00.0 Host bridge: Intel Corporation 3rd Gen Core processor DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
00:16.0 Communication controller: Intel Corporation 7 Series/C216 Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 7 Series/C216 Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 7 Series/C216 Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 7 Series/C216 Chipset Family PCI Express Root Port 1 (rev c4)
00:1c.3 PCI bridge: Intel Corporation 7 Series/C216 Chipset Family PCI Express Root Port 4 (rev c4)
00:1c.5 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 6 (rev c4)
00:1d.0 USB controller: Intel Corporation 7 Series/C216 Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation HM75 Express Chipset LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 7 Series Chipset Family 6-port SATA Controller [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 7 Series/C216 Chipset Family SMBus Controller (rev 04)
07:00.0 Network controller: Broadcom Inc. and subsidiaries BCM43142 802.11b/g/n (rev 01)
09:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 07)

please help me... thanks in advance.

3

Just in case somebody reached this question looking for a solution. The only native solution (no need to do something external) is provided by @Nate on this link https://askubuntu.com/a/37609/9598 which I reproduce partially here to give you a clue on how to fix this problem.

I [...] noticed that the ACLs weren't set in /dev/snd

sudo setfacl -m u:username:rw /dev/snd/*

So, running this command in a terminal will fix the issue.

| improve this answer | |
5

I think i have a workaround for your problem: Try

sudo alsa force-reload

This brought my soundcard back to life. But it doesn't survive a reboot, so I am working on making the change persistent... See:

https://www.maketecheasier.com/fix-no-sound-issue-ubuntu/

| improve this answer | |
  • I already tried this.. see at question – Injamul Mohammad Mollah Apr 24 at 19:34
  • this works for me on Dell XPS L502X, and keeps working after sleep. – geoffrey Apr 29 at 18:20
  • @geoffrey, why shouldn't it be working after sleep? – Alexey May 4 at 8:37
  • Well because it's said that it doesn't persist after reboot. I don't know the internal working. I just wanted to add the info, maybe it could help someone diagnosing the problem better. – geoffrey May 5 at 9:08
  • @geoffrey, reboot has nothing to do with sleep. Sleep changes nothing, your comment almost certainly will not help. – Alexey May 16 at 13:26
5

Mine is a Dell Inspiron 1525. I tried all the solutions listed here on askubuntu.com and all over the web but of no use and finally to find that it is a bug in Ubuntu 20.04 LTS/kernel-5.4 (Focal kernel) where the internal sound card is not detected. The driver soc-skl is disabled by default from kernel-5.4. Kernels 5.5, 5.6 all disabled this driver. Read the bug reports here and here.

It affects many users. There is nothing much we can do until the kernels are fixed.

For me, the headphones and mic are working. For the time being, connecting the headphone jacks to external speakers solves the problem.

| improve this answer | |
5

What fixed it for me after an upgrade to 20.04 was:

sudo apt purge timidity-daemon

Then reboot.
Quick and easy so worth trying!

| improve this answer | |
  • 1
    this worked for me. None of the other things did. – Space Bear May 5 at 13:07
  • 2
    Didn't work for me. I don't have timidity-daemon installed – Greg May 10 at 10:16
  • This worked for me as well! – cberner Jun 23 at 5:05
  • I don't have timidity-daemon installed too – Lebnik Aug 7 at 20:28
4

Your speakers may be detected as unplugged which causes them to be ignored.

Temporary fix:

  1. sudo apt install pavucontrol
  2. Run pavucontrol
  3. Configuration tab > Profile > Analogue Stereo Output (unplugged) (unavailable)

Speakers should work but it will reset when headphones are unplugged or system rebooted.

Permanent fix:

  1. sudo apt install alsa-tools-gui
  2. Run hdajackretask
  3. Parser hints > jack_detect = no
  4. Apply now
  5. Install boot override
| improve this answer | |
  • The second one worked for me, even if there were error messages when I applied it. – billy May 14 at 11:22
  • Tried everything for asus zenbook pro ux434f but didnt work. Finally permanent fix worked for me after a restart (didn't installed boot override though). I will read the documentation and would then install boot override. – Niranjan Jun 7 at 18:30
2

I tried all the solutions listed here on askubuntu.com and all over the web but of no use and finally to find that it is a bug in Ubuntu 20.04 LTS/kernel-5.4 (Focal kernel) where the internal sound card is not detected.

@Greg gave me The patch which is working for me

sudo add-apt-repository ppa:kaihengfeng/fix-lp1869819 sudo apt-get upgrade

Now Sound is working fine.

https://answers.launchpad.net/ubuntu/+source/alsa-driver/+question/690180

https://launchpad.net/~kaihengfeng/+archive/ubuntu/fix-lp1869819

| improve this answer | |
-1

Original:

Também fiz uma atualização do 19.0 para o 20.04 e ocorreu o mesmo problema (tenho um Dell Inspiron 1525) retornei para o 19.10 e o som funciona normalmente usei o #sudo alsa force-reload. e também não voltou, já quando eu coloco alto-falantes bluetooth funciona normalmente.

Translated:

I also upgraded from 19.0 to 20.04 and the same problem occurred (I have a Dell Inspiron 1525) I returned to 19.10 and the sound works normally using #sudo alsa force-reload. and it didn't come back, since when I put bluetooth speakers it works normally.

| improve this answer | |
  • I do not think this answer helps to resolve the OP's problem. – Alexey May 4 at 8:39
-2

Having a similar issue with the onboard sound not working (External sound card works)

sudo alsa force-reload

Didn't fix it for me.

Have logged a issue https://answers.launchpad.net/ubuntu/+source/alsa-driver/+question/690180

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.