5

I just upgraded to Ubuntu 20.04 and wanted to try the Deepin Desktop Environment which looks great. I added the PPA (ppa:leaeasy/dde) to the known repositories as recommended. But there are some dependencies that cannot be resolved when trying apt install dde.

The package qtbase-abi-5-9-5 cannot be installed: It looks like to be a virtual package that points to libqt5core5a which is already installed. The real package is installed but the virtual package is not referenced as installed.

This library is used by Plasma and many others so I don't really want to uninstall/reinstall it with the virtual package.

Is there an easy workaround to get the qtbase-abi-5-9-5 package "installed" or bypass this dependency when installing DDE?

EDIT: apt-cache policy dde

  dde:
  Installed: (none)
  Candidate: 15.4+16
  Version table:
     15.4+16 500
        500 http://ppa.launchpad.net/leaeasy/dde/ubuntu bionic/main amd64 Packages
        500 http://ppa.launchpad.net/leaeasy/dde/ubuntu bionic/main i386 Packages
  • It is unclear which PPA provides package for focal. Please add output of apt-cache policy dde to the question body. – N0rbert Apr 24 at 14:23
  • This PPA is exclusively for bionic, but I enabled the Ubuntu repositories for this release too. Actually, I don't know if that should work correctly. – MatPy Apr 24 at 15:03
6

Update 20200515:

UbuntuDDE team has provided stable PPA. You can install packages from it:

sudo add-apt-repository ppa:ubuntudde-dev/stable
sudo apt-get install ubuntudde-dde

Tried to fix this in a fast way on VM, downloaded a dozen of deb-packages including libqt5core5a which provides qtbase-abi-5-9-5 and got serious dependency issue. Manual installation of packages from different releases may harm your system, so it is safer to revert these changes and to wait for packages with DDE specially prepared for 20.04 LTS.

Also I have searched the LaunchPad.net and found other PPA from Ubuntu DDE team - ppa:openarun/dde-dev. It allows to install DDE on Focal.

So you have to remove other PPA(s) by commands like:

sudo apt-get install ppa-purge
sudo ppa-purge ppa:leaeasy/dde

and add this PPA to the system

sudo add-apt-repository ppa:openarun/dde-dev
sudo apt-get install ubuntudde-*

and then it should work:

Ubuntu DDE login

Ubuntu DDE desktop

| improve this answer | |
  • 2
    This PPA is what is needed! Thanks! I used to search for PPA with Google which doesn't seem very efficient. – MatPy Apr 24 at 20:40
  • How did you pick that ppa over all the others which provide deepin packages? Official team? – init_js Apr 30 at 7:10
  • By visiting launchpad.net/ubuntudde , launchpad.net/ubuntu/+ppas , using deduction and logic :) – N0rbert Apr 30 at 8:02
  • use sudo add-apt-repository ppa:ubuntudde-dev/stable . This is the updated and most secure way . – Afsal May 15 at 13:09
  • Every time I try this it doesn't work. – Goddard Jun 11 at 3:26
4
sudo add-apt-repository ppa:ubuntudde-dev/stable
sudo apt update
sudo apt install ubuntudde-dde
| improve this answer | |
3

There is a stable UbuntuDDE release for focal fossa here: https://launchpad.net/~ubuntudde-dev/+archive/ubuntu/stable

Use:

sudo add-apt-repository ppa:ubuntudde-dev/stable
sudo apt-get update

I have tried it out on my focal installation successfully.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.