1

I am a Gourmet user for my cooking recipes, I found no better alternative on Ubuntu for that. Gnome Recipes is attractive and promising, but dev is not very active from what I can see, and it lacks import function which is mandatory to me, as I have a huge list of my own recipes.

I checked in a VM to install Gourmet on Ubuntu 20.04 with no luck : I can install Python 2.7 (no more installed by default), I can find a Gourmet .deb package (removed from store), but when tying to install (with GDebi) I have that error : Dependency error not satisfied with python-gtk2 (>= 2.22.0)

And python-gtk2 package is no more available. So I am stuck here !

  • We are working on the new version of Gourmet which will be python3 compatible. I hope it will be distributed via original channels. Any contribution is highly appreciated!: github.com/kirienko/gourmet – Yury Kirienko May 1 at 8:58
1

Installation is still possible, but you have to download packages manually from previous Ubuntu releases with commands below:

mkdir -p ~/Downloads/gourmet
cd ~/Downloads/gourmet

wget http://archive.ubuntu.com/ubuntu/pool/universe/g/gourmet/gourmet_0.17.4-7_all.deb
wget http://archive.ubuntu.com/ubuntu/pool/universe/p/pygtk/python-gtk2_2.24.0-6_amd64.deb
wget http://security.ubuntu.com/ubuntu/pool/universe/p/python-reportlab/python-reportlab_3.5.23-1ubuntu0.1_all.deb
wget http://archive.ubuntu.com/ubuntu/pool/universe/e/elib.intl/python-elib.intl_0.0.3~git20110809-5_all.deb
wget http://security.ubuntu.com/ubuntu/pool/universe/p/python-reportlab/python-reportlab-accel_3.5.23-1ubuntu0.1_amd64.deb
wget http://archive.ubuntu.com/ubuntu/pool/universe/p/pygtkspellcheck/python-gtkspellcheck_4.0.5-1_all.deb
wget http://archive.ubuntu.com/ubuntu/pool/universe/p/pyenchant/python-enchant_2.0.0-1_all.deb
wget http://archive.ubuntu.com/ubuntu/pool/universe/p/python-mechanize/python-mechanize_0.2.5-3_all.deb
wget http://archive.ubuntu.com/ubuntu/pool/universe/b/beautifulsoup/python-beautifulsoup_3.2.1-1_all.deb

sudo apt-get install ./*.deb
| improve this answer | |
  • Thank you so much ! It works perfectly. – pled Apr 24 at 17:15
0

In Ubuntu 20.04 install python-cairo

sudo apt install python-cairo

Configurando python-cairo:amd64 (1.16.2-2ubuntu2)... Configurando python-gtk2 (2.24.0-6)...

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.