18

I used this method in 18.04 (https://joshtronic.com/2017/07/26/hide-title-bars-in-gnome-shell/) but it doesn't working now... Any ideas?

P.S. I used a standard desktop environment

P.P.S. To be more precise: I used to have a clean terminal without ANY bars, status bars, borders etc. in any window size and I am trying to achieve this again in new ubuntu 20.04.

1
  • Unite works great if you want to merge window title with the header bar.
    – pLumo
    Commented Apr 24, 2020 at 8:16

5 Answers 5

24

What finally worked for me was to run:

sudo apt install gnome-shell-extension-pixelsaver
gnome-extensions enable [email protected]
gsettings set org.gnome.Terminal.Legacy.Settings headerbar false

in the terminal, then restart the shell (Alt-F2, r).

3
  • Thanks, that's a solution! And so simple this time.
    – Q. Q.
    Commented Apr 27, 2020 at 7:28
  • I got E: Package 'gnome-shell-extension-pixelsaver' has no installation candidate on Ubuntu 22.04.3 LTS.
    – Jasha
    Commented Jan 31 at 19:08
  • 1
    On 22.04, you need to install gnome-shell-extension-manager and then install the Pixelsaver extension through that. Commented Feb 2 at 9:29
10

Very simple!

  1. Install dconf-editor

    for ubuntu-like distros
    sudo apt install dconf-editor

    for arch distros
    pacman -S dconf-editor

  2. Open dconf-editor

  3. Go to /org/gnome/terminal/legacy/headerbar

  4. Disable "Default value" and change "Custom value" to "False".

  5. Close all your gnome-terminal windows and then reopen your terminal. Voilà!

To remove menu bar, in terminal go to "View" and uncheck "Show menu bar" (or something else).

[Edit]

OR
Just open your terminal, copy and paste code below:
gsettings set org.gnome.Terminal.Legacy.Settings headerbar "@mb false"

If didn't work, install dconf-cli and try again.

To remove menu bar in terminal, go to "View", and uncheck "Show menu bar" (or something else).

2
  • 2
    This not appear to work in ubuntu 22
    – Kay
    Commented Dec 10, 2022 at 15:16
  • The second suggestion, gsettings set org.gnome.Terminal.Legacy.Settings headerbar "@mb false", worked lovely in Debian bookworm.
    – clarkevans
    Commented Jun 25, 2023 at 21:49
1

I use Unite and it works for me.

To install Unite you need to open up Firefox and install an add on. Just visit Firefox addons page for to install gnome shell integration. Once ready, click + Add to Firefox

After that, in terminal enter this code:

sudo apt install chrome-gnome-shell

Finally, visit Unite extension page and slide the button up right from off to on. The extension will be installed. You can refresh the page to click on the configurations button of the extensions on the same page.

5
  • 1
    This extension does nothing to terminal at all.
    – Q. Q.
    Commented Apr 24, 2020 at 10:58
  • 1
    Same here. Unite does a lot of useful things, but the window titlebar stays where it is for all GTK3 apps. Works for Firefox etc., but not for Terminal, GEdit etc. Commented Apr 26, 2020 at 10:45
  • It works great for me, thanks ! Took me a while to realize it is installed and controlled via FIREFOX ONLY.
    – Alon
    Commented Oct 27, 2020 at 9:35
  • Unite only can remove decorations on Xorg. Ubuntu 21.04 puts you on Wayland, even after an upgrade.
    – vanadium
    Commented Aug 18, 2021 at 6:42
  • The first two comments from Q.Q and Florian were misleading. The Unite works great. Please refer to stackoverflow.com/a/71908794/941508 for more details.
    – Chris.Q
    Commented Apr 20 at 20:27
1

Since this is still a relevant question, but other answers do not work on Ubuntu 22+ or delete all titlebars instead of only the terminal one, I thought that an update might be nice. I tried to write something that works out-of-the-box and shared the snippet on github in this repo :)

This is tested to work on Ubuntu 23.10 and removes ONLY the terminal titlebar/headerbar.

You can just copy the css or use the script in the repo if you're lazy :)

1
  • Copying over the CSS applied immediately after restarting the Gnome terminal on Fedora 39.
    – user598527
    Commented Mar 20 at 12:45
0

I found a solution on this site: https://joshtronic.com/2017/07/26/hide-title-bars-in-gnome-shell/

Copy this code from site and paste in ~/.config/gtk-3.0/gtk.css (open this with gedit or nano (I used gedit)).

After that save and you can close that windows (gedit) and I prefer you open new terminal. After you done that part, in shell (terminal) paste this code: gsettings set org.gnome.Terminal.Legacy.Settings headerbar "@mb false"

(this command is on that site too), after that do ALT + F2 and put latter "r" in command line, click ENTER. This fixed my problem. You just need to open new terminal and see if that worked.

^ If this doesnt work than open terminal and paste those commands: sudo apt install gnome-shell-extension-pixelsaver gnome-extensions enable [email protected] gsettings set org.gnome.Terminal.Legacy.Settings headerbar false

and after that go to ~/.config/gtk-3.0/gtk.css if code you paste that disapear copy it and paste it again. Again, run command line: gsettings set org.gnome.Terminal.Legacy.Settings headerbar "@mb false"

And after that do ALT+F2 and in command line put latter r and click ENTER. You just need to open new terminal and see if that worked.

I hope this helped some. Nice day to all of you guys! :)

Answer by: -epeu

I had the same problem and asked for help today and somehow find some solution: (link to my question and solution) https://askubuntu.com/a/1387051/1561747

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .