0

My Gnome installation (Ubuntu 18.04) appears to be broken. After I log in, it displays some log messages and hangs. The last message says in effect "Starting Gnome." I've tried removing the proprietary graphics drivers and switching to a radically different graphics card; neither measure helped.

I assume, but am not sure, that Ubuntu itself is intact. It appears to work just as it should when I boot to rescue mode.

How can I repair my system with a minimum of disruption?

I found instructions for installing Gnome...

https://linuxconfig.org/how-to-install-gnome-on-ubuntu-18-04-bionic-beaver-linux

...and for repairing Linux...

https://www.ostechnix.com/how-to-fix-broken-ubuntu-os-without-reinstalling-it/

The first set of instructions are admirably simple: install a few packages. It seems to me that I should be able to uninstall the broken Gnome by removing the same packages in reverse order, but I don't know whether that is the best approach; I suspect that after I reinstall Gnome I'll have to reinstall all of my graphic applications. I'd prefer instructions specifically for repairing Gnome, but I haven't found any.

The latter instructions assume a system that functions in rescue mode, but don't distinguish between "repairing" Ubuntu and Gnome, so I'm not sure just what they're meant to accomplish. The system's useless as it is, but I'd rather know what this experiment is supposed to do before I undertake it.

Perhaps I should just restore the Linux partition with dd. If I save my current data first I won't lose anything. The only disadvantage is that I'll have to reconstruct whatever software I installed or reconfigured after my last backup.

9
  • You may have a bad GNOME Shell extension. Go to extensions.gnome.org/local and temporarily disable ALL extensions, restart GNOME Shell or reboot, and see if your problem is gone. If so, only enable one extension at a time until you find the bad one. – heynnema Apr 24 '20 at 16:49
  • Thought I responded to this yesterday, but my message isn't here. I'm afraid your suggestion didn't help; it actually made things worse. When I restarted the computer after disabling extensions, Gnome displayed the Ubuntu logo, then a black screen with blinking underline cursor a few lines below the top. After a considerable wait I tried pressing Ctrl+C; the computer displayed a flickering "^C" echo for a few seconds, then went black. When I tried to reboot it went straight to black. I can still boot to recovery mode, but the GUI no longer gets even as far as it did before! – Jonathan Sachs Apr 28 '20 at 6:55
  • Disabling GNOME Shell extensions won't cause your current symptom. At the GRUB menu, can you boot to a prior kernel? Do you have a Ubuntu Live DVD/USB and do you know how to run fsck? Did you perform any of the commands from the two links that you gave? Report back and I'll try to help you. – heynnema Apr 28 '20 at 13:42
  • Sorry about the slow response. This is the season when computing competes with gardening. /// I tried booting to all three prior kernels in the GRUB menu. They all fail the same way. Some display more log entries than others before crashing. I have photographs of those if they will help. /// I have a Ubuntu Live DVD. I tried booting it; no problem. /// I didn't try any of those links. I wanted more advice first, for the reasons I detailed. /// I've used fsck, although I refer to the instructions each time. No hesitation about doing it again if that's advised. – Jonathan Sachs May 10 '20 at 3:14
0

To check your file system...

  • boot to a Ubuntu Live DVD/USB in “Try Ubuntu” mode
  • open a terminal window by pressing Ctrl+Alt+T
  • type sudo fdisk -l
  • identify the /dev/sdXX device name for your "Linux Filesystem"
  • type sudo fsck -f /dev/sda5, replacing sdXX with the number you found earlier
  • type sudo fsck -f /dev/sda6
  • repeat the fsck command if there were errors
  • type reboot

To check your disk's SMART...

Start the Disks application. Select your HDD. Go to the "hamburger" icon and select SMART Data & Tests. Get screenshot(s) of the SMART Data and edit them into your question.

The SMART values says that the disk is OK. The only problem is there's a ton of command timeouts. I suspect a bad SATA cable.

Boot crashes...

Take pictures of your boot screen output. Either edit them into your question, or put them on imgur.com.

Update #1:

With the command timeout errors on the SATA disk subsystem, and we tried new SATA cables, and a backup drive worked fine when reinstalled back into the system, we conclude that the primary HDD is defective, or needs to be re-initialized and Ubuntu reinstalled.

17
  • fsck appears to say that my disks are OK. See jhsachs.com/DSCN8634.JPG. (/dev/sda5 in my Linux volume; /dev/sda6 is an additional volume.) /// SMART shows that the disk is not in good shape (no surprise, it's a beater) but is still functional. I can still boot Windows 10 from it consistently without problems. See jhsachs.comm/DSCN8636.JPG. – Jonathan Sachs May 25 '20 at 6:12
  • @JonathanSachs Actually, the SMART looks ok, except for a ton of command timeouts. In terminal do grep -i FPDMA /var/log/syslog*. Is this a desktop or laptop? Report back. – heynnema May 25 '20 at 13:57
  • I tried that - no output at all. The system is a desktop, or more precisely a benchtop. – Jonathan Sachs May 27 '20 at 5:14
  • @JonathanSachs Did you show me a picture of the boot screen? Anyway, I suspect that your SATA drive cable may be bad, or the SATA port itself might be flakey. So you have another cable, or can you move the cable to a different port? – heynnema May 27 '20 at 15:11
  • I have a picture of the boot screen but I haven't uploaded it yet. I'm having problems with my ISP and currently can't upload anything -- I'll make it available as soon as I can. /// I tried changing the SATA connector & cable but the results were actually worse: Linux froze in the same place but left the screen blinking. I restored the original cable and connector but attached a different drive; no problem booting. /// The drive that works is a backup of the problem drive, but it's not as current as I'd like. I still hope I can restore the original one to health. – Jonathan Sachs May 31 '20 at 3:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.