0

I am very new to Linux and trying to use this application server named Lucee. I am using Ubuntu 18.04. The instructions I am following say to download the application using wget.

When I run this command:

wget http://release.lucee.org/rest/update/provider/loader/5.3.1.102 

in my browser, I get a .jar file.

When I run it from my linux terminal it does download the file, but it removes the .jar extension because when I do an ls in the /tmp directory all I see is "5.3.1.102"

How do I prevent it from being converted or altered if possible?

  • Or the server might be misconfigured and sending different headers to browsers and command-line clients. Won't be the first time. – muru Apr 24 at 1:33
  • Welcome to AskUbuntu, the original file location is cdn.lucee.org/lucee-5.3.1.102.jar redirected to the url on your post. – Sadaharu Wakisaka Apr 24 at 1:35
1

You can use the hard link that you can see in the wget output... although you can download it (other version maybe) from the downloads page. Why don't you?

wget http://release.lucee.org/rest/update/provider/loader/5.3.1.102 
--2020-04-23 22:33:36--  http://release.lucee.org/rest/update/provider/loader/5.3.1.102
Resolving release.lucee.org (release.lucee.org)... 205.210.189.210
Connecting to release.lucee.org (release.lucee.org)|205.210.189.210|:80... connected.
HTTP request sent, awaiting response... 302 Found
Location: https://cdn.lucee.org/lucee-5.3.1.102.jar [following]

Then:

wget https://cdn.lucee.org/lucee-5.3.1.102.jar
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.