14

After upgrading to ubuntu 20.04 the hdmi sound stopped working. If I select headphones as audio output they work well, but if I change to HDMI output it doesn't work.

Also I noticed that when I select HDMI output the "configuration" option disappear.

If I select headphones as output, the configurations look like this:

enter image description here

when I select HDMI output, the configurations look like this:

enter image description here

And no sound is played.

What can I do to fix this?

3
  • Try Option #3 in this answer – Raffa Apr 23 '20 at 23:28
  • Please help us with identifying your sound hardware with sudo lspci -v && lsmod | grep snd Please run that, then highlight the results, copy with Ctrl-Shift-C , come back here, do edit, and paste the results into your question.to add that so all the facts we need are in the question. Please also tell us the make and model part number (from the serial number sticker) of your PC. Please don't use Add Comment, since that's our channel to you. All facts about your system should go in the Question with edit – K7AAY Apr 23 '20 at 23:32
  • 1
    Unfortunately none of the answers here worked for my setup: I've a desktop connected to a ThinkVision monitor. I'm using the sound output on the monitor that does work on Windows. I'll come back to update If I find a way to solve it – Rudolf Real Jul 26 '20 at 16:59
10

Suggestion of Raffa works for me on a laptop Asus UX303L !

rm -r ~/.config/pulse/
reboot

and it's ok now

2
  • 1
    This worked for me. What's concerning is that it was working for the first week, then stopped working one day. I have a feeling I'll be needing to do this whenever pulseaudio forgets how to work... – basicdays May 10 '20 at 20:03
  • Same here, worked on Asus UX303LA – chris Aug 22 '20 at 21:34
14

Reboot should not be necessary if you just need to reinitialize pulse, just do a:

killall pulseaudio; rm -rf ~/.config/pulse/* ; rm -rf ~/.pulse*

and you should be good as well.

2

In my case, following upgrade to Ubuntu 20.04, HDMI output is just not listed anymore in sound settings if I plug or turn on my TV after logging in.

I am not sure this will help with the particular issue you are encountering, but the workaround for me is to open a terminal and run:

pulseaudio -k

then re-open the sound settings, where HDMI output can be selected and works as expected.

1

Reboot with the HDMI connected, I had that "bug" or fail, and restarting with the HDMI connected Ubuntu detects the sound, but if you connect the HDMI after the start, it doesn't. It happens since 20.04 (not on 19.10). This is just a workaround.

0

Ubuntu 20.04 only shows the option to push audio though HDMI when there it is actually connected (unlike previous versions)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.