4

I am curious how am I supposed to switch to using the nvidia card on my ubuntu 20.04 setup?

on 18.04 once installed, I could just plug in and go.. seems with 20.04 it is using both iGPU and PCI-E GPU... I see the device is here, I have nvidia-smi responding with output.. but the ubuntu gnome resolution is only going up to 1920x1080.. telling me it's using the intel iGPU off my core i7 2600K

Edit:

strangely, after reinstalling.. it now eroneously occupies the GPU even though I only get intel resolutions..

how do I revert so the iGPU is used 100% and the GPU is left freed ?

enter image description here

1
+75

Try changing the driver in Software & Updates --> Additional Drivers.

| improve this answer | |
0

This solution was given to me and tested via the NVIDIA linux forums

Essentially start the NVIDIA X Server settings:

https://forums.developer.nvidia.com/t/ubuntu-20-04-fresh-install-looking-for-how-to-use-prime-to-use-igpu-on-desktop-intel-gtx-1060/124195/2

under PRIME profiles select

NVIDIA OnDemand

next, you need to do the following :

  • add ‘nogpumanager’ kernel parameter

See https://wiki.ubuntu.com/Kernel/KernelBootParameters if you're unfamiliar with that step

  • delete /usr/share/X11/xorg.conf.d/11-nvidia-offload.conf
  • create /etc/X11/xorg.conf with contents:
   Section "Device"
       Identifier     "intel"
       Driver         "modesetting"
       BusID          "PCI:0:2:0"
   EndSection
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.