33

Today I did a clean install of the new Ubuntu 20.04 Focal Fossa. Since then I can no longer mount folders on my NAS, which was possible on 18.04 and on Windows.

It's exactly the same issue as this one: Ubuntu 20.04 Focal Fossa (development branch) Nautilus can't mount a NAS That issue got closed for being off-topic because 20.04 was not a stable release back then. It is now, so I guess it is on-topic now?

The German message posted in that Question is Failed to mount Windows share: Software caused connection abort in the English version.

Things I tried so far:

  • downgrading samba
  • adding client min protocol = CORE to /etc/samba/smb.conf
  • adding client min protocol = SMB3 and client max protocol = SMB3 to /etc/samba/smb.conf

None of these seemed to fix the issue.

5
  • I have exactly the same problem after doing a fresh install of 20.04. I have two NAS devices a QNAP and a D-Link. Both could be accessed from Files, + Other locations in Ubuntu 18.04, 19.04 & 19.10 where they are/were listed. In 20.04 although they are both still listed only the QNAP is still accessible from this window. The D-Link is not and when selected connections fail with the "Failed to mount Windows share: Software caused connection abort" message. I do not have a /etc/samba/smb.conf file on my system so there's nothing to edit. BIG, BIG PROBLEM - may have to downgrade! Apr 27, 2020 at 7:41
  • Same problem with Synology NAS, version is DSM 6.2.3. May 12, 2020 at 17:57
  • I found some interesting information in Ubuntu 20.04 release notes : with Samba 4.11, SMB1 is disabled by default. Source : wiki.ubuntu.com/FocalFossa/ReleaseNotes#Samba_4.11 May 16, 2020 at 12:18
  • For more details, see Samba 4.11.0 release notes : samba.org/samba/history/samba-4.11.0.html May 16, 2020 at 12:20
  • For me, it is now solved after today's (may 21) Ubuntu upgrade to samba 2:4.11.6+dfsg-0ubuntu1.2. With full samba installed and "client min protocol = NT1" add to smb.conf I can mount the NAS share and the objects (avi, jpg, etc.) are seen and treated properly as objects not as folders. I haven't tried with just samba-common installed.
    – ross minet
    May 21, 2020 at 14:49

7 Answers 7

48

Same issue here.

Since version 4, both Samba Server & Samba Clients do not allow an older level of protocols negotiation. You have to enable them in smb.conf file

Edit /etc/samba/smb.conf file (need root permissions)

in the [global] section, add the following line

client min protocol = NT1

Save the file and exit the editor.

You must restart the Samba Service for this change to take effect. In a terminal, enter this command:

sudo service smbd restart

You should be able to access your samba shares successfully. If you cannot connect to your samba share, you can lower even more the protocol security in smb.conf (not recommended), by using:

client min protocol = CORE

Cheers!

13
  • 5
    Unfortunately it did not work.
    – Opifex
    Apr 25, 2020 at 15:27
  • 1
    This answer worked for me on Xubuntu 20.04 fresh upgrade from 19.10. Did not need the CORE line, just the edit to smb.conf and a service restart. May 8, 2020 at 8:37
  • 1
    Adding 'client min protocol = NT1' allows you to access/mount the NAS share but all objects are seen as folders, bugs.launchpad.net/ubuntu/+source/samba/+bug/1872476 They say (page bottom) it's been fixed recently.
    – ross minet
    May 14, 2020 at 13:45
  • For reference, the full list of protocol versions that can be specified with client min protocol is here: samba.org/samba/docs/current/man-html/… , which supports NT1 as the last version < SMB 2, though for now this has the files-as-directories issue as noted
    – rakslice
    May 15, 2020 at 6:58
  • 1
    @rossminet The PPA mentioned in the comments of that bug report does avoid the files-as-directories issue for me.
    – rakslice
    May 15, 2020 at 7:10
6

Same issue here. It worked out of the box in 18 and 19 without any further step. It's easy to check with a 18,19 live dvd. In a february discussion, they wondered if this out of the box feature should be scraped in 20.04.

Samba.libs and samba.common are installed by default in 18,19, 20.04 but it does not work in the latter Simply installing the full Samba package, which installs /etc/samba/smb.conf. and adding under [GLOBAL] client min protocol = NT1 or CORE does not work. You can access the NAS folder but every object text, jpg etc. is treated as a folder.

There is a bug report relating to NAS and samba. https://bugs.launchpad.net/ubuntu/+source/samba/+bug/1872476 If you install full samba add NT1 to smb.conf (installed by full samba), you can access the NAS share but all objects in the share (avi, jp, txt, etc.) are seen as folders.

1
  • 3
    I'm having the same issue. After setting the min Protocol to NT1, i can access to my folders but all the files are shown as folders. Once i copy them to my computer I can open them correclty, but it's a "pain" to do this way.
    – Nothor
    May 2, 2020 at 20:33
4

I had the same issue with a Synology NAS running under DSM 6.3.

In the control panel (Synology's Web UI), the previous values for SMB settings were :

Maximum SMB protocol = SMB1
Minimum SMB protocol = SMB1

I changed Maximum SMB protocol to SMB3, and it seems to be working fine.


You can find these settings in Control Panel > File Services > SMB/AFP/NFS > SMB.
Then go to Advanced Settings.

See online help here : https://www.synology.com/en-global/knowledgebase/DSM/help/DSM/AdminCenter/file_winmacnfs_win

9
  • Unfortunately, Gulllaume, all those edit to smb.conf (CORE, NT1, SMB3, etc.) don't work. With full Samba package installed (not by default), you may access/mount the NAS share but all objects (avi, jpg, text, etc.) are seen as folders! A behaviour unique to NAS share. Sharing other folders is perfectly ok. In 18-19, it work out of the box right from the live DVD without smb.conf There are so many proposed workaround (like a PPA) that dont't work and seem to point rather to a bug. I tried CIFS and NFS, I did not get past the elementary stage: the NAS is undetected (no such file).
    – ross minet
    May 14, 2020 at 12:35
  • 2
    I didn't have to touch smb.conf in my case, only changed the settings on my NAS. May 16, 2020 at 12:24
  • Just like Opiflex (see answer below) there's no such option on my ZyXEL EMG2926 router. Only a page defining write/read options with or without passwords. It works perfectly under Win 10 and Ubu 18-19. If I need to exchange files from shares, samba works well except with NAS. I can simply switch to Win 10 to access NAS.
    – ross minet
    May 17, 2020 at 17:03
  • 1
    OK I understand. On some routers or ISP boxes, the NAS feature is offered but is not the main one. So it offers the minimal features, without options to customize it. In France we have the same problem with the ISB box Freebox Revolution, stuck with SMB v1 (free.fr/freebox/freebox-revolution). May 18, 2020 at 6:55
  • 1
    So the only solution for now seems to be what you proposed first, ie : editing smb.conf and modifying client min protocol. But apparently it is buggy ? I haven't tried this. You can find details here : samba.org/samba/history/samba-4.11.0.html May 18, 2020 at 13:23
2

I had to go into my NAS settings and allow access from all versions of SMB up to 3. It only allowed version 1 by default.

3
  • 2
    I couldn't find any of these settings in my NAS. The only thing I found was some UNIX/Mac compatibility feature, but this didn't change anything. (And it wasn't needed for use with Ubuntu 18.04 either)
    – Opifex
    Apr 25, 2020 at 15:28
  • Only some NAS devices offer these settings and unfortunately neither of mine do. My Buffalo NAS is fine but the D-Link is not with only .txt files showing as actual files. All others show as folders and even trying to copy them off gives an error and they will not copy so all my data is inaccessible until this has been fixed!
    – DonP
    May 29, 2020 at 8:21
  • At least Synology has these settings.
    – user205301
    Sep 4, 2020 at 9:59
2

solution https://troglobit.com/2020/02/Fixing-file-sharing-in-Ubuntu-20.04/

In /etc/samba/smb.conf Add the following line to the [global] section: client min protocol = CORE

3
  • 2
    In the OP it was already mentioned that this did not work.
    – Opifex
    Apr 27, 2020 at 14:21
  • Great! This solution worked for me - Many thanks... Apr 28, 2020 at 15:44
  • With full samba (only libs and common are installed in 18-19-20), general file and directory sharing works well in all versions including 20.04. But in 20.04, with full samba, Nautilus can mount the share (so it seems to work) but all objects (jpg avi txt, etc.) are treated as folders. It's a NAS share specific problem.
    – ross minet
    May 4, 2020 at 13:45
0

I had the same issue except server using SMBv1. Adding "client min protocol = NT1" to /etc/samba/smb.conf fixed this for me

1
  • 3
    Unfortunately, this did not work for me.
    – Opifex
    Apr 25, 2020 at 15:27
0

I had a fresh install of 20.04, and it took me these two steps to get the sharing working with Ubuntu 18:

Configure the workgroup's protocol at /etc/samba/smb.conf (here SMB3 wouldn't work):

client min protocol = CORE
server min protocol = CORE

Set a Samba password for the user:

sudo smbpasswd -a <user name>

Not the answer you're looking for? Browse other questions tagged or ask your own question.