25

I´ve just installed 20.04 on my laptop, replacing 19.10.

The USB installer process worked perfectly, but after rebooting, I´m getting a black screen right after the grub, with no text, and selecting recovery mode gets stuck on "loading initial ramdisk".

I have tried editing the boot parameters, removing quiet splash, and changing gfxmode $linux_gfx_mode for gfxmode text, to be able to see some kind of info at boot, but the black screen still persists.

Any suggestion?

Machine: DELL Inspiron 15 5567 AMD Radeon R7 M445 Graphics Intel i7 Processor

Dual boot Ubuntu 20.04 + Windows 10 (it was working fine with 19.10)

Bios: Uefi, security OFF.

3

4 Answers 4

23

I had the same problem. My computer is a Dell Inspiron 15.

The problem is with UEFI. To fix it you can turn off PPT in the UEFI/BIOS options and enable Legacy Boot.

8
  • Hey Victor, thank you! It was the PPT option indeed, turning it off solves the problem. Ubuntu can boot correctly now, it's a bit strange that 19.10 had no problem booting up, even with PPT turned on.
    – DonTropo
    Apr 23, 2020 at 20:35
  • 4
    I'm facing the same problem but I don't find any settings for PPT in BIOS. Can you please share where is located in Dell Inspiron 15 3521?
    – GNB
    Apr 24, 2020 at 18:36
  • 1
    @DonTropo same pc and same probem here, can you say to us where to find that option?
    – ScTALE
    Apr 25, 2020 at 14:12
  • 4
    You can find the "PPT Security" option in the BIOS under the Security tab, you have to uncheck "PPT On". I did not have to enable the Legacy Boot in order to boot 20.04 correctly.
    – DonTropo
    Apr 26, 2020 at 15:17
  • 2
    On brand new Latitude 5400, the PTT option is replaced by TPM (see dell.com/support/article/fr-fr/how12395/…). But this change nothing, and the "Legacy Boot Mode" is no longer present. See the answser of @Amias (askubuntu.com/a/1250303/706066) for the right solution.
    – AnTiToinE
    Aug 26, 2020 at 10:27
11

I too found the same thing on my Inspiron 5567. I had PPT on also, but could still boot any Ubuntu version before 20.04 as well. I'm wondering what's causing this.

However, I did not have to turn Legacy boot on. Just turning PPT off worked just fine.

For those who are new to the BIOS, press F2 when you see the Dell logo, go to Security -> PTT Security and uncheck PTT On. Click Apply (I would recommend choosing Save as Custom User Settings), then OK, then Exit.

2
  • If this question had a bounty I'd award it to you. How did you figure that out? You have my utmost respect. Jun 10, 2020 at 20:57
  • @starbeamrainbowlabs you can start a bounty on the question with "Reward existing answer". That's what I usually do :)
    – Matthieu
    Aug 20, 2020 at 15:08
8

I had this problem on a Dell Precision m3800. It seemed to have something to do with the boot splash screen.

I fixed it by disabling the splash. I did this by removing splash from GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub and running:

sudo update-grub

to apply the change.

6
  • i have not had problems with secure boot being on or off with ubuntu.
    – Amias
    Jul 30, 2020 at 11:19
  • This solve the issue on a brand new Latitude 5400. Changing the TPM/PTT do nothing, and the Legacy Boot option is no longer present. So this is the right solution to apply.
    – AnTiToinE
    Aug 26, 2020 at 10:24
  • I can't thank you enough Amias. I used your solution and it fixed my (very frustrating) problem. I have read other solutions and tried few but they did not work for me. Some solutions blame the AMD graphic card but I don't even have an AMD card. Thanks a bunch.
    – user25406
    Oct 6, 2020 at 18:45
  • 1
    Maybe your solution is connected with this of mine and related to UEFI, and can be applied in this full form, editing /etc/default/grub replacing GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" with GRUB_CMDLINE_LINUX_DEFAULT="dis_ucode_ldr"
    – FantomX1
    Apr 21, 2021 at 11:57
  • 1
    @FantomX1 thank you! Finally I booted the Ubuntu...
    – scarface
    Jul 25, 2021 at 16:21
2

For me, the problem was that I would get only a black screen when trying to boot 5.11.0.34, but I could boot 5.11.0.27 with no problem. I resolved it by stepping back from nvidia-driver-470 to nvidia-driver-450. You can find the GUI to make this change in Software & Updates | Additional Drivers.

Steve

1

Not the answer you're looking for? Browse other questions tagged or ask your own question.