10

I´ve just installed 20.04 on my laptop, replacing 19.10.

The USB installer process worked perfectly, but after rebooting, I´m getting a black screen right after the grub, with no text, and selecting recovery mode gets stuck on "loading initial ramdisk".

I have tried editing the boot parameters, removing quiet splash, and changing gfxmode $linux_gfx_mode for gfxmode text, to be able to see some kind of info at boot, but the black screen still persists.

Any suggestion?

Machine: DELL Inspiron 15 5567 AMD Radeon R7 M445 Graphics Intel i7 Processor

Dual boot Ubuntu 20.04 + Windows 10 (it was working fine with 19.10)

Bios: Uefi, security OFF.

13

I had the same problem. My computer is a Dell Inspiron 15.

The problem is with UEFI. To fix it you can turn off PPT in the UEFI/BIOS options and enable Legacy Boot.

| improve this answer | |
  • Hey Victor, thank you! It was the PPT option indeed, turning it off solves the problem. Ubuntu can boot correctly now, it's a bit strange that 19.10 had no problem booting up, even with PPT turned on. – DonTropo Apr 23 at 20:35
  • I have the same issue and I know that Ubuntu supports TPM (wiki.ubuntu.com/UEFI/SecureBoot) so in theory it should work as it did previously. – P4C Apr 24 at 14:30
  • 1
    I'm facing the same problem but I don't find any settings for PPT in BIOS. Can you please share where is located in Dell Inspiron 15 3521? – GNB Apr 24 at 18:36
  • 1
    @DonTropo same pc and same probem here, can you say to us where to find that option? – ScTALE Apr 25 at 14:12
  • 3
    You can find the "PPT Security" option in the BIOS under the Security tab, you have to uncheck "PPT On". I did not have to enable the Legacy Boot in order to boot 20.04 correctly. – DonTropo Apr 26 at 15:17
9

I too found the same thing on my Inspiron 5567. I had PPT on also, but could still boot any Ubuntu version before 20.04 as well. I'm wondering what's causing this.

However, I did not have to turn Legacy boot on. Just turning PPT off worked just fine.

For those who are new to the BIOS, press F2 when you see the Dell logo, go to Security -> PTT Security and uncheck PTT On. Click Apply (I would recommend choosing Save as Custom User Settings), then OK, then Exit.

| improve this answer | |
  • 1
    Thanks it fix my issue ! – Jérôme B Jun 1 at 12:55
  • If this question had a bounty I'd award it to you. How did you figure that out? You have my utmost respect. – starbeamrainbowlabs Jun 10 at 20:57
  • Thanks a lot! Thanks a lot!!! – Mumbaikar007 Jun 12 at 4:04
1

I had this problem on a Dell Precision m3800.

Seemed to be something to do with the boot splash screen.

I fixed it by disabling the splash .

do this by removing splash from GRUB_CMDLINE_LINUX_DEFAULT in /etc/defaults/grub

then to apply the change i ran sudo update-grub.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.