1

So after the clean install (of Ubuntu 20.04), everything worked perfect. I downloaded some files, used internet, all was OK. But after the first reboot the Wi-Fi just doesn't work at all.

The Wi-Fi card is an RTL8723AE . I have the same issues as: wifi networks lost after updating

I have tried the following:

sudo apt-get update && sudo apt-get install build-essential git dkms    
sudo apt-get install mokutil && mokutil --sb-state    
sudo apt-get install git build-essential linux-headers-$(uname -r)    
git clone https://github.com/lwfinger/rtlwifi_new.git    
cd rtlwifi_new    
make    
sudo make install    
rm -v -R --interactive=never rtlwif*

Also some variants as:

git clone -b extended https://github.com/lwfinger/rtlwifi_new.git
sudo dkms add ./rtlwifi_new
sudo dkms install rtlwifi-new/0.6
sudo modprobe -r rtl8723ae && sudo modprobe rtl8723ae
echo "options rtl8723ae ant_sel=3" | sudo tee /etc/modprobe.d/rtl8723ae.conf

But I have no good result. The point is: It was already working fine, why it all went wrong with a reboot? If it was working properly at first, what could be happening now?

I also attach the text file generated by the Wireless Script (created when I made this question in ubuntu forums: https://ubuntuforums.org/showthread.php?t=370108): https://pastebin.com/fHEDL5Yk

Thank you very much for your help. (I made this question here before but 20.04 was not already oficial so they closed it. Now it is available, and I've re-verified with another fresh install with the oficial 20.04, and I still have no Wi-Fi. Not even in the beggining with the installation.)

Results for $ lsmod | grep rtl

rtl8723ae              90112  0
btcoexist             155648  1 rtl8723ae
rtl8723_common         24576  1 rtl8723ae
rtl_pci                28672  1 rtl8723ae
rtlwifi                90112  4 rtl_pci,btcoexist,rtl8723ae,rtl8723_common
mac80211              843776  3 rtl_pci,rtl8723ae,rtlwifi
btrtl                  24576  1 btusb
cfg80211              704512  2 rtlwifi,mac80211
bluetooth             581632  31 btrtl,btintel,btbcm,bnep,btusb,rfcomm

Results for $ lspci -knn | grep Net -A3; rfkill list:

04:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8723AE PCIe Wireless Network Adapter [10ec:8723]
    Subsystem: Realtek Semiconductor Co., Ltd. RTL8723AE PCIe Wireless Network Adapter [10ec:0726]
    Kernel driver in use: rtl8723ae
    Kernel modules: rtl8723ae
05:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTL8411 PCI Express Card Reader [10ec:5289] (rev 01)
0: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

Output for $ dmesg | grep 8723 :

[    0.147894] pci 0000:04:00.0: [10ec:8723] type 00 class 0x028000
[    1.077465] usb 3-7: New USB device found, idVendor=0bda, idProduct=8723, bcdDevice= 2.00
[    3.344439] Bluetooth: hci0: RTL: loading rtl_bt/rtl8723a_fw.bin
[    3.426191] rtl8723ae: Using firmware rtlwifi/rtl8723fw_B.bin
[    3.556218] rtl8723ae 0000:04:00.0 wlp4s0: renamed from wlan0
[    6.943635] rtl8723ae: ***** Before switch (c2h_event.cmd_id)
[    6.943849] rtl8723ae: ***** Before switch (c2h_event.cmd_id)
[    6.944286] rtl8723ae: ***** Before switch (c2h_event.cmd_id)
[    6.945908] rtl8723ae: ***** Before switch (c2h_event.cmd_id)
[    6.947019] rtl8723ae: ***** Before switch (c2h_event.cmd_id)
[    6.947880] rtl8723ae: ***** Before switch (c2h_event.cmd_id)
[    6.948227] rtl8723ae: ***** Before switch (c2h_event.cmd_id)
[    6.948663] rtl8723ae: ***** Before switch (c2h_event.cmd_id)
[    6.948948] rtl8723ae: ***** Before switch (c2h_event.cmd_id)
[    6.949191] rtl8723ae: ***** Before switch (c2h_event.cmd_id)
[    6.949457] rtl8723ae: ***** Before switch (c2h_event.cmd_id)
[   10.442737] rtl8723ae: ***** Before switch (c2h_event.cmd_id)
[   33.450917] rtl8723ae: ***** Before switch (c2h_event.cmd_id)
[   47.134911] rtl8723ae: ***** Before switch (c2h_event.cmd_id)
[   90.457744] rtl8723ae: ***** Before switch (c2h_event.cmd_id)
[  108.088089] rtl8723ae: ***** Before switch (c2h_event.cmd_id)
[  172.090897] rtl8723ae: ***** Before switch (c2h_event.cmd_id)
[  208.602618] rtl8723ae: ***** Before switch (c2h_event.cmd_id)
[  273.115580] rtl8723ae: ***** Before switch (c2h_event.cmd_id)

Installed kernel 5.6.7-050607-generic but didn't result. Wi-Fi still not working

Output for $ dmesg | grep 8723

[    0.148284] pci 0000:04:00.0: [10ec:8723] type 00 class 0x028000
[    1.221886] usb 3-7: New USB device found, idVendor=0bda, idProduct=8723, bcdDevice= 2.00
[    3.415513] Bluetooth: hci0: RTL: loading rtl_bt/rtl8723a_fw.bin
[    3.458617] rtl8723ae: Using firmware rtlwifi/rtl8723fw_B.bin
[    3.589877] rtl8723ae 0000:04:00.0 wlp4s0: renamed from wlan0
[   11.540903] rtl8723ae: ***** Before switch (c2h_event.cmd_id)
[   34.532879] rtl8723ae: ***** Before switch (c2h_event.cmd_id)
[   67.661409] rtl8723ae: ***** Before switch (c2h_event.cmd_id)
[  110.646875] rtl8723ae: ***** Before switch (c2h_event.cmd_id)
[  163.705916] rtl8723ae: ***** Before switch (c2h_event.cmd_id)
[  226.648493] rtl8723ae: ***** Before switch (c2h_event.cmd_id)
[  289.698981] rtl8723ae: ***** Before switch (c2h_event.cmd_id)
[  352.723416] rtl8723ae: ***** Before switch (c2h_event.cmd_id)

LAST EDIT, I MADE IT WORK FOR A WHILE Since it's a totally random thing, I re-run the ubuntuforums script to see the differences between when it works and when it doesn't. The major differences are as follows:

GENERAL.DEVICE:                         enp5s0f2
GENERAL.TYPE:                           ethernet
GENERAL.NM-TYPE:                        NMDeviceEthernet
GENERAL.DBUS-PATH:                      /org/freedesktop/NetworkManager/Devices/2
GENERAL.VENDOR:                         Realtek Semiconductor Co., Ltd.
GENERAL.PRODUCT:                        RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
GENERAL.DRIVER:                         r8169
GENERAL.DRIVER-VERSION:                 --
GENERAL.FIRMWARE-VERSION:               --
GENERAL.HWADDR:                         <MAC 'enp5s0f2' [IF1]>
GENERAL.MTU:                            1500
GENERAL.STATE:                          20 (unavailable)
GENERAL.REASON:                         2 (Device is now managed)


##When there was NO  WIFI the value of GENERAL.REASON was: 40 (Carrier/link changed)

Also dmesg has changed a lot from this (WIFI NOT Working):

##### dmesg #############################

[    6.990240] r8169 0000:05:00.2 enp5s0f2: Link is Down

[    7.387187] rtlwifi: ****** Calling c2h_command_handle with hw 00000000a4ada57c
[    7.387215] rtl8723ae: ***** Before switch (c2h_event.cmd_id)
[    7.387218] rtlwifi: ****** back from c2h_command_handle
[   11.502458] rtlwifi: ****** Calling c2h_command_handle with hw 00000000a4ada57c                                                         

[   11.520833] rtl8723ae: ***** Before switch (c2h_event.cmd_id)
[   11.523569] rtlwifi: ****** back from c2h_command_handle


[   34.572875] rtlwifi: ****** Calling c2h_command_handle with hw 00000000a4ada57c
[   34.928824] rtl8723ae: ***** Before switch (c2h_event.cmd_id)
[   34.932942] rtlwifi: ****** back from c2h_command_handle

To this (WIFI working):

##### dmesg #############################

[    7.380836] rtl8723ae: ***** Before switch (c2h_event.cmd_id)
[    7.380841] rtlwifi: ****** back from c2h_command_handle
[    7.381140] rtlwifi: ****** Calling c2h_command_handle with hw 00000000950d7059
[    7.381161] rtl8723ae: ***** Before switch (c2h_event.cmd_id)
[    7.381164] rtlwifi: ****** back from c2h_command_handle
[   34.411323] rtlwifi: ****** Calling c2h_command_handle with hw 00000000950d7059
[   34.411342] rtlwifi: ****** back from c2h_command_handle
[   34.412444] rtlwifi: ****** Calling c2h_command_handle with hw 00000000950d7059
[   34.412466] rtl8723ae: ***** Before switch (c2h_event.cmd_id)
[   34.412469] rtlwifi: ****** back from c2h_command_handle
[   35.380432] wlp4s0: authenticate with <MAC 'PROVIDER_85' [AC1]>
  • "ant_sel" is not an available driver parameter in rtl8723ae. Confirm: modinfo rtl8723ae | grep parm Please delete the incorrect file: sudo rm /etc/modprobe.d/rtl8723ae.conf Reboot and let us see a pastebin of: dmesg | grep -i rtl – chili555 Apr 23 '20 at 19:56
  • @chili555 Done it: pastebin.com/9eelwtp2 – Ayiti Apr 23 '20 at 20:36
  • It looks perfectly normal. Are available networks shown in Network Manager? How about here? nmcli device wifi list – chili555 Apr 26 '20 at 19:54
  • @chili555 Just an empty list. Maybe a 20.04 bug? – Ayiti Apr 28 '20 at 7:20
  • 1
    @Pilot6 Yes, indeed. However, in OP's question, it says the driver was installed from github with dkms. If it were there, I'd have asked that it be removed. The data you asked for is in the linked paste. – chili555 Apr 28 '20 at 20:32
1

I have exactly the same problem, but I found a workaround: each time I suspend my computer, I get the wifi connection back after waking up. I've noticed a few lines that were not there initially in dmesg:

[ 1045.522721] wlp5s0: authenticate with 0a:47:17:b9:79:d8
[ 1045.539247] wlp5s0: send auth to 0a:47:17:b9:79:d8 (try 1/3)
[ 1045.549974] wlp5s0: authenticated
[ 1045.550150] rtl8723ae 0000:05:00.0 wlp5s0: disabling HT/VHT/HE due to WEP/TKIP use
[ 1045.550840] wlp5s0: associate with 0a:47:17:b9:79:d8 (try 1/3)
[ 1045.554430] wlp5s0: RX AssocResp from 0a:47:17:b9:79:d8 (capab=0x411 status=0 aid=3)
[ 1045.554621] wlp5s0: associated
[ 1046.143069] IPv6: ADDRCONF(NETDEV_CHANGE): wlp5s0: link becomes ready

I don't know what makes it do that after waking up, especially that part: rtl8723ae 0000:05:00.0 wlp5s0: disabling HT/VHT/HE due to WEP/TKIP use

And sometimes, the wifi connection works straight away after booting up my computer. Then those previous lines are also in dmesg.

  • What is the workaround? The act of suspending and waking up? – Nmath May 11 '20 at 20:38
  • Yes, it's far from being satisfactory but it's the only thing I found so far to get the wifi up and running when it's not. I tried to reproduce the waking process when the wifi was not working, running the scripts automatically executed after suspend, but to no avail. However for the last 2 days the wifi has been working fine several times in a row after booting up, without getting any update or compiling any module ... – Liam May 13 '20 at 13:34
  • I'm sorry, my English may be responsible for that misunderstanding : - I found just one "solution", that takes 20s or so, to get the wifi to work if it doesn't after booting up : putting my computer to sleep and then waking it up. - Then, once the wifi works it always keeps working well until I shut down my computer (the signal is strong, all the networks around are detected and I can even switch seamlessly from one to another) . – Liam May 13 '20 at 20:28
  • - what I was trying to say is that I haven't had to use that solution a single time for the past 2 days because I haven't had any problem with the wifi during that period (I even did several reboots for testing purposes) - I know that the wifi can be tricky but when the wifi connection isn't working, it isn't working at all : no connection whatsoever, even with my nearby phone on hotspot mode or my brothers'phones or parents' : no network detected! I hope that I was clear enough this time and sorry again for the misunderstanding. – Liam May 13 '20 at 20:28
  • @Nmath It's exactly like that. Randomly after a time off it works. Once fixed (in my case) I have reinstalled Ubuntu to reproduce the solution and the only thing in common is leaving the PC off for a while (days in some cases) – Ayiti May 18 '20 at 19:49
0

I have the same adapter and the same problem. I have notebook with dead battery, so it always connected to the power. If I disable my notebook and leave it connected to the power, and enable it, wifi adapter is not working. If I disable the notebook, disconnect it from power, connect again, enable notebook, wifi works. Hope this information will help someone.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.