7

Edit on 15/10/2020: This's a bug found on the kernel and intel/drm drivers.

More info: https://gitlab.freedesktop.org/drm/intel/-/issues/2181

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1871721

ORIGINAL POST:

For some reason, the second monitor connected via HDMI is in black (black screen), but xrandr and Nvidia Settings detects it.

    Screen 0: minimum 8 x 8, current 2720 x 1080, maximum 16384 x 16384
eDP-1-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 344mm x 193mm
   1920x1080 60.00*+ 59.97 59.96 59.93
   1680x1050 59.95 59.88
   1600x1024 60.17
   1400x1050 59.98
   1600x900 59.99 59.94 59.95 59.82
   1280x1024 60.02
   1440x900 59.89
   1400x900 59.96 59.88
   1280x960 60.00
   1440x810 60.00 59.97
   1368x768 59.88 59.85
   1360x768 59.80 59.96
   1280x800 59.99 59.97 59.81 59.91
   1152x864 60.00
   1280x720 60.00 59.99 59.86 59.74
   1024x768 60.04 60.00
   960x720 60.00
   928x696 60.05
   896x672 60.01
   1024x576 59.95 59.96 59.90 59.82
   960x600 59.93 60.00
   960x540 59.96 59.99 59.63 59.82
   800x600 60.00 60.32 56.25
   840x525 60.01 59.88
   864x486 59.92 59.57
   800x512 60.17
   700x525 59.98
   800x450 59.95 59.82
   640x512 60.02
   720x450 59.89
   700x450 59.96 59.88
   640x480 60.00 59.94
   720x405 59.51 58.99
   684x384 59.88 59.85
   680x384 59.80 59.96
   640x400 59.88 59.98
   576x432 60.06
   640x360 59.86 59.83 59.84 59.32
   512x384 60.00
   512x288 60.00 59.92
   480x270 59.63 59.82
   400x300 60.32 56.34
   432x243 59.92 59.57
   320x240 60.05
   360x202 59.51 59.13
   320x180 59.84 59.32
DP-1-1 disconnected (normal left inverted right x axis y axis)
HDMI-1-1 disconnected (normal left inverted right x axis y axis)
HDMI-1-2 connected 800x600+1920+0 (normal left inverted right x axis y axis) 1600mm x 900mm
   1920x1080 60.00 + 50.00 59.94 30.00 25.00 24.00 29.97 23.98
   1920x1080i 60.00 50.00 59.94
   1280x1024 60.02
   1360x768 60.02
   1152x864 59.97
   1280x720 59.81 60.00 50.00 59.94
   1024x768 60.00
   800x600 60.32*
   720x576 50.00
   720x576i 50.00
   720x480 60.00 59.94
   640x480 60.00 59.94
   720x400 70.08
DP-1-2 disconnected (normal left inverted right x axis y axis)
HDMI-1-3 disconnected (normal left inverted right x axis y axis)

I tried with propietary drivers of Nvidia and Nouveau's drivers, and I have the same result. On Ubuntu 18.04 with the LTS Kernel (4.15 was?) works perfectly. Same with Windows 10. Since 19.10 it doesn't work.

The nvidia-drm modeset is on 0 (nvidia-drm modeset=0).

Laptop: Asus Intel: i5-6300 Graphic card: Nvidia GTX960m

PS: With nomodeset it works perfectly. But still, it doesn't work with propietary drivers and nouveau.

PS2: I tried with only Nvidia and only Intel graphics. No results.

PS3: I tried with a Live USB and it doesn't work neither the second monitor. This just detects a second monitor, but in the second monitor the only thing I can see is a blank screen. I'm tired trying to make this work seeing a lot of pages. Please, if anyones can tell me if someone had a similar problem or what I can do. I don't want to use again W10. Thanks!

9
  • Have you tried sudo dpkg-reconfigure gdm3: askubuntu.com/a/1229479/925971 – Gryu Apr 23 '20 at 22:31
  • Yeah, I did it. Still doesn't work. – Noctis Apr 23 '20 at 23:44
  • when you run nvidia-settings , do you see prime settings at the left corner ? Which version of driver is installed ? – hsyn26 Apr 26 '20 at 0:41
  • make sure, you are using nvidia by check settings->details->graphics – hsyn26 Apr 26 '20 at 0:49
  • 1
    Windows technique and all works after my upgrade 19.10 to 20.04: second monitor was recognized, mouse working but screen completely black but the taskbar, all icons disappeared but visible in ~/Desktop, and without the possibility to right click on it, nor change background. After some unsuccessful attempts (i.e. checking the driver and restarting the pc) I turned off just the monitor, the taskbar moved to the other one, then I turned it on again. All works fine now. – Alex Poca Jun 15 '20 at 20:12
2
  1. In the file /usr/share/X11/xorg.conf.d/10-nvidia.conf, add the line:

    Option "PrimaryGPU" "Yes"
    
  2. In the file /usr/share/X11/xorg.conf.d/10-amdgpu.conf, change the line

    from

    Driver "amdgpu"
    

    to

    Driver "modesetting"`
    
2
  • Hello Swaraj. I'm glad that you made it works changing thoses files. I already tried that and, in my case, it doesn't work. – Noctis Oct 15 '20 at 18:00
  • Thanks! This worked great for me. Laptop with Ryzen 7 4700H and nvidia GTX 1650. – Pedro Náñez Dec 15 '20 at 15:18
1

I solved it with the following: Edit /lib/modprobe.d/nvidia-kms.conf

and comment the line options nvidia-drm modeset=0 with an #

Maybe there is another way to disable the option, but I've tried many and only this one worked.

3
0

Noctis-if we followed "You can force the upgrade, however, with the following steps:

close Update Manager if it’s still running open a terminal in the same way you opened Update Manager type update-manager -d and press enter" --then we might as well become a Windows enthusiast --with even cruder thoughts on how to re-arrange any earlier and possibly required non looping essentials. ??

c/f

Is the "Final Release" a "Development Release"?

shalom

2
  • Interim (6-month) Release users: You do need to use -d to upgrade for the next few months. Since this is an LTS, the regular (non -d) upgrade won't be offered until 20.04.1. Reason: There's one mechanism, and it cannot tell the difference between interim releases and LTS releases. This is normal behavior for an LTS release, and occurs once every two years. – mcpherson robert May 17 '20 at 23:07
  • Sorry, don't know what's your point. My steps was: Ubuntu 18.04 doesn't have Nvidia on-demand, so I tried with 19.10. This ver. leave me without second monitor (I waited to 20.04 LTS). I updated to 20.04 expecting this was fixed (and it's not), aaaand here we are. In 20.04 LTS waiting to see what can I do. Because I don't even know what's going on and who's the guilty (Nvidia? The own kernel and Nvidia together?) – Noctis May 18 '20 at 2:33
0

Not sufficient space for comment-only

-Was proposing that any difficulty appearing from 19.10 or 20.04 is not surprising given neither are final releases. Hence the fun and games you raise .

c/f potentially : (i) "I run the Ubuntu 18.04. Had that issue myself. The solution for me was to: plug all monitors to my laptop go to Settings -> Displays having only 1 display (laptop) on and 2 monitors connected but black turn on all displays by clicking their names (switching between them) and clicking the input for that" (answered Apr 8 '19 at 8:21 red777) –though imho may be fairly suspect --in comparison TO :

(ii)

With the help of this solution, I realized it is just a matter of some basic math and xrandr commands which I will outline as simply as I can here:

Run xrandr to determine the names of your display outputs. In my case, I have:

eDP-1 (Internal) DP-2-2 (External, Dell 1920x1080) DP-2-1 (External, Eizo 1280x1024, rotated to the right) Calculate the full size of your framebuffer --fb, in my case, I want to use only my external displays:

diagram

First clear/rest xrandr settings

xrandr -s 0 Then turn off the laptop display

xrandr --output eDP-1 --off Then position the primary display to 0x0, set as --primary and set panning to its own resolution:

xrandr --output DP-2-1 --auto --scale 1x1 --pos 0x0 --primary --panning 1920x1080 Then position the second screen to the right at 1920x0, set the framebuffer and rotate it accordingly:

xrandr --output DP-2-2 --auto --scale 1x1 --pos 1920x0 --fb 2944x1280 --right-of DP-2-1 --rotate left Popping these lines into a script I run after docking helps set everything up, and it resets back to the internal LCD when I remove it. 18.04 Multiple monitor issues ???

1
  • That's a lot of work with each monitor I have to connect (being a laptop I need to connect to differents). But I understand what you mean. But...this workaround works if xrandr doesn't detect the monitor, right? But my laptop and xrandr detects it. Yeah, 19.10 to 20.04 have some fails sometimes between non-LTS and LTS, but on 19.10 it wasn't working, so... – Noctis May 21 '20 at 19:10
0

Finally I found the answer. It's something related to the kernel and the GPU Intel (it's a hybrid) since 4.16/4.17 version. So let's say it's a "bug".

More info: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1871721

https://gitlab.freedesktop.org/drm/intel/-/issues/2181

Not the answer you're looking for? Browse other questions tagged or ask your own question.