11

After upgrading to Ubuntu 20.04 today I found that my monitor configuration is not working properly any more. I have a 4k primary display in landscape and a 1080p secondary display in portrait (right) mode next to it on the right. I have an ATO GTX 950 videocard to power them both.

After upgrading from 19.10 to 20.04 I fond that panel (that I use on top using 'dash to panel' extension was partially on second monitor. Also windows are weirldy displayed partially across both screens in some circumstances. After more investigation I found that when I go to the second screen and move mouse cursor to right there seems to be more desktop there and the whole desktop shifts. Itś almost like the desktop is too wide for the screens.

If I change second monitor to "normal" landscape orientation the panel shifts back fully to my primary monitor (instead of being partially on primary and partially on secondary) and all works normally (except that I cant use portait mode which I want to do and always could do before. When I "move" second monitor to left or above secondary primary monitor in display settings everything also looks and behaves normal (also in portrait) only the my mouse movements become illogical (I have to move cursor left off primary screen to get to monitor on the right.

Anybody have a clue what to do about this (except for possible bugfix in Ubuntu or display driver)?

9
  • Refer askubuntu.com/help/on-topic where you'll notice only supported releases of Ubuntu and flavors are on-topic for this site. For focal fossa [20.04] questions you'll need to use a development support site such as IRC (#ubuntu+1) or Ubuntu Forums, or wait until after release for this site (expected release date for Ubuntu 20.04 is late 23rd April 2020 when your question will be on-topic here).
    – guiverc
    Apr 23 '20 at 10:43
  • 2
    23rd April is... today, isn't it ?
    – alci
    Apr 23 '20 at 10:50
  • 1
    I'm also having this issue. Using two 1440p 144Hz monitors connected via DP and a GTX 1660 Ti. Whenever I try to set one of the monitors to portrait, or enable fractional scaling on one of them, it resets both to landscape, with no fractional scaling, running at 60Hz.
    – Matt
    May 2 '20 at 15:29
  • 1
    For what it's worth, I'm not only having this issue on Ubuntu (GNOME and KDE flavors, though they mess up in different ways, but on POP_Os and Manjaro. Something is way wrong somewhere, and I think it must be to do with Nvidia, as everyone with this issue seems to use one of their cards. Thing is, it doesn't even matter which driver I use.
    – 2-bits
    May 2 '20 at 22:53
  • Ubuntu 20.04, RTX 2060 Super with Nvidia drivers, XV273K and PG278Q. Can't enable portrait mode whatsoever, even with only one monitor connected. It either just switches back to landscape or goes into "No signal" black screen mode. I could enable portrait mode with arandr, but then I couldn't get more than 60 Hz. Everything works as expected in Windows 10 by the way. May 4 '20 at 17:06
5

I can't enable portrait mode at all for any of my monitors in the display settings. (arandr kind of works, but limits me to 60 Hz.)

However, turns out I can do it in the Nvidia Control Panel or with xrandr. Maybe, as a workaround, you could put something like this in a startup script:

xrandr --output DP-0 --rotate left

You would have to replace DP-0 with whatever output your secondary monitor is connected to, of course.

Specs for reference:

  • OS: Ubuntu 20.04 Beta
  • GPU: RTX 2060 Super
  • Driver: Nvidia 440.64
  • Monitor 1: Acer XV273K
  • Monitor 2: Asus PG278Q
3
  • I also had this problem after upgrading to 20.04 using an nvidia card. Using the Nvidia settings directly to rotate the monitor worked, thanks! This answer is better than xrandr, is does not have the limitation xrandr does.
    – tdimmig
    May 13 '20 at 13:50
  • Does this workaround allow you to set the monitor to portrait mode while keeping a refresh rate above 60 Hz? Some users elsewhere in this question reported issues using tools like arandr to set it to portrait mode, where it reset back down to 60 Hz.
    – Matt
    Oct 20 '20 at 2:01
  • arandr limits me to 60 Hz, but xrandr doesn't. nvidia-settings --assign with Rotation=90 also works fine. Oct 20 '20 at 14:53
4

I was able to work around this by using sudo apt install arandr

running arandr in terminal and then changing the monitor orientation there.

2
  • Kind of worked for me in the sense that I could use portrait mode at all, but I couldn't find any way to go above 60 Hz with this workaround. Monitors are XV273K and PG278Q, both of which I usually run at 120 Hz. May 4 '20 at 17:04
  • This worked for me. Sad that it is needed..
    – advance512
    May 25 '20 at 18:27
1

Simon Alling's answer worked for me but this is the way I persisted configuration across reboots and user sessions. I saved the xrandr command to a file '~/.config/autostart/setup_monitor_display.desktop', made it executable with chmod +x.

# Wait until GUI is ready
X-GNOME-Autostart-Delay=1
xrandr --output DP-0 --rotate left

Then I added the execution of the script to the startup application list.

  1. Open Startup Application Preferences
  2. Click Add
  3. Fill in the name and comment
  4. For command do something like sh -c '~/.config/autostart/setup_monitor_display.desktop'

Based off the answer here: https://askubuntu.com/a/1230863/1152625

0

I post a solution in the other thread: https://askubuntu.com/a/1247763/206776, repost here:

First, we create a ~/.config/monitors.xml file for the layout (we can experiment a layout with xrandr). My monitors.xml is attached below.

Then, copy the monitors.xml to /var/lib/gdm3/.config/ and change file owner:

sudo cp ~/.config/monitors.xml /var/lib/gdm3/.config/
sudo chown gdm:gdm /var/lib/gdm3/.config/monitors.xml

The monitor layout will persist across restarts and screen locks.

0

I had a similar problem with 20.04 LTS and seems like i solved it... I have a horizontal 4k monitor in the middle with 2 vertical 1080p monitors on the sides, with a GTX 2080 Ti. The desktop area was somehow larger than each screen, so it would scroll when my mouse went to the edge. I went to NVIDIA X Server Settings where you can actually see the desktop area versus screen size. I then clicked on each screen and moved the Underscan bar back and forth which made the extra desktop area disappear. Now everything looks normal... let's hope it lasts a reboot.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.