0

My ethernet connection is quite unreliable (It uses powerline adapters) so I bought an external wifi adapter. I have plugged it in and run the command sudo ip address add 192.168.0.39/24 brd + dev enp7s0, and KDE has detected it. Unfortunately, it doesn't seem to realise it is a wireless network and therefore needs credentials. Where I could normally find a place to enter credentials (the network widget, system settings) there are none. KDE reports that the device is connected in the UI. How do I make it work out that it is wireless and therefore needs credentials?

Edit:

With ethernet plugged out, (USB) adapter plugged in:

$ ip address show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp7s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN group default qlen 1000
    link/ether 04:d9:f5:8a:f5:e0 brd ff:ff:ff:ff:ff:ff

With ethernet plugged in, adapter plugged in:

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp7s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether 04:d9:f5:8a:f5:e0 brd ff:ff:ff:ff:ff:ff
    inet 192.168.0.51/24 brd 192.168.0.255 scope global dynamic noprefixroute enp7s0
       valid_lft 863988sec preferred_lft 863988sec
    inet6 fe80::7eb1:eca2:96a0:fe5c/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever

With just ethernet:

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp7s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether 04:d9:f5:8a:f5:e0 brd ff:ff:ff:ff:ff:ff
    inet 192.168.0.51/24 brd 192.168.0.255 scope global dynamic noprefixroute enp7s0
       valid_lft 863960sec preferred_lft 863960sec
    inet6 fe80::7eb1:eca2:96a0:fe5c/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever

With nothing:

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp7s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN group default qlen 1000
    link/ether 04:d9:f5:8a:f5:e0 brd ff:ff:ff:ff:ff:ff

lsusb, adapter plugged in:

Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 002: ID 046d:c31c Logitech, Inc. Keyboard K120
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 1d57:32da Xenta 2.4GHz Receiver (Keyboard and Mouse)
Bus 001 Device 004: ID 0bda:b812 Realtek Semiconductor Corp. 802.11ac NIC
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

I'm not adding it with it plugged out because it's obviously the Bus 001 Device 004: ID 0bda:b812 Realtek Semiconductor Corp. 802.11ac NIC. There were no restarts between any of these changes.

  • To start with, which Kubuntu release number is installed? Different releases have different tools for us to recommend. Please click edit and add that vital information to your question so all the facts we need are in the question. Please don't use Add Comment, since that's our channel to you. All facts about your system should go in the Question with edit – K7AAY Apr 22 at 22:43
1

First of all, enp7s0 is likely not the designation of your wireless device. enpxxx is generally reserved for ethernet devices. Find out the correct designation with:

iwconfig

If, as we expect, you find 'No Wireless Extensions' then your external device hasn't claimed a suitable driver. Is your external wireless device a USB device? If so, please edit your question to show the result of the terminal command:

lsusb

Once we have more information, I will expand this answer to show the next steps.

EDIT: Your wireless device, 0bda:b812 Realtek Semiconductor Corp. 802.11ac NIC, uses the driver 88x2bu. With a working internet connection, presumably the ethernet, open a terminal and do:

sudo apt update
sudo apt install dkms build-essential git
git clone https://github.com/cilynx/rtl88x2BU_WiFi_linux_v5.3.1_27678.20180430_COEX20180427-5959
sudo dkms add ./rtl88x2BU_WiFi_linux_v5.3.1_27678.20180430_COEX20180427-5959
sudo dkms install -m rtl88x2bu -v 5.3.1
sudo modprobe 88x2bu

Your wireless should now be working. The KDE GUI, Network Manager, should announce that wireless networks are available, show you a list and offer to connect. After you supply the requested WPA2 password, you should be all set.

| improve this answer | |
  • I have updated my question. – alex chamber Apr 22 at 21:44
  • Please see my edit above. – chili555 Apr 22 at 21:58
  • All working! Thanks for the help. – alex chamber Apr 23 at 8:47
  • I tried to install a second network and it got stuck on "configuring interface" and wouldn't connect. Now no networks work - I got it to connect for a minute or so after the restart but the ping times were about 1500ms and it disconnected shortly after. It periodically asks for passwords too. It seemed to work with just one network - is there a way to reset it? I have tried forgetting them in KDE system settings. – alex chamber Apr 23 at 9:31
  • I think that’s a subject for a new question which I will be happy to address. – chili555 Apr 23 at 11:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.