0

Thanks for your time,

I have a master and worker Microk8s cluster running in my homelab. My build doc is here; GitHub

I get no errors when running sudo microk8s.inspect

I can't even start a simple container without it going into crashloopbackoff

sudo microk8s.kubectl run http --image=katacoda/docker-http-server:latest

Pod description below;

ubuntu@MasterControl:~$ sudo microk8s.kubectl describe pod/http
Name:         http
Namespace:    default
Priority:     0
Node:         mastercontrol/192.168.123.10
Start Time:   Wed, 22 Apr 2020 15:33:41 +0000
Labels:       run=http
Annotations:  <none>
Status:       Running
IP:           10.1.39.13
IPs:
  IP:  10.1.39.13
Containers:
  http:
    Container ID:   containerd://2cb60ab4a7c25775b0b2acd5320145bf8b0f491b12fdeb32e879a68f18eb492f
    Image:          katacoda/docker-http-server:latest
    Image ID:       docker.io/katacoda/docker-http-server@sha256:76dc8a47fd019f80f2a3163aba789faf55b41b2fb06397653610c754cb12d3ee
    Port:           <none>
    Host Port:      <none>
    State:          Waiting
      Reason:       CrashLoopBackOff
    Last State:     Terminated
      Reason:       Error
      Exit Code:    1
      Started:      Wed, 22 Apr 2020 15:33:46 +0000
      Finished:     Wed, 22 Apr 2020 15:33:46 +0000
    Ready:          False
    Restart Count:  1
    Environment:    <none>
    Mounts:
      /var/run/secrets/kubernetes.io/serviceaccount from default-token-j9x8g (ro)
Conditions:
  Type              Status
  Initialized       True 
  Ready             False 
  ContainersReady   False 
  PodScheduled      True 
Volumes:
  default-token-j9x8g:
    Type:        Secret (a volume populated by a Secret)
    SecretName:  default-token-j9x8g
    Optional:    false
QoS Class:       BestEffort
Node-Selectors:  <none>
Tolerations:     node.kubernetes.io/not-ready:NoExecute for 300s
                 node.kubernetes.io/unreachable:NoExecute for 300s
Events:
  Type     Reason     Age                From                    Message
  ----     ------     ----               ----                    -------
  Normal   Scheduled  <unknown>          default-scheduler       Successfully assigned default/http to mastercontrol
  Normal   Created    15s (x2 over 18s)  kubelet, mastercontrol  Created container http
  Normal   Started    15s (x2 over 17s)  kubelet, mastercontrol  Started container http
  Warning  BackOff    13s (x2 over 14s)  kubelet, mastercontrol  Back-off restarting failed container
  Normal   Pulling    1s (x3 over 19s)   kubelet, mastercontrol  Pulling image "katacoda/docker-http-server:latest"
  Normal   Pulled     1s (x3 over 18s)   kubelet, mastercontrol  Successfully pulled image "katacoda/docker-http-server:latest"

Any help is greatly appreciated, but I'd love to know where I'm going wrong!

0

I'm going to leave this up in case anyone runs into the same problem. The issue was that I was trying to run an x86 container on an arm64 architecture. Definitely a novice mistake, but that's why I bought my pi's to begin with!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.