I'm using Ubuntu 11.10 and I've copied the wpa_supplicant configs from another computer running Ubuntu 11.10, which is connected to my home network.

The non-connecting device has an Intel wireless card which uses the ipw2100 driver and the wireless interface is called eth1. Issuing the iwlist scanning command shows that the card can see my network SSID (along with several others).

However, when I run the command:

wpa_supplicant -Dwext -ieth1 -c/etc/wpa_supplicant.conf

I get the error message:

wpa_supplicant ioctl[SIOCSIWENCODEEXT]: Invalid argument 

Any guidance on explaining this error and help in getting wpa_supplicant to work giving me connectivity to my home network would be greatly appreciated.

  • Also when issuing -italic_wpa_supplicant -Dwext -ieth1 -c/etc/wpa_supplicant.conf_italic_ I'm getting italic_Trying to associate with [My SSID etc]_italic followed by italic_ioctl[SIOCSIWFREQ]: Operation not supported_italic followed by italic_Association request to the driver failed_italic
    – Ally
    Apr 17, 2012 at 20:16
  • Welcome to Ask Ubuntu, please put the new information in your question (click edit), that way you can continually add information to your question. Apr 17, 2012 at 20:28

3 Answers 3


SOLVED: The wired interface (eth0 in my case) must be shut down otherwise it appears to disrupt the correct operation of the wireless interface (eth1 in my case) and wpa_supplicant.


I had problems with wpa_supplicant generating the same error message, ioctl[SIOCSIWENCODEEXT]:invalid argument for both of the statements in the network section of my wpa_supplicant.conf file. The line I used to invoke wpa_supplicant was:

sudo wpa_supplicant -B -iwlan0 -c/etc/wpa_supplicant.conf -Dwext

My wpa_supplicant.conf file consisted of the following:

network {
           ssid="My Wireless Network Name"
           psk="My Wireless Network Password"

I issued the wpa_supplicant command line in terminal after starting ndiswrapper and configuring wlan0 with iwconfig. After running wpa_supplicant in this way, I would get the window on my GUI asking for my passphrase. Sometimes it would accept it and close the window, sometimes it would freeze on the screen.

I was able to supply my signon info to the Wireless Network Provider using wpa_cli instead of wpa_supplicant. The line below was used:

sudo wpa_cli identity "My Wireless Network Name" password "My Wireless Network Password"

I also set up the wireless provider's info within the GUI by clicking on the network icon in the upper right of the screen and editing the wireless section.


Old question...

After struggling with this error for some time, decided to recompile wpa_supplicant with the same usage options. Same version 2.1 from

apt-get source wpasupplicant

and, with this recompiled version, no more error...

My guess is that Ubuntu default version includes some settings incompatible with the computer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.