I have a dual boot laptop with Win7 and Ubuntu 11.10. Since few days my Ubuntu does not mount automatically the win partition or a usb drive. It's also not possible to change the desktop wallpaper.

I "fixed" the win partition by hand modifying /etc/fstab. I also played a bit and now Ubuntu mount the usb drive. On the other hand I cannot unmount them because

umount: only root can unmount UUID=521832F21832D4A7 from /media/WINDOWS

But my account is admin, so I do not understand why I have this message. If I unmount with sudo from terminal there is no problem. For the wallpaper I have no error message but I can't change anything. I also tried to assign my account to "normal" user group and then back to admin group: useless.

I believe that even if my account is administrator there is something messed up with permissions. Few days ago a guest played a bit with my account and the standard guest user (he couldn't unlock as he forgot the password). I don't know if this could be the cause, but at the moment I don't understand what it could be. Thank you for your help


When you run the sudo command in the Terminal, that causes what you type after sudo to be run as root. This is why it works from the Terminal--because the technique you are using makes you act as root.

Being an administrator does not mean you are root, or that most of what you do is done as root. It does mean that you can perform actions as root with a couple of built-in facilities (one of which is sudo).

When partitions are mounted automatically from /etc/fstab, the mount operation is performed by root, so it is necessary to be root (or run a command as root) to undo it. This is the normal and expected behavior, and not a bug.

When you mount partitions dynamically as a non-root user, behind the scenes, that uses udisks --mount. Then you can unmount them automatically with udisks --unmount (which is what happens behind the scenes when you unmount them). The way you fixed your problem prevents this from happening, because /etc/fstab entries are not mounted/unmounted dynamically with udisks.

So it seems that the way you've fixed your problem does not fully suit your needs. I recommend that you post a new question detailing the problem you were experiencing, so that someone can help you make automatic, non-root mounting and unmounting of your Windows partition work again.

| improve this answer | |
  • I didn't know that fstab does its job under root (even in ubuntu where there is no root?). The udisks thing seems promising but everything worked out of the box after installation (months ago) without configuring anything. At this point I cannot use the touchpad anymore and still having the wallpaper problem. Is there a way to understand if this is a permission problem? – ray Apr 18 '12 at 14:20
  • @ray The touchpad problem is also probably a separate problem. To address your question about there being "no root" in Ubuntu: In Ubuntu, there absolutely is a root account. It just has logins disabled. Logging in as root is not supported, recommended, or necessary, because the system provides facilities like sudo to allow a non-root user to perform actions as root. The root account still does exist. Run top in the Terminal, and you'll see plenty of programs running as root as part of the system. (Press q to quit top.) – Eliah Kagan Apr 18 '12 at 15:01
  • It seems the touchpad is going away after trying to unmount the win partitions from nautilus. And now I noticed my terminal disappeared from the Launcher (i usually call it from a shortcut, that's why I didn't see it before!). I will follow your suggestion trying to split the problem in different questions even if their concurrent appearance hints, IMO, a common root cause. Thank you anyway for your information – ray Apr 18 '12 at 20:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.