0

I installed Gnome Boxes 3.28.1-1 on my Dell Precision 7530 with Ubuntu 18.04 LTS. I created a Linux Mint 19.3 virtual machine. Initially I got a "failed to start" error when I tried to start the Linux Mint VM, so I went through the extra steps described in this article to fix the Ubuntu 18.04 bug, which allowed the VM to start. The display performance was very poor, so I additionally installed the spice-tools as described in the same article.Now my Linux Mint VM machine runs great.

Installation Instructions

The problem I have been having is that the Gnome Boxes website shows a procedure for accessing a USB drive within the virtual machine that does do not work (at least for me). The instructions say to go to properties of the VM, and then turn on the USB, but all this accomplished for me was making the USB drive disappear entirely, unmounting from the Ubuntu host OS. I just found a workaround that works, but am wondering if this is the best way, and if others have had the same problem.

Solution

1) Connect the USB drive to the computer,and make sure the host OS is mounting it.

2) Within the VM, go to properties, "Devices and Shares" tab. Make sure the USB device is turned off (This is the opposite of what the Gnome site instructions say to do).

3) At the bottom of the Devices and Shares tab, under "Folder Shares", click on the little plus sign to create a shared folder. If you click on "other locations", you should shee the host file system, which would include the USB drive. Select the USBdrive, and give it a name. The path on the host OS should be shown, along with the name.

4) Within the VM, use the file explorer to browse the network, and eventually you should find the USB drive folder you created. If you click on this, it created a "Spice client folder" icon on my VM desktop.

5) Close the file explorer and just double click on the desktop icon. The external hard drive should now appear in the file explorer that pops up. It seems really buggy, which is why I listed the exact steps that worked for me. If I didn't do it that way, icons wouldn't appear and directories were missing from the file explorer.

6) I tested it, and I am now able to write and access files to the USB drive both from the host and VM.

Note: I did have to open the USB drive in superuser mode and change all the permissions to read / write for everything and everyone,... but that might have been because I had just formatted the drive.

Well, anyways, I am pretty excited to have this working, as it was the main thing standing in the way of full utility of the VM for me. Now, this setup is very nice...

If anyone has a better way to obtain this USB functionality within Gnome Boxes, please comment.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.