5

I have some issues when recording/videocalling with Logitech C270 USB webcam: my voice is high-pitched, accelerated, squeaky. The odd thing is that this happens sometimes, not always, and independently from software used (Teams, Skype, Meet, Audacity, arecord, audio-recorder, Telegram); every time it happens, I get a

usb 1-2: reset high-speed USB device number 3 using ehci-pci

in dmesg output. More information:

  • Using audio-recorder I can distinguish when my recording is going to be "bad" because time flows more slowly (a 3 s recording lasts 5-6 s);
  • I have the same problem on Kubuntu 18.04 and MX 19.1;
  • Restarting pulseaudio by

    pulseaudio -k
    pulseaudio --start
    

    sometimes fixes, sometimes not;

  • Setting -r 16000 when invoking arecord doesn't fix (I tried this since many people solved similar issues by changing default sample rate in pulseaudio settings, which I have not tried since my issue is not exactly the same);
  • The only application I had no issues with (if I remember correctly) is guvcview: when recording, anyway, dmesg complains

    uvcvideo: Failed to query (SET_CUR) UVC control 4 on unit 1: -32 (exp. 4).
    

Please ask for every piece of information you need.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.