I've been trying to set up a radio streaming device using various versions of Ubuntu, various remote servers, and different remote clients. I'm trying to remote-desktop via Windows Remote Desktop Connection to a war-horse laptop, start audio streams, and leave the audio on the remote system (to not redirect it) Right now, I'm running the Ubuntu minimal install with xrdp on the old laptop. If I launch the session from the console, I can bring up the Pulse volume control app and it will list the output device as "Built in Analog Stereo". Sessions start, audio works, everything is peachy. If I start the remote machine, leave it setting at the login prompt, and initiate a remote session, everything seems to work except for the sound. In this instance, when I bring up the Pulse volume control, it lists the output device as "Dummy Output", and no audio seems to work. What's weird is that the audio works if I start the remote machine, initiate X and log in at the console, and then exit back to the command prompt. In that instance, I can remote in and everything works fine. Something seems to get loaded by the desktop initializing at the console, and it sticks around if you log out. Does anybody know where that something is, and how I can initiated it in/from a remote session? I've tried XRDP, vino, and TightVNC with no luck. Thanks!


2 Answers 2


You do not really specify which version of Ubuntu you are running. To have sound working within xRDP session, you have to install an additional xrdp module....( that can be found at git clone https://github.com/neutrinolabs/pulseaudio-module-xrdp.git

You can check this post that explains how to install manually the xrdp sound module (see https://c-nergy.be/blog/?p=13655

If you want to, you can also try to use the latest version of the script (running on Ubuntu 16.04.x, 18.04.x,19.10.x and soon on Ubuntu 20.04) that can help automate the installation of the xRDP and ease and automate the installation of the xrdp sound module (check this link http://c-nergy.be/blog/?p=14093.

Using the script is quite straight forward (Please read the howto use it first in the post [http://c-nergy.be/blog/?p=14093] !!!)

Step 1 - Download the script

wget https://www.c-nergy.be/downloads/xrdp-installer-1.1.zip

Step 2 - Unzip it

unzip xrdp-installer-1.1.zip

Step 3 - Mark it as executable

chmod +x xrdp-installer-1.1.sh 

Step 4 - Execute the script with parameters to enable your selected options

./xrdp-installer-1.1.sh -h  (for the help)
./xrdp-installer-1.1.sh -s  (install xrdp + enable sound redirection )

If you are using Ubuntu 19.10, be aware that sometimes the sound modules does not load properly (and automatically). The following post explains the working around (https://c-nergy.be/blog/?p=14079) which basically consists of issuing the following command in the remote session

pulseaudio -k

As mentioned, a new version of the script will be published soon to include support for Ubuntu 20.04 and fix some minor issues..

Hope this help Till next time

  • 1
    Thanks for the answer. pulseaudio -k was what finally did the trick for me!
    – jaibatrik
    Jul 10, 2020 at 17:51
  • At least on Ubuntu 20, there is endless rabbit holes here. The script above doesn't work, it exits because it is the wrong version, and apt install xrdp-pulseaudio-installer fails because there are "no viable candidates". May 23, 2021 at 10:54
  • @xpusostomos, please always use the latest version of the script. script version 1.2.3 include support for Ubuntu 20.xx. Check this link (c-nergy.be/blog/?p=16817) and you will be able to implement sound redirection...hope this help
    – Griffon
    Oct 3, 2021 at 17:06

Make sure user is part of the audio group groups (username) if not add user to the audio group sudo usermod -a -G audio (username)

  • Worked just with a COPY/PASTE :) You are the captain! RHEL 9 Sep 13, 2023 at 1:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .