1

I have two languages installed: English and Russian. I have a keybind that allows me to switch between the two using Alt + Shift combination. When I run

setxkbmap -query

it used to output something like

layout: us, ru, us

I've been following this question's answer and I used this command:

setxkbmap us

and now the

setxkbmap -query

outputs

layout: us

and although I can switch between ru and en (in the top language panel in DE), I only type in english.

I can also do

setxkbmap ru

and then I'll only be able to type in russian.

I'm not sure how to go back to my previous set up - I used the GUI to set it up (Settings and Gnome Tweaks) and from what I can tell the GUI settings stayed the same - I still have the two languages.

5
  • 1
    This is expected and normal. Reboot your system and it will go back to normal as before and you can select and type in different layouts. – Raffa Apr 20 '20 at 1:34
  • @Raffa How does it work internally? Is there a .xkb file that got updated after my command? – parsecer Apr 20 '20 at 1:37
  • 2
    Yo gave it only one layout option. Give it two and it will give you two like this setxkbmap us,ru : ) – Raffa Apr 20 '20 at 1:42
  • @Raffa Thank you! That seems to have worked. I probably put a space between which gave me error. But my previous layout somewhy had three groups: us,ru,us. Why? Should I do setxkbmap us,ru,us? – parsecer Apr 20 '20 at 1:45
  • one us is enough. It will work the same way as us,ru,us both will work the same as far as I know and you can even do us,ru,us,ru,us,ru,us no difference. And it is temporary until reboot and will go back to before. – Raffa Apr 20 '20 at 1:50
1
setxkbmap -layout ru,us

Then check if the input language matches the one displayed in the gui. If not:

setxkbmap -layout us,ru

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.