8

I am using Cisco AnyConnect on Ubuntu 18.04. The VPN sometimes got disconnected unexectedly. I try to reconnect, even quit the GUI, kill all process for programs under /opt/cisco, restart NetworkManger service. No use, it still can't initiate the connection (no login dialog). What am I missing? I guess there is something with the route is not cleaned up.

Update:

I got also this message from VPNGUI after a while:

The VPN connection failed due to unsuccessful domain name resolution

This article explains something about external DNS. I cleaned that up, and checked DNS information in Ehternet setting. Still couldn't get rid of the error.

Update 2:

This is the command that worked for me at last:

systemctl restart systemd-resolved.service
2
  • Please don't put the answer (Update 2) inside the question. You are encouraged to write your own solution as your own answer. Whether write your answer or not, accept the correct answer by clicking on the gray check mark next to the answer and turning it green. This will help others and mark your problem as solved.
    – user68186
    May 8, 2020 at 18:16
  • @user68186 whatever, his update solved my problem so who cares.
    – 6infinity8
    Apr 17, 2021 at 11:46

0

You must log in to answer this question.

Browse other questions tagged .