0
dpkg -i /root/Downloads/google-chrome-stable_current_amd64.deb
Selecting previously unselected package google-chrome-stable:amd64.
(Reading database ... 66306 files and directories currently installed.)
Preparing to unpack .../google-chrome-stable_current_amd64.deb ...
Unpacking google-chrome-stable:amd64 (81.0.4044.113-1) ...
dpkg: dependency problems prevent configuration of google-chrome-stable:amd64:
 google-chrome-stable:amd64 depends on libappindicator3-1.
 google-chrome-stable:amd64 depends on libasound2 (>= 1.0.16).
 google-chrome-stable:amd64 depends on libatk-bridge2.0-0 (>= 2.5.3).
 google-chrome-stable:amd64 depends on libatk1.0-0 (>= 2.2.0).
 google-chrome-stable:amd64 depends on libatspi2.0-0 (>= 2.9.90).
 google-chrome-stable:amd64 depends on libc6 (>= 2.16).
 google-chrome-stable:amd64 depends on libcairo2 (>= 1.6.0).
 google-chrome-stable:amd64 depends on libcups2 (>= 1.4.0).
 google-chrome-stable:amd64 depends on libdbus-1-3 (>= 1.5.12).
 google-chrome-stable:amd64 depends on libdrm2 (>= 2.4.38).
 google-chrome-stable:amd64 depends on libexpat1 (>= 2.0.1).
 google-chrome-stable:amd64 depends on libgbm1 (>= 8.1~0).
 google-chrome-stable:amd64 depends on libgcc1 (>= 1:3.0).
 google-chrome-stable:amd64 depends on libgdk-pixbuf2.0-0 (>= 2.22.0).
 google-chrome-stable:amd64 depends on libglib2.0-0 (>= 2.39.4).
 google-chrome-stable:amd64 depends on libgtk-3-0 (>= 3.9.10).
 google-chrome-stable:amd64 depends on libnspr4 (>= 2:4.9-2~).
 google-chrome-stable:amd64 depends on libnss3 (>= 2:3.22).
 google-chrome-stable:amd64 depends on libpango-1.0-0 (>= 1.14.0).
 google-chrome-stable:amd64 depends on libpangocairo-1.0-0 (>= 1.14.0).
 google-chrome-stable:amd64 depends on libx11-6 (>= 2:1.4.99.1).
 google-chrome-stable:amd64 depends on libx11-xcb1.
 google-chrome-stable:amd64 depends on libxcb-dri3-0.
 google-chrome-stable:amd64 depends on libxcb1 (>= 1.6).
 google-chrome-stable:amd64 depends on libxcomposite1 (>= 1:0.3-1).
 google-chrome-stable:amd64 depends on libxcursor1 (>> 1.1.2).
 google-chrome-stable:amd64 depends on libxdamage1 (>= 1:1.1).
 google-chrome-stable:amd64 depends on libxext6.
 google-chrome-stable:amd64 depends on libxfixes3 (>= 1:5.0).
 google-chrome-stable:amd64 depends on libxi6 (>= 2:1.2.99.4).
 google-chrome-stable:amd64 depends on libxrandr2 (>= 2:1.2.99.3).
 google-chrome-stable:amd64 depends on libxrender1.
 google-chrome-stable:amd64 depends on libxss1.
 google-chrome-stable:amd64 depends on libxtst6.

dpkg: error processing package google-chrome-stable:amd64 (--install):
 dependency problems - leaving unconfigured
Processing triggers for desktop-file-utils (0.23-1ubuntu3) ...
Processing triggers for mime-support (3.60ubuntu1) ...
Processing triggers for man-db (2.8.3-2) ...
Errors were encountered while processing:
 google-chrome-stable:amd64
  • Hello, please try sudo apt instead of dpkg. That should solve it! – Sambhav Surana Apr 18 at 16:45
  • Why have you downloaded Google Chrome in /root/Downloads? Which version of Ubuntu are you using? – Kulfy Apr 18 at 17:32
  • installing dependencies of chromiun (which have the same dependecies as chrome) – bac0n Apr 18 at 19:33
0

first of all, make sure you are in your .deb folder, then, try to reconfigure all dpkg config files and programs running this:

dpkg-reconfigure --all

Then, run this to install dependencies

apt install -f

Next, you should be able to install chrome .deb file

dpkg -i /root/Downloads/google-chrome-stable_current_amd64.deb

If you get another error, just install chrome via apt, following this steps: First of all, add google repo:

wget -q -O - https://dl-ssl.google.com/linux/linux_signing_key.pub | sudo apt-key add - 

Then,

sudo sh -c 'echo "deb https://dl.google.com/linux/chrome/deb/ stable main" >> /etc/apt/sources.list.d/google.list'

and finally:

apt update && apt install google-chrome-stable -y

That should be enough.

| improve this answer | |
0

dpkg -i doesn't do any automatic dependency resolution. Try running this command which automatically installs all the dependencies required to install Chrome along with Chrome itself.

sudo apt install ./root/Downloads/google-chrome-stable_current_amd64.deb  

If the location at the end of the command is your root account and not your normal user account, please copy or move google-chrome-stable_current_amd64.deb to your normal user's Downloads directory and run the command from there.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.