1

i'm running Ubuntu Server 18.04.4 LTS

I'm able to ping 1.1.1.1 and 8.8.8.8 etc. but cannot ping domainnames.
I tried many things but i can't seem to solve this issue. therefore i'm not able to update my system.

few things I discovered:

  • I have no /etc/resolv.conf file
  • I have no /etc/network/interfaces/ file
  • /etc/NetworkManager/NetworkManager.conf shows dns=default
  • systemd-resolve --status shows 1.1.1.1 as DNS
  • My netplan configuration shows

    network:
      ethernets:
        enp6s0:
          dhcp4: yes
    version: 2
    

Can someone help me? Or give me some clues?

  • 2
    /etc/network/interfaces is not used with netplan so don't worry about that. Otherwise You are missing a symlink to /run/resolvconf/resolv.conf . See this askubuntu.com/questions/872614/… – Stephen Boston Apr 17 at 23:15
  • To start with, which version of Linux have you installed (Ubuntu server, Ubuntu desktop, Kubuntu, Lubuntu, Xubuntu, Ubuntu MATE, et al.) , and which release number? Different releases have different tools for us to recommend. Please click edit and add that vital information to your question so all the facts we need are in the question. Please don't use Add Comment, since that's our channel to you. All facts about your system should go in the Question with edit – K7AAY Apr 17 at 23:27
  • i've added the version of linux to my post. @StephenBoston tried to make a simlink, did it following the URL you send me, but still the same problem now – Maik Verheijen Apr 18 at 22:11
  • ls -l /etc/resolv.conf' and cat /etc/resolv.conf' – Stephen Boston Apr 19 at 0:47
  • 'ls -l /etc/resolv.conf' gives me: /etc/resolv.conf -> /run/resolvconf/resolv.conf and 'cat /etc/resolv.conf'' gives me: cat: /etc/resolv.conf: No such file or directory. i think pihole installation and deinstallation messed up my system somehow. really don'' t want to reinstall ubuntu but i think i have no choice. – Maik Verheijen Apr 19 at 16:32
0

I've fixed the issue, don't really know how but i wanted to share: I did a 'dpkg-reconfigure cloud-init' and now it works!

Thanks for your help all!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.