0

I just installed Xubuntu 19.10. I like Linux and most things work great, but I can never get Windows networking to work.

When I open the File Manager it has a Browse Network page listed under NETWORK. On that page is a single icon: Windows Network. When I double click that I get an error saying "Failed to open "Windows Network".: Failed to retrieve share list from server: No such file or directory." - an unhelpful message giving no indication what's wrong or how to proceed.

How can I get this to work? I have Googled the problem, but everything I find is about:

  • Hosting files on Linux via Windows networking - I'm not interested in that
  • Various other ways of connecting to Windows shares (Gigolo, smbclient, etc.) - I'm not interested in that either (and in fact I can connect to shares using Gigolo); I'd like to get this UI to work

There are no other Windows machines on the network, but there is a Synology NAS which it should see at the very least, as well as a printer. When running Windows on this same machine network browsing works fine and it sees those. The fact that I can connect to shares using Gigolo must mean that the basic dependencies and configuration are present.

  • 1
    Have you installed smbclient? That is necessary to access Windows networks. – Jos Apr 17 at 16:38
  • @Jos No. How do you know that? Where is that documented? – Pepijn Schmitz Apr 17 at 16:54
  • @Jos I have now installed it but unfortunately it makes no difference. I still get the same error. – Pepijn Schmitz Apr 17 at 16:54
  • What if you go to "Other locations" in the File Manager, then on the bottom connect to your NAS? You need to specify smb://ip-address-of-nas. – Jos Apr 17 at 17:36
  • @Jos As I stated in the question: this question is about getting this UI to work. I know I can connect to Windows shares in other ways. – Pepijn Schmitz Apr 17 at 18:22
0

Note: I do not have your NAS but I have assisted those that do and this is from my notes:

but there is a Synology NAS which it should see at the very least

It should see it automatically and not under Windows Network but under Browse Network directly but you have to tell Synology to do that. In the Control Panel > File Sharing > File Services > Advanced > Bonjour > Select Enable Bonjour service discovery

Bonjour allows Mac users to discover the NAS in their file manager automatically. Bonjour in Linux is called Avahi and it does the exact same thing. The only thing you need to do on the Linux side is make sure avahi is running:

sudo service avahi-daemon status

If for some reason it's not running start it:

sudo service avahi-daemon start
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.