2

I'm having this exact issue: How to exit emergency mode and boot to default mode?

When Ubuntu is booting, an fstab entry fails to boot, causing it to enter Emergency Mode. However, this is just because sometimes that drive is either removed or unavailable momentarily (Its an external drive for all of the movies for my plex server, and sometimes the system does one of its scheduled reboots while the drive is removed).

The drive is not important for the system to run. Because this is a server, I would like for it to just wait 10 seconds then try and boot again, to disable emergency mode altogether, or, if possible, tell fstab to not go into emergency mode for that specific drive. Otherwise, I have to go over to the server, dig it out, plug in a keyboard and sometimes a display, just to make it boot. Is this possible?

1
  • I don't understand why this was downvoted...
    – Mark Deven
    Apr 17 '20 at 16:44
4

Add the nofail-option to the mount options in your fstab-line.

From man fstab:

nofail     do not report errors for this device if it does not exist

With the nofail-option added you will be able to boot successfully whether the removable drive is connected or not.

1
  • Wonderful, thank you!
    – Mark Deven
    Apr 17 '20 at 16:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.